<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.mtairynews.com/xmlrpc.php" />
<title>Badgett, Moxley receive top honors | Mt. Airy News</title>

<!-- The SEO Framework by Sybre Waaijer -->
<meta name="description" content="North Surry High School selected two three-sport student athletes in the class of 2020 as recipients of the school’s top athletic awards." />
<meta property="og:image" content="https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_DSC_0064e.jpg" />
<meta property="og:image:width" content="604" />
<meta property="og:image:height" content="640" />
<meta property="og:image:alt" content="Nick Badgett was named the 2019-20 Ron King Male Student Athlete of the Year for his accomplishments in football, basketball and baseball.
                                 Cory Smith | The News" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Badgett, Moxley receive top honors | Mt. Airy News" />
<meta property="og:description" content="North Surry High School selected two three-sport student athletes in the class of 2020 as recipients of the school’s top athletic awards." />
<meta property="og:url" content="https://www.mtairynews.com/sports/87403/badgett-moxley-receive-top-honors" />
<meta property="og:site_name" content="Mt. Airy News" />
<meta property="article:publisher" content="https://www.facebook.com/pages/The-Mount-Airy-News/120821418072" />
<meta property="article:published_time" content="2020-06-04T01:57+00:00" />
<meta property="article:modified_time" content="2020-06-04T01:57+00:00" />
<meta property="og:updated_time" content="2020-06-04T01:57+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@mountairynews" />
<meta name="twitter:title" content="Badgett, Moxley receive top honors | Mt. Airy News" />
<meta name="twitter:description" content="North Surry High School selected two three-sport student athletes in the class of 2020 as recipients of the school’s top athletic awards." />
<meta name="twitter:image" content="https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_DSC_0064e.jpg" />
<meta name="twitter:image:width" content="604" />
<meta name="twitter:image:height" content="640" />
<meta name="twitter:image:alt" content="Nick Badgett was named the 2019-20 Ron King Male Student Athlete of the Year for his accomplishments in football, basketball and baseball.
                                 Cory Smith | The News" />
<link rel="canonical" href="https://www.mtairynews.com/sports/87403/badgett-moxley-receive-top-honors" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.mtairynews.com/","name":"Mt. Airy News"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.mtairynews.com/category/sports","name":"Sports"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.mtairynews.com/sports/87403/badgett-moxley-receive-top-honors","name":"Badgett, Moxley receive top honors"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 0.29ms meta | 0.62ms boot -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mt. Airy News &raquo; Feed" href="https://www.mtairynews.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Mt. Airy News &raquo; Comments Feed" href="https://www.mtairynews.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Mt. Airy News &raquo; Badgett, Moxley receive top honors Comments Feed" href="https://www.mtairynews.com/sports/87403/badgett-moxley-receive-top-honors/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s24476.pcdn.co\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://s24476.pcdn.co/wp-includes/css/dist/block-library/style.min.css?ver=5.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='simple-staff-list-css'  href='https://s24476.pcdn.co/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='staff-list-custom-css-css'  href='https://s24476.pcdn.co/wp-content/themes/mh-magazine/simple-staff-list-custom.css?ver=5.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='vfb-pro-css'  href='https://s24476.pcdn.co/wp-content/plugins/vfb-pro/public/assets/css/vfb-style.min.css?ver=2019.05.10' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://s24476.pcdn.co/wp-includes/css/dashicons.min.css?ver=5.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://s24476.pcdn.co/wp-content/themes/mh-magazine/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://s24476.pcdn.co/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=PT+Sans:300,400,400italic,600,700%7cMerriweather:300,400,400italic,600,700' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3'></script>
<link rel='https://api.w.org/' href='https://www.mtairynews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mtairynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s24476.pcdn.co/wp-includes/wlwmanifest.xml" /> 
<link rel="alternate" type="application/json+oembed" href="https://www.mtairynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F87403%2Fbadgett-moxley-receive-top-honors" />
<link rel="alternate" type="text/xml+oembed" href="https://www.mtairynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F87403%2Fbadgett-moxley-receive-top-honors&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.9.0" /><style type="text/css">
.mh-header { background: #022452; }
.mh-widget-layout4 .mh-widget-title { background: #022452; background: rgba(2, 36, 82, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #022452; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #022452; }
.mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #022452; }
</style>
<!--[if lt IE 9]>
<script src="https://s24476.pcdn.co/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "PT Sans", sans-serif; }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-6471856723304346",
enable_page_level_ads: true,
tag_partner: "site_kit"
});
</script>
		<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e0e0e0; }
</style>
	<link rel="icon" href="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-32x32.png" sizes="32x32" />
<link rel="icon" href="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-180x180.png" />
<meta name="msapplication-TileImage" content="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.mh-widget-title {
	background-color: #022452 !important;
}

.mh-header-nav li a {
    padding: 0 19px !important;
}

.attachment-mh-magazine-slider{
height: 300px !important;
width: auto !important;
}
.metaInfo{
	display:none;
}

.class1 img {
	display: block;
	margin: auto;
	float: none !important;
}

@media screen and (min-width: 1125px) {

.mh-col-1-3 {
    width: 27% !important;
}

.mh-col-2-3 {
    width: 70% !important;
}

}

@media screen and (max-width: 1124px) {

.mh-col-1-3 {
    width: 30%;
		min-width: 300px;
		margin: auto !important;
		float: none;
}

.mh-col-2-3 {
    width: 100%;
		margin: auto !important;
}

}

.mh-googleplus{
	display:none;
}
.mh-posts-large-thumb{
	background-color:black;
}
.mh-posts-large-thumb img{
	width:auto !important;
}
.mh-main-nav li a {
    padding: 10px 18px;
}

.google-auto-placed {
	display: none;
}		</style>
		<style type="text/css"></style>
<script async="async" src="//zdwidget3-bs.sphereup.com/zoomd/SearchUi/Script?clientId=05916537"></script>
</head>
<body data-rsssl=1 id="mh-mobile" class="post-template-default single single-post postid-87403 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout5" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-header-menu-container"><ul id="menu-header-menu" class="menu"><li id="menu-item-65282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65282"><a href="http://yourjobmatchnc.thejobnetwork.com/">Jobs</a></li>
<li id="menu-item-65270" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65270"><a href="https://www.mtairynews.com/e-edition">E-Edition</a></li>
<li id="menu-item-65271" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65271"><a href="https://www.mtairynews.com/classifieds">Classifieds</a></li>
<li id="menu-item-65272" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65272"><a href="https://www.mtairynews.com/subscribe">Subscribe</a></li>
<li id="menu-item-65273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65273"><a href="https://www.mtairynews.com/sign-up-for-notices">Sign Up For Notices</a></li>
<li id="menu-item-65285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65285"><a href="https://play.google.com/store/apps/details?id=com.vervewireless.droid.mtairynews&#038;hl=en">Android App</a></li>
<li id="menu-item-65286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65286"><a href="https://itunes.apple.com/us/app/the-mount-airy-news/id1378553829?ls=1&#038;mt=8">iOS App</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-social-container"><ul id="menu-social" class="menu"><li id="menu-item-65280" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65280"><a href="https://www.facebook.com/pages/The-Mount-Airy-News/120821418072"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-65281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65281"><a href="https://twitter.com/mountairynews"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://www.mtairynews.com/" class="custom-logo-link" rel="home"><img width="374" height="36" src="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews.png" class="custom-logo" alt="Mt. Airy News" srcset="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews.png 374w, https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews-300x29.png 300w" sizes="(max-width: 374px) 100vw, 374px" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-10" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="5" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins><script src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script>
</div></div></aside>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-37973" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-37973"><a href="https://www.mtairynews.com">Home</a>
<ul class="sub-menu">
	<li id="menu-item-38363" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38363"><a href="https://www.mtairynews.com/contact-us">Contact Us</a></li>
	<li id="menu-item-38364" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38364"><a href="https://www.mtairynews.com/about-us">About Us</a></li>
	<li id="menu-item-38368" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38368"><a href="https://www.mtairynews.com/advertise">Advertise</a></li>
	<li id="menu-item-38412" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38412"><a href="http://www.facebook.com/pages/The-Mount-Airy-News/120821418072">Mount Airy News on Facebook</a></li>
	<li id="menu-item-40794" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40794"><a href="https://twitter.com/mountairynews">Mount Airy News on Twitter</a></li>
	<li id="menu-item-38414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38414"><a href="https://www.mtairynews.com/sign-up-for-notices">Sign Up For Notices</a></li>
	<li id="menu-item-38415" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38415"><a href="https://www.mtairynews.com/reader-services">Reader Services</a></li>
	<li id="menu-item-38413" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38413"><a href="https://www.mtairynews.com/subscribe">Subscribe</a></li>
	<li id="menu-item-77699" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77699"><a href="https://www.mtairynews.com/terms-of-use">Terms Of Use</a></li>
</ul>
</li>
<li id="menu-item-37963" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37963"><a href="https://www.mtairynews.com/category/news">News</a>
<ul class="sub-menu">
	<li id="menu-item-38369" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38369"><a href="https://www.mtairynews.com/archives">Archive</a></li>
	<li id="menu-item-38370" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38370"><a href="https://www.mtairynews.com/circulars">Circulars</a></li>
	<li id="menu-item-56100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56100"><a href="https://www.mtairynews.com/category/special-sections">Special Sections</a></li>
	<li id="menu-item-38371" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38371"><a href="https://www.mtairynews.com/online-community">Online Community</a></li>
	<li id="menu-item-38373" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38373"><a href="https://www.mtairynews.com/subscribe">Subscribe</a></li>
	<li id="menu-item-38375" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38375"><a href="https://www.mtairynews.com/formnewstip">Submit News Tip</a></li>
	<li id="menu-item-38376" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38376"><a href="https://www.mtairynews.com/onlineforms">Online Forms</a></li>
	<li id="menu-item-38416" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38416"><a href="https://www.mtairynews.com/feed">All Articles Feed</a></li>
</ul>
</li>
<li id="menu-item-37965" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-37965"><a href="https://www.mtairynews.com/category/sports">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-38377" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38377"><a href="https://www.mtairynews.com/formscores">Submit Scores</a></li>
	<li id="menu-item-38378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38378"><a href="https://www.mtairynews.com/formsportsnews">Submit Sports News</a></li>
	<li id="menu-item-43456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43456"><a href="http://pro32.ap.org/mtairynews">Pro32</a></li>
	<li id="menu-item-43458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43458"><a href="http://racing.ap.org/mtairynews">Auto Racing</a></li>
	<li id="menu-item-43459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43459"><a href="http://collegebasketball.ap.org/mtairynews">College Basketball</a></li>
	<li id="menu-item-43460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43460"><a href="http://collegefootball.ap.org/mtairynews">College Football</a></li>
</ul>
</li>
<li id="menu-item-37967" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37967"><a href="http://www.legacy.com/obituaries/mtairynews">Obituaries</a></li>
<li id="menu-item-37964" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37964"><a href="https://www.mtairynews.com/category/opinion">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-38379" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38379"><a href="https://www.mtairynews.com/formeditor">Send A Letter To The Editor</a></li>
</ul>
</li>
<li id="menu-item-37966" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37966"><a href="https://www.mtairynews.com/category/features">Features</a>
<ul class="sub-menu">
	<li id="menu-item-38380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38380"><a href="https://www.mtairynews.com/contests">Contests</a></li>
	<li id="menu-item-38382" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38382"><a href="https://www.mtairynews.com/comics">Comics</a></li>
	<li id="menu-item-38383" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38383"><a href="https://www.mtairynews.com/horoscopes">Horoscopes</a></li>
	<li id="menu-item-63246" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63246"><a href="https://www.mtairynews.com/category/special-sections">Special Sections</a></li>
	<li id="menu-item-38385" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38385"><a href="https://www.mtairynews.com/formanniversary">Submit Anniversary</a></li>
	<li id="menu-item-38386" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38386"><a href="https://www.mtairynews.com/formbirth">Submit Birth</a></li>
	<li id="menu-item-38387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38387"><a href="https://www.mtairynews.com/formbirthday">Submit Birthday</a></li>
	<li id="menu-item-38388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38388"><a href="https://www.mtairynews.com/formengagement">Submit Engagement</a></li>
	<li id="menu-item-38389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38389"><a href="https://www.mtairynews.com/formwedding">Submit Wedding</a></li>
</ul>
</li>
<li id="menu-item-37968" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37968"><a href="https://www.mtairynews.com/calendar">Events</a></li>
<li id="menu-item-37969" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-37969"><a href="https://www.mtairynews.com/entertainment">TV/Games</a>
<ul class="sub-menu">
	<li id="menu-item-82825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-82825"><a href="https://www.mtairynews.com/games">Games</a></li>
	<li id="menu-item-38434" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38434"><a href="https://www.mtairynews.com/tvsoaps">Soaps</a></li>
	<li id="menu-item-39181" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39181"><a href="https://www.mtairynews.com/tvbestbets">TV Best Bets</a></li>
	<li id="menu-item-38390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38390"><a href="https://www.mtairynews.com/tvbestbets">TV Best Bets</a></li>
	<li id="menu-item-38436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38436"><a href="https://www.mtairynews.com/tvmovies">Movies</a></li>
	<li id="menu-item-38391" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38391"><a href="https://www.mtairynews.com/tvlistings">TV Listings</a></li>
	<li id="menu-item-38392" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38392"><a href="https://www.mtairynews.com/tvnews">TV News</a></li>
	<li id="menu-item-38433" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38433"><a href="https://www.mtairynews.com/tvqa">Q &#038; A</a></li>
	<li id="menu-item-38437" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38437"><a href="https://www.mtairynews.com/tvnews">TV News</a></li>
	<li id="menu-item-38393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38393"><a href="https://www.mtairynews.com/tvsearch">TV Search</a></li>
	<li id="menu-item-38394" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38394"><a href="https://www.mtairynews.com/tvsports">TV Sports</a></li>
	<li id="menu-item-38395" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38395"><a href="https://www.mtairynews.com/tvtalk">TV Talk</a></li>
	<li id="menu-item-38396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38396"><a href="https://www.mtairynews.com/tvvideo">TV Video</a></li>
</ul>
</li>
<li id="menu-item-39252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39252"><a href="http://local.mtairynews.com">Businesses</a>
<ul class="sub-menu">
	<li id="menu-item-86887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86887"><a href="https://opentoserveyou.mtairynews.com/">Local Businesses</a></li>
</ul>
</li>
<li id="menu-item-64582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-64582"><a href="http://www.ncpress.com/ncnotices/">Public Notices</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-date mh-header-date-bottom">
							June 4, 2020						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside zoomdSearch='{"trigger":"OnClick"}' class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://www.mtairynews.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.mtairynews.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.mtairynews.com/category/sports" itemprop="url"><span itemprop="title">Sports</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Badgett, Moxley receive top honors</nav>


<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.mtairynews.com/sports/87403/badgett-moxley-receive-top-honors"
  },
  "headline": "Badgett, Moxley receive top honors",
        "image": "https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_DSC_0064e.jpg",
     "datePublished": "2020-06-03T21:57:00-04:00",
  "dateModified": "2020-06-03T21:57:00-04:00",
  "author": {
    "@type": "Person",
	    "name": "By Cory Smith csmith@mtairynews.com"
	  },
   "publisher": {
    "@type": "Organization",
    "name": "Mt. Airy News",
    "logo": {
      "@type": "ImageObject",
      "url": "https://s24476.pcdn.co/wp-content/uploads/2015/07/mtairynews.png"
    }
  },
  "description": "
				North Surry High School selected two three-sport student athletes in the class of 2020 as recipients of the school&rsquo;s top athletic awards.
			 [...]"
}
</script>
<style>
.neFileBlock{
	display:none;
}
.metaInfo{
	display:none;
}
.entry-thumbnail img {
width: auto !important;
max-height: 400px;
}
.factbox{ 
	float:left; 
	width:190px; 
	margin:7px; 
	background-color:#f5f5f5; 
	padding:5px; 
	box-shadow: 0 10px 16px 0 rgba(0,0,0,0.2),0 6px 20px 0 rgba(0,0,0,0.19);
}
.map{ 
	float:left; 
	width:200px; 
	margin:7px; 
}
.kicker{
	font-style:italic;
}
.pullquote {
    float: left;
    width: 190px;
    background: #f5f5f5;
    font-weight: bold;
    padding: 5px;
    margin: 0 5px 5px 0;
	font-size:18px;
}
.extraBox{
	float:left; 
	width:200px;  
	margin-right:20px;
}
.breakout{
border-radius: 25px;
  border: 2px solid #c00c00;
  padding: 20px;
}

</style>
<article id="post-87403" class="post-87403 post type-post status-publish format-standard has-post-thumbnail hentry category-sports">
		<header class="entry-header clearfix"><h1 class="entry-title">Badgett, Moxley receive top honors</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.mtairynews.com/date/2020/06">June 3, 2020</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.mtairynews.com/author/csmith">Cory Smith</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.mtairynews.com/category/sports" rel="category tag">Sports</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.mtairynews.com/sports/87403/badgett-moxley-receive-top-honors#respond" class="mh-comment-count-link" ><span class="dsq-postid" data-dsqidentifier="87403 https://www.mtairynews.com/sports/87403/badgett-moxley-receive-top-honors">0</span></a></span>
</div>
				<h4 class="subhead"> <p>North Surry names Athletes of the Year</p></h4>
				
				<div id="byline" style="margin-left: 5px; margin-top: 5px;"><b> By Cory Smith csmith@mtairynews.com</b></div>
			</header>
		<div class="entry-content clearfix">
	<figure class="entry-thumbnail">
			<a href="https://www.mtairynews.com/sports/87403/badgett-moxley-receive-top-honors" alt="Badgett, Moxley receive top honors">
			<img width="604" height="640" src="https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_DSC_0064e.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Nick Badgett was named the 2019-20 Ron King Male Student Athlete of the Year for his accomplishments in football, basketball and baseball.
                                 Cory Smith | The News" srcset="https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_DSC_0064e.jpg 604w, https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_DSC_0064e-283x300.jpg 283w, https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_DSC_0064e-413x438.jpg 413w, https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_DSC_0064e-360x381.jpg 360w, https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_DSC_0064e-480x509.jpg 480w, https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_DSC_0064e-231x245.jpg 231w, https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_DSC_0064e-57x60.jpg 57w" sizes="(max-width: 604px) 100vw, 604px" />		</a>
		</figure>
																				<div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F87403%2Fbadgett-moxley-receive-top-honors&t=Badgett%2C+Moxley+receive+top+honors', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Badgett%2C+Moxley+receive+top+honors:&url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F87403%2Fbadgett-moxley-receive-top-honors', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F87403%2Fbadgett-moxley-receive-top-honors&media=https://www.mtairynews.com/wp-content/uploads/2020/06/125106581_web1_DSC_0064e.jpg&description=Badgett%2C+Moxley+receive+top+honors', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F87403%2Fbadgett-moxley-receive-top-honors', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Badgett%2C%20Moxley%20receive%20top%20honors&amp;body=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F87403%2Fbadgett-moxley-receive-top-honors" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
																		
																						<div class="extraBox">
											<a href="#" onclick="window.open('https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_72843599_1331589620298507_6114224492358139904_n.jpg','Photo','width=600,height=400')"><img src="https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_72843599_1331589620298507_6114224492358139904_n.jpg" alt="<p>Hannah Moxley was awarded North Surry&rsquo;s top athletic award, the 2019-20 Don L. Smith Female Student-Athlete of the Year, for her success in volleyball, basketball and soccer.</p>
                                 <p>Jimmy Kuhn | Special to the News</p>" style="float:left; width:200px; margin-top:3px; margin-bottom:3px"></a>
				<p>Hannah Moxley was awarded North Surry&rsquo;s top athletic award, the 2019-20 Don L. Smith Female Student-Athlete of the Year, for her success in volleyball, basketball and soccer.</p>
                                 <p>Jimmy Kuhn | Special to the News</p>								<a href="#" onclick="window.open('https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_DSC_0641.jpg','Photo','width=600,height=400')"><img src="https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_DSC_0641.jpg" alt="<p>Nick Badgett beats the North Forsyth secondary in a 2019 win for the Greyhounds.</p>
                                 <p>Cory Smith | The News</p>" style="float:left; width:200px; margin-top:3px; margin-bottom:3px"></a>
				<p>Nick Badgett beats the North Forsyth secondary in a 2019 win for the Greyhounds.</p>
                                 <p>Cory Smith | The News</p>								<a href="#" onclick="window.open('https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_87225628_2512113615669400_4321495380547076096_n--2-.jpg','Photo','width=600,height=400')"><img src="https://s24476.pcdn.co/wp-content/uploads/2020/06/125106581_web1_87225628_2512113615669400_4321495380547076096_n--2-.jpg" alt="<p>North Surry&rsquo;s Hannah Moxley settles a goal kick in the Greyhound midfield in a match earlier this year.</p>
                                 <p>Jimmy Kuhn | Special to the News</p>" style="float:left; width:200px; margin-top:3px; margin-bottom:3px"></a>
				<p>North Surry&rsquo;s Hannah Moxley settles a goal kick in the Greyhound midfield in a match earlier this year.</p>
                                 <p>Jimmy Kuhn | Special to the News</p>													
				</div>
										<p>North Surry High School selected two three-sport student athletes in the class of 2020 as recipients of the school&rsquo;s top athletic awards.</p>
<p>North Surry Athletic Director Chris Butler outlined the following criteria for the outstanding athletic awards:</p>
<p>&#8226; A senior that participated in at least one athletic program all four years</p>
<p>&#8226; Displays leadership and sportsmanship on and off the court</p>
<p>&#8226; Maintains a high level of achievement in the classroom</p>
<p>&#8226; Represents North Surry as an ambassador for all students</p>
<p>&#8226; Is the epitome of a student athlete</p>
<p><strong>2019-20 Ron King Male Student Athlete of the Year: Nick Badgett</strong></p>
<p>Nick Badgett did whatever was asked of him to get his team a win, whether that be in football, basketball or baseball. In his combined 10 seasons playing a varsity sport, his teams never missed the playoffs.</p>
<p>Nick joined the varsity football team as a sophomore and was thrust into a starting role as a receiver. He finished first in the conference in yards per reception (minimum of 25 receptions), second in the conference in yards receiving, fourth in receiving touchdowns. This was enough to earn him his first of three All-Western Piedmont 2A Conference selections. North Surry also won the WPAC Championship in 2017, the team&rsquo;s first in 17 years.</p>
<p>Badgett would lead the WPAC in receptions, yards receiving, receiving TDs and yards per reception as a junior. He nearly repeated as the conference leader in four categories as a senior. He did lead the WPAC in receptions, but finished second in yards receiving (despite surpassing the 1,000-yard mark for the first time in his career), average yards receiving and receiving TDs.</p>
<p>Badgett now holds six North Surry school records for receiving: career yards receiving (2,729), career receptions (133), career receiving TDs (29), single-season yards receiving (1,064 in 2019), single-season receptions (60 in 2019) and single-season receiving TDs (14 in 2018).</p>
<p>Football&rsquo;s record book isn&rsquo;t the one that will have Badgett in it. Nick is also the No. 12 on the North Surry all-time scoring list with 1,151 points.</p>
<p>He spent three years as a starter on the basketball team and was the only freshman pulled up to varsity during the Greyhounds&rsquo; state runner-up season in 2016-17. He joined the starting lineup as a sophomore and became a focal point of the offense. He scored 320 points that year. He took on more responsibility as a junior and averaged 19.5 points, 3.8 rebounds, 3.3 assists and 2.4 steals.</p>
<p>After two seasons of sub-.500 records, Nick helped the Greyhounds to a 16-9 record as a senior. He was surrounded by more scoring talent and was able to play as a true point guard. His scoring average dropped to 13.3, still good enough for second on the team, but he led the team in average offensive rebounds (2.1), total rebounds per game (5.0) and assists per game (4.6).</p>
<p>He passed the 1,000-point mark as a senior and was named to all-conference and all-district teams. He made the all-conference team all three years on varsity.</p>
<p>Badgett was a four-year varsity member of the Greyhounds&rsquo; baseball program and helped the team to a WPAC Tournament Championship in 2019. North Surry&rsquo;s teams finished with 50 wins over the past four years despite a shortened senior season.</p>
<p>He was selected for the WPAC All Conference team as a sophomore and junior, with a legitimate shot of three-peating with his senior season. North Surry finished as WPAC regular season runners up in 2018 and 2019. For those two years, he had a .337 batting average, a .389 on base percentage, 35 hits, 13 RBI, 26 runs and a .862 fielding percentage. Full baseball stats for his freshman and senior years were not available on MaxPreps.</p>
<p>Badgett is currently undecided on what institution he will attend but plans to major in Criminal Justice.</p>
<p>&ldquo;I cannot think of a more complete and decorated player in my 10 years at North Surry. He is a dominant competitor, and was always ready for the situation no matter how big the moment. He competed in all 3 sports at an extremely high level, and I think he is very deserving of the nomination.&rdquo; <em>&#8211;Patrick Taylor, North Surry football coach</em></p>
<p>&ldquo;Nick was an incredible athlete to coach because he has that competitive drive that every coach loves to see in their athletes. It didn&rsquo;t matter if it was sprints in practice, a free-throw competition, or a rivalry game in a packed gym, Nick was going to compete to win every time. By doing so, he also brought out the best in his teammates. One of the best attributes a leader can have is the ability to help make his teammates better and Nick was able to do that on a consistent basis through hard work, competition, and will to win. The traits that Nick demonstrated in the athletic arena will help lead him to be successful in whatever he chooses to do in the future.&rdquo; <em>-Tyler</em><em> Bentley, North Surry boys basketball coach</em></p>
<p>&ldquo;It has been my privilege and honor to coach Nick Badgett. Super skilled three sport athlete that exemplifies toughness at its best. Very competitive, confident and coachable young man that has put in the work. We congratulate Nick on his accomplishments and we wish him nothing but the best in the future.&rdquo; <em>-Tony Martin, North Surry baseball coach</em></p>
<p><strong>2019-20 Don L. Smith Female Student-Athlete of the Year: Hannah Moxley</strong></p>
<p>Hannah Moxley spent 10 of a possible 12 seasons in high school playing a varsity sport and made her presence known in each.</p>
<p>She spent four years with the volleyball program, two on JV and two on varsity. She thrived as an outside and opposite hitter. As a junior, Moxley was third on the team in kills and attacks. North Surry finished second in the WPAC regular season and conference tournament that year.</p>
<p>Statistics from her senior year are not available on MaxPreps. North Surry finished fourth in the conference with an 8-6 record.</p>
<p>Moxley was also a four-year member of the varsity basketball program where her leadership and versatility helped the Lady Hounds win 77 games.</p>
<p>She was one of two underclassmen and one of only seven overall players to play in all 32 games her freshman year. The Lady Greyhounds won 26 games in dominant fashion that year. North went perfect in conference competition to win the regular season and tournament championships in 2017. The season ended with North Surry falling in the 2A State Championship.</p>
<p>Moxley shifted from a role player to starter as a sophomore and began to show her versatility. She finished the year in the top five in average points, rebounds, assists, steals and blocks. North Surry upset the top two seeds in the conference tournament to win a second-straight WPAC Tournament Championship.</p>
<p>Hannah showed improvement in her previous year&rsquo;s performance by leading the team in four categories: defensive rebounds, assists, steals and blocks. For assists, steals and blocks she finished in the top three in the conference. She also finished second on the team and fifth in the conference in total rebounds.</p>
<p>As a senior, Moxley earned her third-consecutive All-WPAC selection and once again stuffed the stat sheet for North Surry. The Hounds reached the postseason for the fourth time in Moxley&rsquo;s career and came within a few plays of upsetting Forbush, one of the top-ranked teams in the state.</p>
<p>She finished with 672 points, 406 rebounds, 271 assists, 192 steals, and 63 blocks. She completed her career as a 3x all WPAC performer (2018, 2019, 2020)</p>
<p>Finally, Hannah was a four-year varsity member of the soccer team where she played midfield. She led the team in assists and was All-WPAC each of her first three years. She later became a team captain for the 2018, 2019, and 2020 seasons.</p>
<p>North Surry went from winning nine total games from 2013-2017 to winning 13 during the 2018 season, Moxley&rsquo;s sophomore campaign. The Hounds took third in the conference and advanced to the state playoffs for the first time in recent memory.</p>
<p>North Surry won nine games in 2019 but were set for a huge season in 2020 before the season was cancelled. The Lady Hounds were 3-0 overall and 2-0 in conference play when the season was called off.</p>
<p>Hannah Moxley will continue her basketball career with Catawba College in the fall.</p>
<p>&ldquo;Hannah Moxley is truly deserving of the Don L. Smith Outstanding Female Athlete Award. She has been a three-sport athlete for all four years who has represented North Surry on the playing field with her competitiveness, versatility, leadership, and sportsmanship. Her team and individual accomplishments are numerous and indicate the value she has brought to North Surry the past four years. In the classroom, she maintains a high level of achievement and is the epitome of the term student-athlete. I expect Hannah to continue to demonstrate these qualities and represent Catawba University and it&rsquo;s women&rsquo;s basketball program in the same way she has North Surry.&rdquo; <em>-Chris Butler, North Surry Athletic Director</em></p>
<p>&ldquo;I don&rsquo;t know anyone more deserving of this award than Mox. She&rsquo;s a phenomenal all-around athlete, great teammate and a great student. To my knowledge, she&rsquo;s the only three-time all-conference soccer player in school history and clearly would&rsquo;ve been the only one to do it four times had this season continued. That&rsquo;s special. Mox doesn&rsquo;t necessarily have the flashiest stats for soccer that a forward or offensive midfielder would because she played like a true defensive center mid. She was the difference maker a lot of times. If for some reason she had to come out for quick breather you could see a clear difference in the flow of the game. She played that big of a role and she was also that much of a leader. It also didn&rsquo;t hurt that she could throw the ball to the near post on a throw in. It&rsquo;s basically like having a corner kick and that gave us such an advantage so many times.&rdquo; <em>-Eric Jessup, North Surry soccer coach</em></p>
										<em><p>Reach Cory on Twitter @MrCoryLeeSmith</p></em>
				<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F87403%2Fbadgett-moxley-receive-top-honors&t=Badgett%2C+Moxley+receive+top+honors', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Badgett%2C+Moxley+receive+top+honors:&url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F87403%2Fbadgett-moxley-receive-top-honors', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F87403%2Fbadgett-moxley-receive-top-honors&media=https://www.mtairynews.com/wp-content/uploads/2020/06/125106581_web1_DSC_0064e.jpg&description=Badgett%2C+Moxley+receive+top+honors', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F87403%2Fbadgett-moxley-receive-top-honors', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Badgett%2C%20Moxley%20receive%20top%20honors&amp;body=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F87403%2Fbadgett-moxley-receive-top-honors" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>

	</div></article>
<nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.mtairynews.com/top-stories/87397/school-board-hears-project-update" rel="prev"><img width="80" height="53" src="https://s24476.pcdn.co/wp-content/uploads/2020/06/125107621_web1_JEFF0006_filtered-80x53.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="The new two-story school building at Dobson Elementary is starting to take shape. It is one of three projects going on at the same time as part of county government&#146;s Phase I of meeting school needs.
                                 Jeff Linville | The News" srcset="https://s24476.pcdn.co/wp-content/uploads/2020/06/125107621_web1_JEFF0006_filtered-80x53.jpg 80w, https://s24476.pcdn.co/wp-content/uploads/2020/06/125107621_web1_JEFF0006_filtered-300x200.jpg 300w, https://s24476.pcdn.co/wp-content/uploads/2020/06/125107621_web1_JEFF0006_filtered-571x381.jpg 571w, https://s24476.pcdn.co/wp-content/uploads/2020/06/125107621_web1_JEFF0006_filtered-326x218.jpg 326w, https://s24476.pcdn.co/wp-content/uploads/2020/06/125107621_web1_JEFF0006_filtered.jpg 640w" sizes="(max-width: 80px) 100vw, 80px" /><span>Previous</span><p>School board hears project update</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://www.mtairynews.com/news/87408/mount-airy-police-reports-188" rel="next"><span>Next</span><p>Mount Airy Police Reports</p></a></div>
</nav>
				<ins class="adbladeads" data-cid="35553-1462681351" data-host="web.adblade.com" data-tag-type="4" data-subid="mtairynews.com" data-protocol="https" style="display:none"></ins>
				<script async src="https://web.adblade.com/js/ads/async/show.js" type="text/javascript"></script>
				<a id="comments"></a>
				
<div id="disqus_thread"></div>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-13" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Weather</span></h4><div class="textwidget custom-html-widget"><div style="width: 300px;"><iframe style="display: block;" src="https://cdnres.willyweather.com/widget/loadView.html?id=100630" width="300" height="228" frameborder="0" scrolling="no"></iframe><a style="height: 20px;position: relative;margin: -20px 0 0 0;text-indent: -9999em;display: block;z-index: 1" href="https://mtairynews.com/weather" rel="nofollow">mount airy weekly forecast</a></div>

<ins data-revive-zoneid="10" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-31" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><p>
<ins data-revive-zoneid="125" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p><p>
<ins data-revive-zoneid="126" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p></div></div><div id="custom_html-2" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="1" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-4" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="2" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-15" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="97" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-22" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Circulars</span></h4><div class="textwidget custom-html-widget">
<ins data-revive-zoneid="119" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
<script async src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script></div></div><div id="custom_html-29" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">National Video</span></h4><div class="textwidget custom-html-widget"><div class="inform-embed"  data-type="VideoLauncher/Slider" data-tracking-group="92955"></div>
<script type="text/javascript">_informq.push(['embed']); vid.muted = true;</script>
<script src="https://launch.inform.com/js/embed.js"></script></div></div><div id="custom_html-17" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="112" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-6" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="3" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-24" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Poll</span></h4><div class="textwidget custom-html-widget"><script type="text/javascript" src="https://www.civicscience.com/widget/jspoll/?elt=130efe3f-8872-9e24-3d0a-f08413db6479&amp;tgtid=0ea95aa6-abf0-e1a4-91f4-4a6b1d2e6b5e"></script>
<div id="130efe3f-8872-9e24-3d0a-f08413db6479"></div></div></div><div id="custom_html-8" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="4" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins></div></div>	</aside>	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-2 mh-widget-col-2 mh-footer-2-cols  mh-footer-area mh-footer-1">
<div id="media_image-2" class="mh-footer-widget widget_media_image"><a href="https://mtairynews.com"><img width="300" height="29" src="https://s24476.pcdn.co/wp-content/uploads/2018/09/mtairynews-300x29.png" class="image wp-image-65276  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://s24476.pcdn.co/wp-content/uploads/2018/09/mtairynews-300x29.png 300w, https://s24476.pcdn.co/wp-content/uploads/2018/09/mtairynews.png 374w" sizes="(max-width: 300px) 100vw, 300px" /></a></div></div>
<div class="mh-col-1-2 mh-widget-col-2 mh-footer-2-cols  mh-footer-area mh-footer-4">
<div id="custom_html-27" class="widget_text mh-footer-widget widget_custom_html"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Contact</span></h6><div class="textwidget custom-html-widget"><b>Phone:</b><br>
336-786-4141<br>
<b>Fax:</b><br>
336-789-2816<br>
<b>Address:</b><br>
319 N. Renfro Street,<br> 
Mount Airy NC, 27030</div></div><div id="custom_html-36" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script></div></div><div id="custom_html-11" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="text/javascript">
(function() {var s=document.createElement('script'); s.type='text/javascript'; s.async=true; s.src='//www.liqwid.net/?key=031A-9BE8-85CE-D8C0';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);})();
</script></div></div></div>
</div>
</footer>
	<div class="mh-footer-nav-mobile"></div>
	<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-77700" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77700"><a href="https://www.mtairynews.com/terms-of-use">Terms Of Use</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			&copy; 2018 The Mount Airy News		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<script type="text/javascript">
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-6686294-41']);
						_gaq.push(['_trackPageview']);
			(function() {
			 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
			 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
			 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			})();
		</script><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"mtairynews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"87403 https:\/\/www.mtairynews.com\/sports\/87403\/badgett-moxley-receive-top-honors","disqusShortname":"mtairynews","disqusTitle":"Badgett, Moxley receive top honors","disqusUrl":"https:\/\/www.mtairynews.com\/sports\/87403\/badgett-moxley-receive-top-honors","postId":"87403"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/comment-reply.min.js?ver=5.3.3'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var megamenu = {"timeout":"300","interval":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/megamenu/js/maxmegamenu.js?ver=2.8'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/wp-embed.min.js?ver=5.3.3'></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"62f380209b","applicationID":"309219129","transactionName":"ZlNUNxdQWhZTWk0KWl8ZdwARWFsLHUpQDVJdUw==","queueTime":0,"applicationTime":107,"atts":"ShRXQV9KSRg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>