<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.mtairynews.com/xmlrpc.php" />
<title>Police reports | Mt. Airy News</title>

<!-- The SEO Framework by Sybre Waaijer -->
<meta name="description" content="An encounter with officers late Tuesday night led to a homeless man being jailed under a large, $81,000 secured, bond on charges including resisting arrest&#8230;" />
<meta property="og:image" content="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews.png" />
<meta property="og:image:width" content="374" />
<meta property="og:image:height" content="36" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Police reports | Mt. Airy News" />
<meta property="og:description" content="An encounter with officers late Tuesday night led to a homeless man being jailed under a large, $81,000 secured, bond on charges including resisting arrest, according to Mount Airy Police Department&#8230;" />
<meta property="og:url" content="https://www.mtairynews.com/news/110793/police-reports-583" />
<meta property="og:site_name" content="Mt. Airy News" />
<meta property="og:updated_time" content="2022-06-16T00:49+00:00" />
<meta property="article:publisher" content="https://www.facebook.com/pages/The-Mount-Airy-News/120821418072" />
<meta property="article:published_time" content="2022-06-16T00:49+00:00" />
<meta property="article:modified_time" content="2022-06-16T00:49+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@mountairynews" />
<meta name="twitter:title" content="Police reports | Mt. Airy News" />
<meta name="twitter:description" content="An encounter with officers late Tuesday night led to a homeless man being jailed under a large, $81,000 secured, bond on charges including resisting arrest, according to Mount Airy Police Department&#8230;" />
<meta name="twitter:image" content="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews.png" />
<meta name="twitter:image:width" content="374" />
<meta name="twitter:image:height" content="36" />
<link rel="canonical" href="https://www.mtairynews.com/news/110793/police-reports-583" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.mtairynews.com/","name":"Mt. Airy News"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.mtairynews.com/category/news","name":"News"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.mtairynews.com/news/110793/police-reports-583","name":"Police reports"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 4.61ms meta | 0.78ms boot -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mt. Airy News &raquo; Feed" href="https://www.mtairynews.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Mt. Airy News &raquo; Comments Feed" href="https://www.mtairynews.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Mt. Airy News &raquo; Police reports Comments Feed" href="https://www.mtairynews.com/news/110793/police-reports-583/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s24476.pcdn.co\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.12"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://s24476.pcdn.co/wp-includes/css/dist/block-library/style.min.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='simple-staff-list-css'  href='https://s24476.pcdn.co/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='staff-list-custom-css-css'  href='https://s24476.pcdn.co/wp-content/themes/mh-magazine/simple-staff-list-custom.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='vfb-pro-css'  href='https://s24476.pcdn.co/wp-content/plugins/vfb-pro/public/assets/css/vfb-style.min.css?ver=2019.05.10' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://s24476.pcdn.co/wp-includes/css/dashicons.min.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://s24476.pcdn.co/wp-content/themes/mh-magazine/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://s24476.pcdn.co/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=PT+Sans:300,400,400italic,600,700%7cMerriweather:300,400,400italic,600,700' type='text/css' media='all' />
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3'></script>
<link rel='https://api.w.org/' href='https://www.mtairynews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mtairynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s24476.pcdn.co/wp-includes/wlwmanifest.xml" /> 
<link rel="alternate" type="application/json+oembed" href="https://www.mtairynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F110793%2Fpolice-reports-583" />
<link rel="alternate" type="text/xml+oembed" href="https://www.mtairynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F110793%2Fpolice-reports-583&#038;format=xml" />
<style type="text/css">
.mh-header { background: #022452; }
.mh-widget-layout4 .mh-widget-title { background: #022452; background: rgba(2, 36, 82, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #022452; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #022452; }
.mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #022452; }
</style>
<!--[if lt IE 9]>
<script src="https://s24476.pcdn.co/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "PT Sans", sans-serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e0e0e0; }
</style>
	<link rel="icon" href="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-32x32.png" sizes="32x32" />
<link rel="icon" href="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-180x180.png" />
<meta name="msapplication-TileImage" content="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.mh-widget-title {
	background-color: #022452 !important;
}

.mh-header-nav li a {
    padding: 0 19px !important;
}

.attachment-mh-magazine-slider{
height: 300px !important;
width: auto !important;
}
.metaInfo{
	display:none;
}

.class1 img {
	display: block;
	margin: auto;
	float: none !important;
}

@media screen and (min-width: 1125px) {

.mh-col-1-3 {
    width: 27% !important;
}

.mh-col-2-3 {
    width: 70% !important;
}

}

@media screen and (max-width: 1124px) {

.mh-col-1-3 {
    width: 30%;
		min-width: 300px;
		margin: auto !important;
		float: none;
}

.mh-col-2-3 {
    width: 100%;
		margin: auto !important;
}

}

.mh-googleplus{
	display:none;
}
.mh-posts-large-thumb{
	background-color:black;
}
.mh-posts-large-thumb img{
	width:auto !important;
}
.mh-main-nav li a {
    padding: 10px 18px;
}

.google-auto-placed {
	display: none;
}
		</style>
		<style type="text/css"></style>
<script async="async" src="//zdwidget3-bs.sphereup.com/zoomd/SearchUi/Script?clientId=05916537"></script>
</head>
<body data-rsssl=1 id="mh-mobile" class="post-template-default single single-post postid-110793 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout5" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<aside class="mh-container mh-header-widget-1">
<div id="custom_html-11" class="widget_text mh-widget mh-header-1 widget_custom_html"><div class="textwidget custom-html-widget"><script> (function(){var l=function(){if (document.readyState && /loading/.test(document.readyState)){return setTimeout(l, 10);} if (!top._liqwid_loaded){top._liqwid_loaded=true; return setTimeout(l, 10);} var s=document.createElement("script"), x=top.document.getElementsByTagName('script')[0]; s.setAttribute('async', 'true'); s.setAttribute('src','https://liqwid.net/?key=2B69-A3AA-AFFC-D516&u='+encodeURIComponent(top.location.href)+'&d='+Date.now()+'&v='+('; '+document.cookie).split('; liqwid=').pop().split(';').shift()); x.parentNode.insertBefore(s,x);};l();})(); </script></div></div></aside>
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-header-menu-container"><ul id="menu-header-menu" class="menu"><li id="menu-item-65282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65282"><a href="http://yourjobmatchnc.thejobnetwork.com/">Jobs</a></li>
<li id="menu-item-65270" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65270"><a href="https://www.mtairynews.com/e-edition">E-Edition</a></li>
<li id="menu-item-65271" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65271"><a href="https://www.mtairynews.com/classifieds">Classifieds</a></li>
<li id="menu-item-91817" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-91817"><a href="https://apg01.newzware.com/ss70v2/adams/common/template.jsp?init=start">Subscribe</a>
<ul class="sub-menu">
	<li id="menu-item-91819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-91819"><a href="https://apg01.newzware.com/ss70v2/adams/common/template.jsp">Manage My Subscription</a></li>
</ul>
</li>
<li id="menu-item-65273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65273"><a href="https://www.mtairynews.com/sign-up-for-notices">Sign Up For Notices</a></li>
<li id="menu-item-65285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65285"><a href="https://play.google.com/store/apps/details?id=com.vervewireless.droid.mtairynews&#038;hl=en">Android App</a></li>
<li id="menu-item-65286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65286"><a href="https://itunes.apple.com/us/app/the-mount-airy-news/id1378553829?ls=1&#038;mt=8">iOS App</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-social-container"><ul id="menu-social" class="menu"><li id="menu-item-65280" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65280"><a href="https://www.facebook.com/pages/The-Mount-Airy-News/120821418072"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-65281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65281"><a href="https://twitter.com/mountairynews"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://www.mtairynews.com/" class="custom-logo-link" rel="home"><img width="374" height="36" src="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews.png" class="custom-logo" alt="Mt. Airy News" srcset="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews.png 374w, https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews-300x29.png 300w" sizes="(max-width: 374px) 100vw, 374px" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-10" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="5" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins><script src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script>--->
</div></div></aside>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-37973" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-37973"><a href="https://www.mtairynews.com">Home</a>
<ul class="sub-menu">
	<li id="menu-item-38363" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38363"><a href="https://www.mtairynews.com/contact-us">Contact Us</a></li>
	<li id="menu-item-38364" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38364"><a href="https://www.mtairynews.com/about-us">About Us</a></li>
	<li id="menu-item-38368" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38368"><a href="https://www.mtairynews.com/advertise">Advertise</a></li>
	<li id="menu-item-38412" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38412"><a href="http://www.facebook.com/pages/The-Mount-Airy-News/120821418072">Mount Airy News on Facebook</a></li>
	<li id="menu-item-40794" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40794"><a href="https://twitter.com/mountairynews">Mount Airy News on Twitter</a></li>
	<li id="menu-item-38414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38414"><a href="https://www.mtairynews.com/sign-up-for-notices">Sign Up For Notices</a></li>
	<li id="menu-item-91816" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-91816"><a href="https://apg01.newzware.com/ss70v2/adams/common/template.jsp?init=start">Subscribe</a></li>
	<li id="menu-item-91820" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-91820"><a href="https://apg01.newzware.com/ss70v2/adams/common/template.jsp">Manage My Subscription</a></li>
	<li id="menu-item-77699" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77699"><a href="https://www.mtairynews.com/terms-of-use">Terms Of Use</a></li>
</ul>
</li>
<li id="menu-item-37963" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-37963"><a href="https://www.mtairynews.com/category/news">News</a>
<ul class="sub-menu">
	<li id="menu-item-100016" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-100016"><a href="https://mtairynews.newsbank.com">Archive</a></li>
	<li id="menu-item-56100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56100"><a href="https://www.mtairynews.com/category/special-sections">Special Sections</a></li>
	<li id="menu-item-38371" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38371"><a href="https://www.mtairynews.com/online-community">Online Community</a></li>
	<li id="menu-item-38375" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38375"><a href="https://www.mtairynews.com/formnewstip">Submit News Tip</a></li>
	<li id="menu-item-38376" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38376"><a href="https://www.mtairynews.com/onlineforms">Online Forms</a></li>
	<li id="menu-item-38416" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38416"><a href="https://www.mtairynews.com/feed">All Articles Feed</a></li>
</ul>
</li>
<li id="menu-item-37965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37965"><a href="https://www.mtairynews.com/category/sports">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-38377" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38377"><a href="https://www.mtairynews.com/formscores">Submit Scores</a></li>
	<li id="menu-item-38378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38378"><a href="https://www.mtairynews.com/formsportsnews">Submit Sports News</a></li>
	<li id="menu-item-43456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43456"><a href="http://pro32.ap.org/mtairynews">Pro32</a></li>
	<li id="menu-item-43458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43458"><a href="http://racing.ap.org/mtairynews">Auto Racing</a></li>
	<li id="menu-item-43459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43459"><a href="http://collegebasketball.ap.org/mtairynews">College Basketball</a></li>
	<li id="menu-item-43460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43460"><a href="http://collegefootball.ap.org/mtairynews">College Football</a></li>
</ul>
</li>
<li id="menu-item-37967" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37967"><a href="http://www.legacy.com/obituaries/mtairynews">Obituaries</a></li>
<li id="menu-item-37964" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37964"><a href="https://www.mtairynews.com/category/opinion">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-38379" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38379"><a href="https://www.mtairynews.com/formeditor">Send A Letter To The Editor</a></li>
</ul>
</li>
<li id="menu-item-37966" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37966"><a href="https://www.mtairynews.com/category/features">Features</a>
<ul class="sub-menu">
	<li id="menu-item-38380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38380"><a href="https://www.mtairynews.com/contests">Contests</a></li>
	<li id="menu-item-38382" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38382"><a href="https://www.mtairynews.com/comics">Comics</a></li>
	<li id="menu-item-38383" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38383"><a href="https://www.mtairynews.com/horoscopes">Horoscopes</a></li>
	<li id="menu-item-63246" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63246"><a href="https://www.mtairynews.com/category/special-sections">Special Sections</a></li>
	<li id="menu-item-38385" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38385"><a href="https://www.mtairynews.com/formanniversary">Submit Anniversary</a></li>
	<li id="menu-item-38386" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38386"><a href="https://www.mtairynews.com/formbirth">Submit Birth</a></li>
	<li id="menu-item-38387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38387"><a href="https://www.mtairynews.com/formbirthday">Submit Birthday</a></li>
	<li id="menu-item-38388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38388"><a href="https://www.mtairynews.com/formengagement">Submit Engagement</a></li>
	<li id="menu-item-38389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38389"><a href="https://www.mtairynews.com/formwedding">Submit Wedding</a></li>
</ul>
</li>
<li id="menu-item-37969" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-37969"><a href="https://www.mtairynews.com/entertainment">TV/Games</a>
<ul class="sub-menu">
	<li id="menu-item-82825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-82825"><a href="https://www.mtairynews.com/games">Games</a></li>
	<li id="menu-item-38434" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38434"><a href="https://www.mtairynews.com/tvsoaps">Soaps</a></li>
	<li id="menu-item-39181" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39181"><a href="https://www.mtairynews.com/tvbestbets">TV Best Bets</a></li>
	<li id="menu-item-38390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38390"><a href="https://www.mtairynews.com/tvbestbets">TV Best Bets</a></li>
	<li id="menu-item-38436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38436"><a href="https://www.mtairynews.com/tvmovies">Movies</a></li>
	<li id="menu-item-38391" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38391"><a href="https://www.mtairynews.com/tvlistings">TV Listings</a></li>
	<li id="menu-item-38392" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38392"><a href="https://www.mtairynews.com/tvnews">TV News</a></li>
	<li id="menu-item-38433" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38433"><a href="https://www.mtairynews.com/tvqa">Q &#038; A</a></li>
	<li id="menu-item-38437" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38437"><a href="https://www.mtairynews.com/tvnews">TV News</a></li>
	<li id="menu-item-38393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38393"><a href="https://www.mtairynews.com/tvsearch">TV Search</a></li>
	<li id="menu-item-38394" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38394"><a href="https://www.mtairynews.com/tvsports">TV Sports</a></li>
	<li id="menu-item-38395" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38395"><a href="https://www.mtairynews.com/tvtalk">TV Talk</a></li>
	<li id="menu-item-38396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38396"><a href="https://www.mtairynews.com/tvvideo">TV Video</a></li>
</ul>
</li>
<li id="menu-item-99553" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-99553"><a href="https://www.mtairynews.com/local-events">Events</a></li>
<li id="menu-item-39252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39252"><a href="http://shoplocal.yadkinvalley.com/mtairynews/">Shop Local</a>
<ul class="sub-menu">
	<li id="menu-item-86887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86887"><a href="https://shoplocal.yadkinvalley.com/mtairynews/">Local Businesses</a></li>
</ul>
</li>
<li id="menu-item-64582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-64582"><a href="http://www.ncpress.com/ncnotices/">Public Notices</a></li>
<li id="menu-item-88298" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-88298"><a href="https://site1.midtcweb.com/flipcore/mountairy/MOU061522final/">Wednesday/Friday</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-date mh-header-date-bottom">
							June 16, 2022						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside zoomdSearch='{"trigger":"OnClick"}' class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://www.mtairynews.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.mtairynews.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.mtairynews.com/category/news" itemprop="url"><span itemprop="title">News</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Police reports</nav>


<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.mtairynews.com/news/110793/police-reports-583"
  },
  "headline": "Police reports",
     "datePublished": "2022-06-15T20:49:00-04:00",
  "dateModified": "2022-06-15T20:49:00-04:00",
  "author": {
    "@type": "Person",
		"name": "Staff Reports"
	  },
   "publisher": {
    "@type": "Organization",
    "name": "Mt. Airy News",
    "logo": {
      "@type": "ImageObject",
      "url": "https://s24476.pcdn.co/wp-content/uploads/2015/07/mtairynews.png"
    }
  },
  "description": "
				&#8226; An encounter with officers late Tuesday night led to a homeless man being jailed under a large, $81,000 secured, bond on charges including resisting arrest, according to Mount Airy Police Department reports.
			 [...]"
}
</script>
<style>
.neFileBlock{
	display:none;
}
.metaInfo{
	display:none;
}
.entry-thumbnail img {
width: auto !important;
max-height: 400px;
}
.factbox{ 
	float:left; 
	width:190px; 
	margin:7px; 
	background-color:#f5f5f5; 
	padding:5px; 
	box-shadow: 0 10px 16px 0 rgba(0,0,0,0.2),0 6px 20px 0 rgba(0,0,0,0.19);
}
.map{ 
	float:left; 
	width:200px; 
	margin:7px; 
}
.kicker{
	font-style:italic;
}
.pullquote {
    float: left;
    width: 190px;
    background: #f5f5f5;
    font-weight: bold;
    padding: 5px;
    margin: 0 5px 5px 0;
	font-size:18px;
}
.extraBox{
	float:left; 
	width:200px;  
	margin-right:20px;
}
.breakout{
border-radius: 25px;
  border: 2px solid #c00c00;
  padding: 20px;
}

</style>
<article id="post-110793" class="post-110793 post type-post status-publish format-standard hentry category-news">
		<header class="entry-header clearfix"><h1 class="entry-title">Police reports</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.mtairynews.com/date/2022/06">June 15, 2022</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.mtairynews.com/author/tjoyce">Thomas Joyce</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.mtairynews.com/category/news" rel="category tag">News</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.mtairynews.com/news/110793/police-reports-583#respond" class="mh-comment-count-link" ><span class="dsq-postid" data-dsqidentifier="110793 https://www.mtairynews.com/news/110793/police-reports-583">0</span></a></span>
</div>
				
			</header>
		<div class="entry-content clearfix">
																					
		<div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F110793%2Fpolice-reports-583&t=Police+reports', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Police+reports:&url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F110793%2Fpolice-reports-583', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F110793%2Fpolice-reports-583&media=&description=Police+reports', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F110793%2Fpolice-reports-583', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Police%20reports&amp;body=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F110793%2Fpolice-reports-583" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
																		
																						<div class="extraBox">
														</div>
										<p>&#8226; An encounter with officers late Tuesday night led to a homeless man being jailed under a large, $81,000 secured, bond on charges including resisting arrest, according to Mount Airy Police Department reports.</p>
<p>Gregory Wayne Childress Jr., 37, was the subject of a traffic stop on Long Street near South Franklin Road due to an unspecified equipment violation regarding the 2009 Pontiac G6 he was operating.</p>
<p>Childress also was wanted on an outstanding arrest order for failing to appear in court which had been issued on May 2 and was charged Tuesday night with resisting, delaying or obstructing a public officer, although the reason for this was not specified in police records.</p>
<p>He also was charged with possession of a Schedule III controlled substance, identified as Suboxone. Childress is scheduled to appear in Surry District Court on July 25.</p>
<p>&#8226; A crime involving the obtaining of property by false pretense was discovered last Saturday at Walmart, where an unknown suspect had taken items from the store and returned them for a gift card. This was identified as batteries valued at $31.28 which were used to obtain a gift card of the same sum.</p>
<p>&#8226; A Suzuki Hayabusa motorcycle valued at $2,500, identified as white in color, was discovered stolen from the Edgewood Place Lane residence of owner Trey Junius Dalton on June 8. No model year or license tag information was noted.</p>
<p>&#8226; Travis Lee Wells, 29, listed as homeless, is facing a felony drug charge that was filed after he crossed paths with officers during a suspicious-vehicle investigation in the 1200 block of West Lebanon Street on June 5.</p>
<p>Wells was found in possession of methamphetamine and paraphernalia including red cut straws and plastic baggies with white powder residue, an aluminum grinder and a glass smoking device.</p>
<p>He was charged with possession of a Schedule II controlled substance and possessing drug paraphernalia, and also was found to be the subject of two outstanding arrest warrants for charges of larceny and damage to property which had been filed by Davie County authorities. Wells was held in the Surry County Jail under a $5,500 secured bond and is slated for a Sept. 12 appearance in District Court at Dobson.</p>
										<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F110793%2Fpolice-reports-583&t=Police+reports', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Police+reports:&url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F110793%2Fpolice-reports-583', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F110793%2Fpolice-reports-583&media=&description=Police+reports', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F110793%2Fpolice-reports-583', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Police%20reports&amp;body=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F110793%2Fpolice-reports-583" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>

	</div></article>
								<div id="rc-widget-7301ab" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="166979"></div>
				<script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
				
				
<div id="disqus_thread"></div>
<nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.mtairynews.com/news/110789/yokley-memorial-award-scholarship-announced" rel="prev"><img width="58" height="60" src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128600179_web1_Yokley-1-58x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="https://s24476.pcdn.co/wp-content/uploads/2022/06/128600179_web1_Yokley-1-58x60.jpg 58w, https://s24476.pcdn.co/wp-content/uploads/2022/06/128600179_web1_Yokley-1-291x300.jpg 291w, https://s24476.pcdn.co/wp-content/uploads/2022/06/128600179_web1_Yokley-1-424x438.jpg 424w, https://s24476.pcdn.co/wp-content/uploads/2022/06/128600179_web1_Yokley-1-369x381.jpg 369w, https://s24476.pcdn.co/wp-content/uploads/2022/06/128600179_web1_Yokley-1-493x509.jpg 493w, https://s24476.pcdn.co/wp-content/uploads/2022/06/128600179_web1_Yokley-1-237x245.jpg 237w, https://s24476.pcdn.co/wp-content/uploads/2022/06/128600179_web1_Yokley-1.jpg 620w" sizes="(max-width: 58px) 100vw, 58px" /><span>Previous</span><p>Yokley memorial award, scholarship announced</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://www.mtairynews.com/opinion/110794/motorist-thankful-for-help" rel="next"><span>Next</span><p>Motorist thankful for help</p></a></div>
</nav>
				<a id="comments"></a>
							<ins data-revive-zoneid="153" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
			<script async src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script>
			  <style type="text/css">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</style><div id="ajax-load-more" class="ajax-load-more-wrap infinite fading-blocks"  data-alm-id="" data-canonical-url="https://www.mtairynews.com/news/110793/police-reports-583" data-slug="police-reports-583" data-post-id="110793"  data-localized="ajax_load_more_vars"><ul aria-live="polite" aria-atomic="true" class="alm-listing alm-ajax" data-seo="true" data-seo-start-page="1" data-seo-scroll="true" data-seo-scrolltop="30" data-seo-controls="1" data-seo-permalink="pretty" data-seo-pageview="true" data-container-type="ul" data-loading-style="infinite fading-blocks" data-repeater="template_1" data-post-type="post" data-category="News" data-order="DESC" data-orderby="date" data-offset="1" data-posts-per-page="50" data-scroll="true" data-scroll-distance="100" data-max-pages="0" data-pause-override="false" data-pause="false" data-button-label="Next Article" data-transition="none"></ul><noscript><ul class="alm-listing alm-noscript"><div class="alm-reveal"><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110796/juneteenth-events-jones-school-fundraiser-this-weekend" title="Juneteenth events, Jones School fundraiser this weekend" style="color:black">Juneteenth events, Jones School fundraiser this weekend</a></h1>

            <a href="https://www.mtairynews.com/news/110796/juneteenth-events-jones-school-fundraiser-this-weekend" title="Juneteenth events, Jones School fundraiser this weekend">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128604851_web1_MuseumJuneteenth-388x509.jpg" alt="Juneteenth events, Jones School fundraiser this weekend">
            </a>
   <p class="entry-meta">June 16, 2022</p>
   <p>It has been twelve weeks since the Surry County Board of County Commissioners and the African American Historical and Genealogical Society agree to transfer the former J. J. Jones High School back into the hands of her alumni.</p>
<p>As the county&rsquo;s fiscal year is reaching its end, the first benchmark of the agreement is set for July 1 when the deed will be transferred to the Save Jones group.</p>
<p><strong>Jones School progress</strong></p>
<p>Co-chair of the Save Jones School Committee Adreann Belle advised this week that, &ldquo;We are progressing nicely toward taking over the Jones Family Resource Center.&rdquo; She said planning and work continue at the L. H. Jones Family Resource Center in anticipation of the transfer of the deed from the county to the Save Jones School group. Save Jones was given the former J. J. Jones High School from Surry County after it had been listed as surplus property due to the cost of maintenance on the aging building.</p>
<p>&ldquo;Cosmetically, it&rsquo;s not that bad,&rdquo; Belle advised this week. &ldquo;The boiler needs to be replaced, it&rsquo;s on last legs. We are looking for some grant money, around $350,000 to help with that.&rdquo; The county&rsquo;s assessment of the building had identified the boiler, plumbing, roof, wiring, HVAC and windows as all being near the end of their projected life cycle.</p>
<p>After the boiler, the roof is the next major project; it will then be time for an architectural analysis to get the design elements of the new mixed-use facility. &ldquo;We want a cultural and heritage center to preserve the artifacts not just of the school, but of the community,&rdquo; Belle said of the future facility.</p>
<p>The group has made an application to the General Assembly for $500,000 in grant money to further projects that will transition the former school from its current configuration as the home for the organizations of YVEDDI to a mixture of residential and community use spaces. LaShene Lowe, president of the African American Historical and Genealogical Society, said Wednesday that at this time all YVEDDI occupants have signaled their intention to stay in the new Jones.</p>
<p>The end of month fundraising goal for the group is $20,000, down two thirds from the last update provided. To add to the Save Jones effort, there are several events upcoming that the community is invited to participate in beginning this Friday, June 17, at 7 p.m. with a Masquerade Ball at the Jones School Auditorium. &ldquo;This is a dress to impress event,&rdquo; Belle said, &ldquo;but we will provide the masquerade mask.&rdquo;</p>
<p>She said this is the one to put fun back in fundraiser, &ldquo;We will have snacks, drinks, and music so it&rsquo;s an opportunity to have some fun.&rdquo; Entry to the masquerade ball is $15.</p>
<p><strong>Juneteenth celebrations</strong></p>
<p>Furthermore, the Save Jones group will have booths set up this Saturday in both Mount Airy and Elkin for Juneteenth events. Juneteenth is the day in 1865 when residents of Galveston, Texas, learned that slavery in the United States had been abolished, two months after the end of the Civil War and 2 1/2 years after the Emancipation Proclamation.</p>
<p>In Elkin, the event is Saturday from 11 a.m. to 7 p.m. at The Heritage Center, 257 Standard Street. Greg Brewer, president of Bridge of Unity extended the offer, &ldquo;If you are able to come, we would love to have you here. Our events will focus on things that bring us together and not focus on the differences &#8211; but things like food, fun, and fellowship that we can all agree on.&rdquo;</p>
<p>Fernando &ldquo;Sly&rdquo; Best, CEO of Bridge of Unity, laid out the activities beginning at 11 a.m. with events for kids such as bounce houses, field day games, and an art gallery for anyone seeking some relief from the heat inside the Heritage Center. A selection of more than 30 vendors will be on hand and Elkin&rsquo;s Got Talent karaoke begins at 2 p.m. where there is a $100 prize for the winner. From 4 p.m. &#8211; 6 p.m. the band Retropunkz will take the stage, &ldquo;They are number-one in New Orleans and Bourbon Street,&rdquo; he said.</p>
<p>&ldquo;Come hungry,&rdquo; Best has told those going to the Juneteenth event. There is an all you can eat buffet beginning at 5 p.m. that costs $25, but he warned, &ldquo;Get there early because last year the ticket and the food ran out quick.&rdquo; With selections of crab legs, brisket, ribs, turkey legs, hamburgers, chicken and more this is a ticket that understandably could fly out the window.</p>
<p>No fear if the buffet runs out, Best said he has it covered with a group of food trucks ranging from soul to creole and points in between heading to Elkin this weekend.</p>
<p>In Mount Airy, also on Saturday, the Second Annual Juneteenth Celebration with be held in the Market Street Arts &#038; Entertainment District and Melva&rsquo;s Alley. Big Dawg Catering &#038; Food Truck will be there along with multiple artists and a performance from the UNC Chapel Hill Kamikazi Dance Team at 2 p.m.</p>
<p>Organizer Dougenna Hill said vendors were chosen from Black owned local businesses again this year to participate in the event. There will be live music in Melva&rsquo;s Alley featuring Lois Atkinson &#038; Aquarius Moon will be found from 7 p.m.- 9:30 p.m.</p>
<p>Before the evening&rsquo;s music, there will be a moment of silence and a toast of red fruit punch, a donation of Lenise Lynch of Hampton Inn of Mount Airy. &ldquo;Red is a color that evokes cultural memory of the bloodshed by our enslaved ancestors through the transatlantic slave trade,&rdquo; said culinary historian Adrian Miller.</p>
<p>On Sunday, the Mount Airy Museum of Regional History is holding its own Juneteenth event from 1 &#8211; 4 p.m.</p>
<p>There will be a reading of the Emancipation Proclamation, games, live music and history focused activities such as crafts and a self-guided walking tour of the main street area that focuses on local African American history. This event is free to the public.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110793/police-reports-583" title="Police reports" style="color:black">Police reports</a></h1>
   <p class="entry-meta">June 15, 2022</p>
   <p>&#8226; An encounter with officers late Tuesday night led to a homeless man being jailed under a large, $81,000 secured, bond on charges including resisting arrest, according to Mount Airy Police Department reports.</p>
<p>Gregory Wayne Childress Jr., 37, was the subject of a traffic stop on Long Street near South Franklin Road due to an unspecified equipment violation regarding the 2009 Pontiac G6 he was operating.</p>
<p>Childress also was wanted on an outstanding arrest order for failing to appear in court which had been issued on May 2 and was charged Tuesday night with resisting, delaying or obstructing a public officer, although the reason for this was not specified in police records.</p>
<p>He also was charged with possession of a Schedule III controlled substance, identified as Suboxone. Childress is scheduled to appear in Surry District Court on July 25.</p>
<p>&#8226; A crime involving the obtaining of property by false pretense was discovered last Saturday at Walmart, where an unknown suspect had taken items from the store and returned them for a gift card. This was identified as batteries valued at $31.28 which were used to obtain a gift card of the same sum.</p>
<p>&#8226; A Suzuki Hayabusa motorcycle valued at $2,500, identified as white in color, was discovered stolen from the Edgewood Place Lane residence of owner Trey Junius Dalton on June 8. No model year or license tag information was noted.</p>
<p>&#8226; Travis Lee Wells, 29, listed as homeless, is facing a felony drug charge that was filed after he crossed paths with officers during a suspicious-vehicle investigation in the 1200 block of West Lebanon Street on June 5.</p>
<p>Wells was found in possession of methamphetamine and paraphernalia including red cut straws and plastic baggies with white powder residue, an aluminum grinder and a glass smoking device.</p>
<p>He was charged with possession of a Schedule II controlled substance and possessing drug paraphernalia, and also was found to be the subject of two outstanding arrest warrants for charges of larceny and damage to property which had been filed by Davie County authorities. Wells was held in the Surry County Jail under a $5,500 secured bond and is slated for a Sept. 12 appearance in District Court at Dobson.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110789/yokley-memorial-award-scholarship-announced" title="Yokley memorial award, scholarship announced" style="color:black">Yokley memorial award, scholarship announced</a></h1>

            <a href="https://www.mtairynews.com/news/110789/yokley-memorial-award-scholarship-announced" title="Yokley memorial award, scholarship announced">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128600179_web1_Yokley-1-493x509.jpg" alt="Yokley memorial award, scholarship announced">
            </a>
   <p class="entry-meta">June 15, 2022</p>
   <p>More than 30 years have passed since the death of an accomplished local student-athlete, but her legacy continues through annual memorial and scholarship programs for students at the school she attended, Mount Airy High.</p>
<p>This included the presentation of the Charlotte Weatherly Yokley Memorial Award to Jessica Sawyers and the awarding of the Charlotte Weatherly Yokley Scholarship to Mackenzie Welch.</p>
<p>Both occurred during Mount Airy High School&rsquo;s annual honors program held recently near the end of the school year.</p>
<p>The presentation of the memorial award to Jessica Sawyers, signified by a trophy, was made by Pam Yokeley, Charlotte&rsquo;s mother, and previous winners Oshyn Bryant (2021), Catherine Sawyers (2020) and Owen Perkins (2019).</p>
<p>It is based on academics, athletics and character.</p>
<p>Jessica plans to attend the University of North Carolina at Greensboro this fall. She is the daughter of Denise and Calvin Sawyers.</p>
<p>The receiving of the Yokley scholarship will aid Mackenzie Welch in her studies at Western Carolina University beginning in the fall. She is the daughter of Beth and David Welch.</p>
<p>It was bestowed to her by Pam Yokley and Charlotte&rsquo;s sisters, Allyson Ferguson and Sheldon Fowler.</p>
<p>The scholarship selection is based on academics and character.</p>
<p>Charlotte Yokley, who would have graduated from Mount Airy High School in 1992, was a member of the National Honor Society, a junior marshal, received the John Hamilton Award in 1990 and was a member of the school&rsquo;s varsity basketball, track and tennis teams.</p>
<p>In the summer of 1991, just before the start of her senior year, Charlotte was traveling the British Virgin Islands on a sailing expedition with a group known as Actionquest. During the trip, a collision with another boat operated by an intoxicated driver led to her death.</p>
<p>Both the memorial award and scholarship program were established the next year as lasting tributes to her.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110788/pilot-man-dead-shot-during-domestic-assault" title="Pilot man dead, shot during domestic assault" style="color:black">Pilot man dead, shot during domestic assault</a></h1>
   <p class="entry-meta">June 15, 2022</p>
   <p>A Pilot Mountain man is dead, apparently shot by his son, during a domestic dispute which occurred Saturday evening, according to Surry County Sheriff Steve C. Hiatt.</p>
<p>While the sheriff released few details &mdash; and said no additional information would be released at this time &mdash; it appears as if the victim was shot while engaged in a domestic assault of his wife, the shooter&rsquo;s mother.</p>
<p>In a written statement released late Tuesday afternoon, the sheriff said his deputies arrived at 180 Moravian Lane in Pilot Mountain after a 9:19 p.m. call on Saturday. Upon arrival at the home, they found Michael Williams Goins, 47, dead from &ldquo;an apparent gunshot wound.&rdquo;</p>
<p>The sheriff&rsquo;s office, along with special agents from the North Carolina State Bureau of Investigation &ldquo;remained on the scene conducting interviews and gathering information throughout the night,&rdquo; the sheriff said.</p>
<p>&ldquo;During the investigation, detectives determined that the shooting incident occurred during a domestic assault incident between Goins and his wife, Sherry Palmer Goins&#8230;Present during the incident, was their son, Andrew William Goins,&rdquo; who the sheriff said fired a single shot with a firearm.</p>
<p>The sheriff&rsquo;s statement did not include what sort of gun was involved, nor any other details regarding the assault.</p>
<p>&ldquo;This incident is still an active investigation and no other information will be released at this time,&rdquo; the sheriff said.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110783/marking-a-masons-milestone" title="Marking a Mason&#8217;s milestone" style="color:black">Marking a Mason&#8217;s milestone</a></h1>

            <a href="https://www.mtairynews.com/news/110783/marking-a-masons-milestone" title="Marking a Mason&#8217;s milestone">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128599108_web1_Sparger1-449x509.jpg" alt="Marking a Mason&amp;#8217;s milestone">
            </a>
   <p class="entry-meta">June 15, 2022</p>
   <p>Guy Sparger stands apart from other Freemasons not just in District 25 but across the nation for his recent recognition of 70 years of membership in the organization.</p>
<p>He was honored by his peers at his home in Mount Airy last week by a collection of masons who have seen 30 and 40 anniversary pins bestowed &#8211; but never seen a 70-year pin.</p>
<p><strong>A rare feat</strong></p>
<p>Local freemason Ricky Lawson joked, &ldquo;They have special recognitions for 25, 50, and 60 years &#8211; but not 70 years!&rdquo; Of the ten local Masons who attended there were none who could recall another Mason being so honored for that length of time.</p>
<p>Sparger is a lively gentleman in his 90s who held court with the assorted guests at his home, some of whom he was not as familiar with. For the local Masons of Round Peak Lodge #616 and Copeland Lodge #390 it was their honor to be there for the plaque and pin ceremony for the United States Navy veteran and elder local Mason.</p>
<p>Mary Louise Sparger, wife of the honoree, had the pleasure of pinning on the anniversary year lapel pin to her husband. The Spargers have been married since 1952, &ldquo;that&rsquo;s a lot of good years,&rdquo; he told the men on the porch.</p>
<p>After leaving to attend school at UNC-Chapel Hill, Sparger entered the Freemasons on April 20, 1951. Yes, the math is a bit off, &ldquo;They always keep us behind a year on the recognitions,&rdquo; Lawson noted. It was in 1990 that he made his return to take care of his mother.</p>
<p>At that time, the Spargers moved into their current home off Sparger Road, just above North Surry High School. Even the road where the home is found has taken on the family name as he said his father had &ldquo;help(ed) move the road up the hill from the water where it used to be.&rdquo;</p>
<p>As Mary Louise explained they made such changes to the old home to make it livable. It is a lovely mix of old wood with modern touches that is reminiscent of many older farmhouses in Surry County that have had a facelift here and there, but the striking beauty of old quality craftsmanship shows through.</p>
<p><strong>&ldquo;We make good men better.&rdquo; </strong></p>
<p>Jonathan Underwood, grand secretary of the Grand Lodge of North Carolina, praised Sparger noting again just how rare an accomplishment he has achieved. &ldquo;It is very rare. We see a few as people are living longer now, 50s and 60s, but only a few who make 70 years. Especially given you have to be 21 to enter, it&rsquo;s rare.&rdquo;</p>
<p>&ldquo;Freemasonry is a philosophical and philanthropic organization,&rdquo; he went on, &ldquo;whose aim is to teach men to be better, to live by the Golden Rule, and to be of service to one another.&rdquo; Freemasonry teaches members to show concern for people, care for the less fortunate, and help for those in need.</p>
<p>Those are noble guideposts to follow in life, and Sparger said if more people ascribed to those goals that a closer sense of community could be found. &ldquo;We&rsquo;d be better off if more people went to church. I&rsquo;d say going to church, being aware of what is going on around you and helping other people &mdash; that&rsquo;s the way to get back to a greater sense of community.&rdquo; The two pastors in attendance gave nods of approval to this diagnosis.</p>
<p>Each of the Masons agreed that they can and have a desire to serve others as is their mission. However, they would like to see the number of Masons increasing. Sparger said, &ldquo;It&rsquo;s the same in the churches now too, they ain&rsquo;t coming like they used to.&rdquo;</p>
<p>The average age of a North Carolina Mason, Lawson said, is 64 years old. The assembled masons struggled between them to produce an age of the youngest mason they could think of locally before concluding they could recall two members in their 20s in this area.</p>
<p>Bringing new members into the fold will only help the Masons with their desire to grow as men and to serve their community. &ldquo;Masons are ready to help,&rdquo; Sparger reminded.</p>
<p>Mystery and mission</p>
<p>Much of what the Freemasons do is cloaked in a bit of mystery; ask someone on the street who or what the masons are, and you may get a fantastical answer involving secret societies and intricate ceremonies. The Grand Lodge of North Carolina says, &ldquo;The fraternity is so old and so many of its records have been lost or destroyed, or never written, that a vast amount of Masonic lore is admittedly legend. &ldquo;</p>
<p>One masonic historian wrote, &ldquo;The Freemasons kept their trade secrets secret as did most guilds such as ironmongers, bakers, and weavers. This secrecy protected the quality of the guild&rsquo;s work and ensured job security for its members.&rdquo;</p>
<p>Fully organized since 1717 it is thought the origins of Freemasonry may go back to guilds of stonemasons in the Middle Ages. Lawson said he thinks the origins go much further than that back to the time of King Solomon. Whatever the date, they write they are &ldquo;the world&rsquo;s oldest and largest non-religious, non-political, fraternal and charitable organization.&rdquo;</p>
<p>&ldquo;The guild of Freemasons transformed into a social and fraternal institution in the 17th and 18th centuries. During this time, they used the tools and legends of their trade as metaphors to emphasize internal enlightenment and personal growth among the fraternity&rsquo;s members.&rdquo;</p>
<p>The men within its ranks then influenced the development of modern concepts of democracy and personal liberty &#8211; ideals entrenched in the founding of the United States.</p>
<p>In North Carolina, the first documented evidence of Masonic activity can be dated to Wilmington and New Bern during the early 1750&rsquo;s.</p>
<p>Today the work of a mason may look different than in centuries past, but the underlying mission of the Freemasons remains one of service. Sparger has served several times over in his lifetime and is not done just yet; there are still ways he can make a difference.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110773/three-summer-concerts-on-tap" title="Three summer concerts on tap" style="color:black">Three summer concerts on tap</a></h1>

            <a href="https://www.mtairynews.com/news/110773/three-summer-concerts-on-tap" title="Three summer concerts on tap">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128614465_web1_North-Tower-Band--002-.jpg" alt="Three summer concerts on tap">
            </a>
   <p class="entry-meta">June 15, 2022</p>
   <p>The Surry Arts Council&rsquo;s Summer Concert Series continues with a full weekend of entertainment starting with North Tower Band on Thursday. The Entertainers will perform on Friday and The Magnificents will take the stage on Saturday. All three shows will start at 7:30 p.m.</p>
<p>North Tower has been one of the South&rsquo;s great party bands for over 35 years, providing the best in Top 40, beach, funk, and oldies. Sizzling brass, super vocals, and a wide-ranging repertoire all contribute to making your event a night to remember.</p>
<p>The Entertainers are proud to have shared in the South&rsquo;s Beach Music tradition for more than 30 years. While staying true to their R&#038;B and Beach Music roots, the group also satisfies the most diverse audiences by playing selections from the latest Top 40, Classic Rock &#038; Roll, and Country music.</p>
<p>The Magnificents Band has a wealth of live playing experience in varied styles of music, includingclassic soul, beach, Motown, Top 40, and dance hits. The band brings a diverse of high-energy collection of music and motivation to get people dancing.</p>
<p>Each concert will begin at 7:30 p.m. on Thursday, Friday and Saturday evening. Admission to each show is $15 or a Surry Arts Council Annual Pass. Children 12 and younger are admitted free with an adult admission or Annual Pass. The Dairy Center, Whit&rsquo;s Custard, and Thirsty Souls Community Brewing will be at the concerts to provide food, snacks, drinks, beer, and wine for purchase. No outside alcohol or coolers are allowed to be brought into the amphitheatre area. Those attending are asked to bring a lounge chair or blanket to sit on.</p>
<p>Tickets are available online at www.surryarts.org, via phone at 336-786-7998, or at the Surry Arts Council office at 218 Rockford Street. For additional information, contact Marianna Juliana at 336-786-7998 or marianna@surryarts.org</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110755/copeland-elementary-student-recognized-for-artwork" title="Copeland Elementary student recognized for artwork" style="color:black">Copeland Elementary student recognized for artwork</a></h1>

            <a href="https://www.mtairynews.com/news/110755/copeland-elementary-student-recognized-for-artwork" title="Copeland Elementary student recognized for artwork">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128584013_web1_Billy-Creed_Jan.jpg" alt="Copeland Elementary student recognized for artwork">
            </a>
   <p class="entry-meta">June 15, 2022</p>
   <p>Copeland Elementary was in the spotlight recently when fifth grader Billy Creed and his artwork were recognized as a North Carolina Farm to School Art Contest winner during the awards reception in Raleigh.</p>
<p>Each year, winners of this contest are chosen, and their artwork is featured in the NC Farm to School Calendar. During the hybrid reception, it was revealed that Billy&rsquo;s artwork will be representing the month of January in the 2022-2023 calendar.</p>
<p>This year, the NC Farm to School program received more than 4,246 entries from across the state so judges had to take on the challenging task of choosing 13 winners. There are two levels of judging &#8211; a prejudging to narrow down the field and then final judging. There are a different set of judges for each event, most having a background in agriculture or visual arts. Each of the 13 winners will be featured as a month, or the cover, in the 2022-2023 North Carolina Farm to School calendar. In addition, honorable mentions will be posted to the North Carolina Farm to School website in late May.</p>
<p>Felecity Davis, a kindergartener at Shoals Elementary, was also recognized as an Honorable Mention in the contest.</p>
<p>&ldquo;I am super proud of all the students at both Copeland Shoals and how hard they worked on the 2022-23 Farm to School Calendar contest,&rdquo; said Hank Whitaker, who serves as visual arts instructor at both of the recognized elementary schools. &ldquo;Billy Creed from Copeland Elementary School has been great to work with all year and is a talented young artist. Felicity Davis at Shoals Elementary School is also a talented young artist. It is great to see them receive recognition for their hard work.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110765/kirkman-appointed-to-judgeship" title="Kirkman appointed to judgeship" style="color:black">Kirkman appointed to judgeship</a></h1>

            <a href="https://www.mtairynews.com/news/110765/kirkman-appointed-to-judgeship" title="Kirkman appointed to judgeship">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128614472_web1_gretchen-news-2-formatted-476x509.jpg" alt="Kirkman appointed to judgeship">
            </a>
   <p class="entry-meta">June 15, 2022</p>
   <p>A local attorney running for the District 17B district court judge seat in the fall will get an early start on her job, after being appointed to the vacant post by Gov. Roy Cooper. District 17B covers Surry and Stokes counties.</p>
<p>Gretchen Hollar Kirkman, a Mount Airy attorney, was among four judicial appointments Cooper announced Tuesday.</p>
<p>The Mount Airy resident previously served as a district court judge for District 17B, when she was appointed to that seat in 2018 to fill a vacancy after Charles M. Neaves Jr. retired from that post. She lost a re-election bid later that year in a tight race with Tom Langan. The death of Judge Spencer Key created the present vacancy, and Kirkman easily won the GOP nomination for the seat over Mark Miller.</p>
<p>Because there are no other candidates filed to run for the seat in November, the primary effectively gave her the victory, and Cooper&rsquo;s appointment allows her to take the judge seat several months early.</p>
<p>Kirkman is the sole practitioner at the Law Office of Gretchen Hollar Kirkman, PLLC. Previously, in addition to serving as a District 17B judge, she was an attorney at the Law Office of Sarah Stevens. The Surry Central High School graduate received her Juris Doctor from Wake Forest University School of Law and her Bachelor of Arts from the University of North Carolina at Chapel Hill.</p>
<p>Other Cooper appointments include:</p>
<p>&#8211; Jennifer Bedford as District Court Judge in District 10F, which serves part of Wake County. She will fill the vacancy created by the retirement of Judge Kris Bailey. Bedford serves as a Wake County Guardian ad Litem. She has worked as a senior legislative analyst and lead committee counsel at the North Carolina General Assembly. She was also an assistant district attorney in North Carolina and served in the U.S. Army. Bedford received her Juris Doctor from Pennsylvania State University and her Bachelor of Arts from Georgia State University.</p>
<p>&#8211; Matthew Rupp as District Court Judge in District 24, which serves Avery, Madison, Mitchell, Watauga and Yancey counties. He will fill the vacancy created by the retirement of Judge Larry Leake. Rupp is a partner at Angle, Rupp and Rupp, Attorneys at Law. Previously, he was an assistant district attorney in the District Attorney&rsquo;s Office for the 35th Prosecutorial District and the 26th Prosecutorial District. His prior experience also includes serving as counsel for the House Committee on Ways and Means and Counselor to the Inspector General. He received his Juris Doctor from Duke University School of Law and his Bachelor of Arts from the University of Notre Dame.</p>
<p>&#8211; Shante&rsquo; Burke-Hayer as District Court Judge in District 26, which serves part of Mecklenburg County. She will fill the vacant seat formerly held by Judge Kimberly Best. Burke-Hayer is managing attorney at Burke-Hayer Law Firm, PLLC. Previously, Burke was Of Counsel &#8211; Attorney at Hunt Law, PLLC, and a legal analyst at Wells Fargo. She received her Juris Doctor from the Charlotte School of Law and her Bachelor of Arts from the University of North Carolina at Charlotte.</p>
<p>&ldquo;These appointees bring years of experience and knowledge to the bench,&rdquo; Gov. Cooper said. &ldquo;I am grateful for their dedication to their communities over the years, and grateful for their willingness to serve.&rdquo;</p>
<p>&#8203;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110749/matlock-actor-visits-mount-airy" title="&#8216;Matlock&#8217; actor visits Mount Airy" style="color:black">&#8216;Matlock&#8217; actor visits Mount Airy</a></h1>

            <a href="https://www.mtairynews.com/news/110749/matlock-actor-visits-mount-airy" title="&#8216;Matlock&#8217; actor visits Mount Airy">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128608913_web1_Roebuck-1.jpg" alt="&amp;#8216;Matlock&amp;#8217; actor visits Mount Airy">
            </a>
   <p class="entry-meta">June 15, 2022</p>
   <p>Usually when actors who worked with Andy Griffith come to town it&rsquo;s because of the Mayberry connection, but in Daniel Roebuck&rsquo;s case his role on &ldquo;the other&rdquo; television series starring the local native &mdash; &ldquo;Matlock&rdquo; &mdash; was involved.</p>
<p>Roebuck appears in 55 episodes of that legal drama, which ran on the NBC and ABC networks from 1986 to 1995, playing Cliff Lewis, the junior partner of the law firm headed by the Griffith character, Ben Matlock.</p>
<p>And Daniel Roebuck&rsquo;s face also is familiar to fans of the movie &ldquo;The Fugitive,&rdquo; in which he portrays Marshal Biggs, one of the officers working under Deputy Marshal Samuel Gerard (Tommy Lee Jones) trying to apprehend the title protagonist (Harrison Ford).</p>
<p>The versatile actor&rsquo;s long list of TV and movie credits further includes &ldquo;U.S. Marshals,&rdquo; a sequel to &ldquo;The Fugitive,&rdquo; and the TV series &ldquo;Lost,&rdquo; among others.</p>
<p>Yet Roebuck&rsquo;s visit this week to Mount Airy, his first &mdash; lasting from Monday night to Tuesday afternoon &mdash; was all about soaking up sights and sounds of the man he worked with on &ldquo;Matlock.&rdquo;</p>
<p>This included visiting the Andy and Opie statue; Griffith&rsquo;s homeplace on East Haymore Street; the Andy Griffith Museum; Grace Moravian Church, where young Andy learned to play the trombone and performed in the church band; and the new Andy Griffith mural on Moore Avenue showing Griffith at different stages of his career, which features an image of him as &ldquo;Matlock.&rdquo;</p>
<p>Of course, there also were the other obligatory stops visitors often take in, the granite quarry and radio station WPAQ.</p>
<p>To reach those locations, Roebuck was chauffeured around in a Squad Car Tours vintage Ford Galaxie driven by Mark Brown, which included the actor checking out the Mayberry Courthouse located next door to the squad car headquarters.</p>
<p>&ldquo;What a great tour!&rdquo; Roebuck, 59, exclaimed upon exiting the Galaxie, just before greeting and posing for photos with members of a large crowd gathered there.</p>
<p>The visiting actor explained that he had been on the road the past few days, covering about 1,200 miles, encompassing a number of key areas of North Carolina.</p>
<p>One was a site in Sylva in Jackson County in the far western portion of the state where an iconic scene in &ldquo;The Fugitive&rdquo; was filmed involving a collision between the prison bus Dr. Richard Kimble was on and a train.</p>
<p>The wreckage was left in place and has been a tourist attraction in the years since the movie&rsquo;s release in 1993 &mdash; but Roebuck&rsquo;s visit was accompanied by him falling down a hillside there and getting a banged-up face.</p>
<p>He also went to Wilmington, where &ldquo;Matlock&rdquo; was filmed. &ldquo;And my brother lives there,&rdquo; Roebuck said.</p>
<p>So his swing through Mount Airy was an appropriate addition to the travel itinerary, where something else stood out to him more than its various tourist attractions.</p>
<p>&ldquo;My first impressions of Mount Airy is great people, ahead of everything else,&rdquo; he said.</p>
<p><strong>Memories of Andy</strong></p>
<p>Roebuck also talked about working with Andy Griffith on &ldquo;Matlock,&rdquo; which transpired after a circuitous, typically Hollywood path. After initially appearing on the program in its first season, Griffith was so impressed with Roebuck&rsquo;s work that he promised the young actor he would have a regular role on the show, according to the Internet Movie Database (IMDb) website.</p>
<p>This would take five seasons, two additional guest appearances as different characters and a change of networks, from NBC to ABC, but Griffith kept that promise and Roebuck finally became a series regular.</p>
<p>&ldquo;What I remember most about my time with Andy Griffith is that there wasn&rsquo;t a day when we weren&rsquo;t laughing and smiling and having a good time,&rdquo; Roebuck recalled Tuesday, which was despite the hard, grueling work required by episodic TV. The veteran actor also took an interest in Roebuck&rsquo;s personal life.</p>
<p>&ldquo;Andy was instrumental, pardon the pun, in helping my wife pick the music for our wedding,&rdquo; he said. It incorporated a trombone choir, hearkening back to Griffith&rsquo;s time in Mount Airy when he learned to play that member of the brass family.</p>
<p>Roebuck also remembers how Griffith wore black sneakers due to suffering from Guillain-Barre syndrome, a disorder accompanied by weakness and tingling in the feet. Roebuck said he has copied that approached by wearing such footwear all the time, even with suits and other formal attire.</p>
<p>&ldquo;If it was good enough for Andy Griffith, it was good enough for me,&rdquo; he reasoned Tuesday.</p>
<p>The 10-year anniversary of Griffith&rsquo;s death in July 2012 at age 86 is approaching.</p>
<p><strong>Social media material</strong></p>
<p>Daniel Roebuck&rsquo;s more recent projects have included working on a reboot of the classic TV series &ldquo;The Munsters,&rdquo; playing Grandpa Munster in a role that merges his two favorite genres, horror and comedy. Spearheading that production was the singer, songwriter, filmmaker and voice actor Rob Zombie.</p>
<p>Roebuck wore a Munsters ball cap while in Mount Airy.</p>
<p>One of Roebuck&rsquo;s reasons for visiting Mount Airy this week was to film material for his own social media channels. This included capturing some scenes at the Mayberry Courthouse site, where he took on the jobs as director and actor.</p>
<p>&ldquo;He&rsquo;s wanting to support our city for his social media outlets,&rdquo; said local Tourism Development Authority Executive Director Jessica Roberts, who called Roebuck &ldquo;a really interesting guy.&rdquo; She, Brown and Jenny Smith of Mount Airy Visitors Center helped guide him to the various locations Tuesday.</p>
<p>&ldquo;I think it is amazing that he is interested in our town,&rdquo; Roberts said, and seeking to present it on his social media network. &ldquo;I just think he wants to be a part of what&rsquo;s going on in Mayberry.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110748/museum-expands-hours-for-summer" title="Museum expands hours for summer" style="color:black">Museum expands hours for summer</a></h1>
   <p class="entry-meta">June 14, 2022</p>
   <p>The days are long, the afternoons hot, and the Mount Airy Museum of Regional History has changed its hours.</p>
<p>The facility has switched over to summer hours, meaning it is open Monday through Saturday from 10 a.m. until 5 p.m., and on Sunday from 1 to 4 p.m.</p>
<p>&ldquo;The hours aren&rsquo;t the only thing changing, and we will soon be opening up new exhibit spaces including our kid&rsquo;s gallery,&rdquo; officials there said recently. &ldquo;We are also bringing back beloved events and programs such as our children&rsquo;s summer camps in June and July and Ghost Tours on Friday and Saturday evening at 8 p.m.&rdquo;</p>
<p>While most events there have a charge, many offer a discount for museum members. A full-year family membership is $55. For more information, contact the museum at mamrh@northcarolinamuseum.org or call 336-786-4478, or visit in person at 301 N. Main St.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110743/former-commissioner-calls-for-tax-cut" title="Former commissioner calls for tax cut" style="color:black">Former commissioner calls for tax cut</a></h1>

            <a href="https://www.mtairynews.com/news/110743/former-commissioner-calls-for-tax-cut" title="Former commissioner calls for tax cut">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128601816_web1_Shirley-sez-this.jpg" alt="Former commissioner calls for tax cut">
            </a>
   <p class="entry-meta">June 14, 2022</p>
   <p>While she was serving on the Mount Airy Board of Commissioners, Shirley Brinkley was among the majority voting for a 25% increase in city property taxes &mdash; but now is singing a different tune.</p>
<p>Brinkley is advocating that taxes be slashed in the municipal budget for the 2022-23 fiscal year that begins on July 1, which the present council members possibly will adopt during a meeting this Thursday night without such a cut.</p>
<p>Although the proposed $18.4 million budget, released last month, is $3.5 million higher than that approved in June 2021 for the present fiscal year, the property tax rate is projected to remain at 60 cents per $100 of assessed valuation.</p>
<p>That might satisfy some citizens, yet Brinkley, a former South Ward commissioner who served two terms, believes the board should go an extra step given the present state of affairs with consumers hit by record gas prices and inflation at a 40-year high.</p>
<p>&ldquo;A tax cut in this economy should have been your priority instead of increasing the budget by $3.5 million,&rdquo; Brinkley told city officials while speaking during a public hearing on the spending plan at a meeting earlier this month.</p>
<p>That increase is largely due to Mount Airy&rsquo;s receiving of about $3.2 million in federal COVID-relief funding through the American Rescue Plan Act, which is reflected in the overall municipal budget even though local tax dollars aren&rsquo;t involved.</p>
<p>The bulk of that funding is proposed to be spent on a long list of projects during the next fiscal year, mainly including major building and equipment needs at City Hall, Reeves Community Center and elsewhere.</p>
<p>Brinkley implied that city officials should have found some way within the budget parameters to reduce property taxes rather than increase spending on items that do not directly help local residents.</p>
<p>&ldquo;You are here to make changes and improvements that will benefit all citizens of Mount Airy, and I say all &mdash; not the few here and there.&rdquo;</p>
<p>The former commissioner added, &ldquo;I see many on this board making your decisions, and forgive me for saying this, in a vacuum,&rdquo; and not &ldquo;looking at the needs of all the citizens.&rdquo;</p>
<p>Brinkley punctuated her comments with stern criticism.</p>
<p>&ldquo;I&rsquo;m just going to say, shame on you,&rdquo; Brinkley told the commissioners at one point, warning that some would be held accountable come ballot time in November.</p>
<p>&ldquo;Elections are on the horizon &mdash; voters are putting their eyes on those running that are honest and will keep their word, those committed to tax cuts,&rdquo; she said.</p>
<p>&ldquo;If I stepped on toes, I apologize,&rdquo; Brinkley concluded in her remarks to city officials. &ldquo;If you felt anything, maybe you had a little conscience from what I said.&rdquo;</p>
<p>Ironically, Brinkley was on the city council the last time property taxes were raised, in June 2018 when the rate jumped from 48 to 60 cents. Before that, the last tax increase had occurred in 2007.</p>
<p>Part of the 2018 hike was due to Brinkley&rsquo;s insistence that city firefighters get a raise.</p>
<p>For the next fiscal year, full-time municipal employees are recommended to receive a $1,500 increase.</p>
<p><strong>Mayor pro tem responds</strong></p>
<p>Brinkley was up for re-election in 2019, but chose not to run for a third term.</p>
<p>Instead Marie Wood successfully campaigned that year for the South Ward seat held by Brinkley and in addition to serving as a commissioner is the city&rsquo;s mayor pro tem, or vice mayor, who presides in the absence of the chief executive.</p>
<p>With Mayor Ron Niland not attending the last council meeting when Brinkley spoke, it fell to Wood to respond to Brinkley&rsquo;s address &mdash; including her belief that now is not the time to reduce taxes.</p>
<p>Based on Wood&rsquo;s statements, this is because the municipality is facing a financial crunch the same as private consumers.</p>
<p>&ldquo;Things are going up &mdash; they are not going down,&rdquo; she said of prices.</p>
<p>In her opinion, &ldquo;it will be impossible to cut taxes &mdash; in this environment,&rdquo; Wood added.</p>
<p>&ldquo;Would I love to have my taxes cut? Absolutely,&rdquo; she said. &ldquo;But I don&rsquo;t see that as a possibility &mdash; I&rsquo;m saying I just don&rsquo;t.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110736/police-reports-582" title="Police reports" style="color:black">Police reports</a></h1>
   <p class="entry-meta">June 13, 2022</p>
   <p>&#8226; A Virginia woman was the victim of a recent break-in of a motor vehicle in Mount Airy, according to city police reports.</p>
<p>The crime was discovered on June 5 at a residence in the 1200 block of Greenhill Road, which involved an undisclosed sum of money and a portable battery charger valued at $30 being stolen from an unsecured vehicle. The owner of the property was identified as Charlotte Pamela Cloud of Robin Ridge Road in Cana.</p>
<p>&#8226; Michelle O&rsquo;Rourke Brown, 54, of 211 Locklear St., was jailed without privilege of bond on the evening of June 7 for her alleged violation of a protective order. It had been filed by Surry County authorities the day before, with Linda Malmquist of Brindle Road in Dobson listed as the complainant.</p>
<p>A warrant in the matter was served on Brown at Mount Airy Bowling Lanes. She is scheduled to appear in District Court on June 28.</p>
<p>&#8226; Michael Edward Salisbury, 20, of 3411 Meadowbrook Road in Cana, Virginia, was served with an outstanding criminal summons for a charge of injury to real property on June 4, after officers responded to a call of an intoxicated pedestrian at Walmart.</p>
<p>Further investigation revealed Salisbury to be the subject of that summons, which had been issued on Feb. 18 with no other details listed. The case is set for Wednesday&rsquo;s session of District Court.</p>
<p>&#8226; Police learned on June 1 that a break-in had occurred at a vacant residence on Fairlane Drive owned by Nancy Marion of that street. Household goods were stolen during the incident, with no loss figure supplied.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110717/taking-it-to-the-streets" title="Taking it to the streets" style="color:black">Taking it to the streets</a></h1>

            <a href="https://www.mtairynews.com/news/110717/taking-it-to-the-streets" title="Taking it to the streets">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128603450_web1_RollingOff.jpg" alt="Taking it to the streets">
            </a>
   <p class="entry-meta">June 13, 2022</p>
   <p>The hogs ran loose from Veterans Memorial Park in Mount Airy this past weekend as the First Mount Airy Men&rsquo;s Shelter Summer Festival Motorcycle Ride took place to help raise money for the cause. It was the first of its kind event for the charity, whose organizers hope to open a year-round homeless shelter for men in need in Mount Airy.</p>
<p>The reason for the festival was to bring awareness to and raise needed funds for the Mount Airy Men&rsquo;s Shelter. Since she began speaking to groups such as the Rotary Club of Mount Airy last fall, Ann Simmons has been leading a team on a mission to secure land, break ground, and open doors of a dedicated shelter.</p>
<p>While the target need is for single men, she has said that there should be room available, if possible, for homeless men who may have children, or families in need. It is something that she feels she was called to do to improve the lives of others.</p>
<p>Under a bright sun the field along West Lebanon Street was filled with dozens of vendors selling their wares. Kids had bounce castle options which is always a good position for them to be in. As the adults wandered through the stalls more than one jealous eye was cast toward a flagon of refreshing strawberry lemonade or a tasty looking Aunt Bea&rsquo;s sandwich.</p>
<p>With the sounds of Santo Chessari Jr. belting out the hits of Neil Diamond and local talent Kinston Nichols serenading with a range from Sinatra to Green Day, it was an all-ages affair.</p>
<p>Dancers entertained the crowd from Danceworks as well as the Surry and Carroll County Dance Centers who were recently featured at the Daytona 500. Kids ran loose as raffles were held for golf clubs and an outdoor griddle that was drawing lots of attention.</p>
<p>The main draw was the motorcycle ride though and after some safety instructions and prayer from Ron Mathews, more than 60 bikes rolled off as their throaty engines called for all in attendance to turn their heads and see.</p>
<p>Organizers of the Mount Airy Men&rsquo;s Shelter are working toward building a facility on West Lebanon Street that would be near the Daymark Treatment center. They want to be able to house single men, men with children, and families out of the elements be it the heat and humidity of the summer, or freezing temperatures in winter.</p>
<p>The founders want to help the homeless by having a &ldquo;safe and secure place to lay their heads with hot meals readily available.&rdquo; The end goal is a year-round full-time facility where they can provide access to health resources, job skills training, money management/budgeting, public relations skills training, and access to regular meetings to help those with substance use disorder.</p>
<p>Offering more than just a pillow or a meal, the Mount Airy Men&rsquo;s Shelter wants to help men transition back to what many of them desire: independent living. With counseling, skills classes, meetings, and a location across the street from one of the area&rsquo;s major treatment centers &mdash; the shelter has the potential to significantly change lives.</p>
<p>The founders also point to a potential long-term savings to the taxpayers of Surry County. &ldquo;Part of their mission states that &lsquo;The community endures the cost if we do not provide for and address the issues of male homelessness in Surry County.&rsquo;&rdquo;</p>
<p>Costs can get passed back to the community when the homeless are arrested for trespassing on a cold night. Or, when one arrives to the emergency department at Northern Regional Hospital, they will not be turned away from not having health insurance; the hospital will have to recoup those costs somehow.</p>
<p>The recently begun Strengthening Systems for North Carolina Children program is looking at these issues, such as homelessness, as traumatic factors that can have a negative impact on a child. The Mount Airy Men&rsquo;s Shelter could be one of the potential mitigation solutions to remove the adverse childhood experience of homelessness from that child. Also, the skills training may be the plus-one addition that a parent needs to break their cycle of unemployment.</p>
<p>Simmons knows those are the potential long-term outcomes, but she managed to keep her eyes focused on what is right ahead of her over the weekend. For her event she said, &ldquo;The best part of the day were the tireless volunteers who came and helped out, the Aunt Beas crew who donated and served food.&rdquo;</p>
<p>&ldquo;Thanks to Santos who kept the music going and Kinston Nichols who put on a great performance &mdash; I hear he&rsquo;s ready to put a band together,&rdquo; she offered. &ldquo;The girls dance teams from Danceworks Inc, Surry County Dance Center and Carroll County Dance Center, were all really good. I don&rsquo;t think I ever moved that much as a child.&rdquo;</p>
<p>What The Mount Airy Men&rsquo;s Shelter founders have done is identify a need, one that has a target audience and a goal to help the homeless help themselves. To get the fundraising ball moving for them this past weekend&rsquo;s Summer Festival helped bring in some funds they will use to move forward. &ldquo;We are all exhausted but super happy for all the exposure for the Mount Airy Men&rsquo;s Shelter.&rdquo;</p>
<p>In the interim they will continue to help with food services for the homeless and being an advocate for those in need. More information and ways to help the Mount Airy Men&rsquo;s Shelter can be found at: www.mountairymensshelter.com.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110711/museums-first-camp-week-a-hit" title="Museum&#8217;s first camp week a hit" style="color:black">Museum&#8217;s first camp week a hit</a></h1>

            <a href="https://www.mtairynews.com/news/110711/museums-first-camp-week-a-hit" title="Museum&#8217;s first camp week a hit">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128605689_web1_20220610_101723.jpg" alt="Museum&amp;#8217;s first camp week a hit">
            </a>
   <p class="entry-meta">June 13, 2022</p>
   <p>Seven area youths got a chance to paint, build their own rockets, test out parachuting, and release butterflies from downtown during the Mount Airy Museum of Regional History&rsquo;s STEM Jr. Camp.</p>
<p>Cassandra Johnson, program and education director at the museum, said many of the activities were designed to be hands on, and meant to connect science with history.</p>
<p>&ldquo;There&rsquo;s not a lot of connection between science and history in the classroom,&rdquo; she said recently. Johnson planned last week&rsquo;s camp activities to show how important science is today, and how vital it was to pioneers settling the region in centuries past.</p>
<p>While the STEM camp is over, there will be other opportunities for area youth to attend the museum&rsquo;s summer activity camps.</p>
<p>The next session will be the Explorers Camp June 20-June 24, from 1 p.m. to 5 p.m. each day, for ages 8 to 13.</p>
<p>&ldquo;If your child is more about being outside and hands-on, this is really the camp that I recommend,&rdquo; she said. &ldquo;We&rsquo;ll have a butterfly display, a butterfly release, we&rsquo;ll go down to Riverside Park one day, we&rsquo;ll be learning basic things about bird watching, local plants, bees&#8230;making a compass&#8230;a sun dial, a little about star charting and navigating,&rdquo; all skills settlers to the region and earlier residents would have used and needed.</p>
<p>The cost of the camps for the general public is $100, with additional children in a family getting a $10 discount for the week. For museum members, she said the cost is discounted $20, so one child would cost $80, additional children from the same family would cost $70.</p>
<p>Johnson said parents should pack a snack for their child each, because there is a brief snack period each day. For more information about the camps, or the museum, call 336-786-4478 or visit the website at https://www.northcarolinamuseum.org/</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110708/jones-intermediate-named-leader-in-me-school" title="Jones Intermediate named Leader In Me School" style="color:black">Jones Intermediate named Leader In Me School</a></h1>

            <a href="https://www.mtairynews.com/news/110708/jones-intermediate-named-leader-in-me-school" title="Jones Intermediate named Leader In Me School">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128572787_web1_IMG_8025-382x509.jpg" alt="Jones Intermediate named Leader In Me School">
            </a>
   <p class="entry-meta">June 13, 2022</p>
   <p>JJ Jones Intermediate School recently learned it has been certified and named as a Leader in Me Lighthouse School by FranklinCovey Education.</p>
<p>&ldquo;This recognition is evidence that the school has produced outstanding results in school and student outcomes, by implementing the Leader in Me process with fidelity and excellence,&rdquo; the Mount Airy City Schools system said. &ldquo;It is also because of the extraordinary impact the school is having on staff, students, parents, and the greater community.&rdquo;</p>
<p>Leader in Me is an evidence-based PK-12 model, developed in partnership with educators, designed to build perseverance and leadership in students, create a high-trust culture, and help improve academic achievement. This model equips students, educators, and families with the leadership and life skills needed to thrive, adapt, and to contribute in a dynamic world.</p>
<p>With Leader in Me, students learn to become self-aware, interdependent, take initiative, plan ahead, set and track goals, do their homework, prioritize their time, be considerate of others, communicate effectively, resolve conflicts, find creative solutions, value differences, live a balanced life, and contribute to society.</p>
<p>&ldquo;Our school is honored to be recognized as a Leader in Me Lighthouse School,&rdquo; said Principal Chelsy Payne. &ldquo;The Leader in Me has helped our students, staff, and families with setting goals, tracking progress, and celebrating success. In addition, it has allowed us to invest in students&rsquo; leadership roles and give back to the greater community. One of my favorite aspects of The Leader in Me is Student Led Conferences. I appreciate how being a Lighthouse School empowers us to shed a beacon of light and make a positive difference for the future.&rdquo;</p>
<p>&ldquo;We are thrilled to recognize Jones Intermediate as a Leader in Me Lighthouse School,&rdquo; said Sean Covey, president of FranklinCovey Education. &ldquo;Schools who achieve this Lighthouse Certification are great examples of a strong leadership model , and of what it means to be a Leader in Me school. This school has experienced incredible results by implementing the principles and practices related to Leader in Me. And we are so pleased and honored to be their partner and to celebrate the success they are experiencing.&rdquo;</p>
<p>Since its official launch nearly a decade ago, more than 5,000 public, private, and charter schools across 50 countries have adopted the Leader in Me process, while nearly 600 schools have achieved the Lighthouse Certification. It is earned by schools that demonstrate the following:</p>
<p>&#9679; The principal, school administration and staff engage in ongoing learning and develop as leaders, while championing leadership for the school;</p>
<p>&#9679; Leadership principles are effectively taught to all students through direct lessons, integrated approaches, and staff modeling. Students are able to think critically about and apply leadership principles;</p>
<p>&#9679; Families and the school partner together in learning about the 7 Habits and leadership principles through effective communication and mutual respect;</p>
<p>&#9679; The school community is able to see leadership in the physical environment, hear leadership through a common language, and feel leadership through a culture of caring, relationships, and affirmation;</p>
<p>&#9679; Leadership is shared with students through a variety of leadership roles and student voice leads to innovations within the school;</p>
<p>&#9679; Schoolwide, classroom, family and community leadership events provide authentic environments to celebrate leadership, build culture, and allow students to practice leadership skills;</p>
<p>&#9679; The school utilizes the 4DX process to identify and track progress toward Wildly Important Goals for the school, classroom, and staff;</p>
<p>&#9679; Students lead their own learning with the skills to assess their needs, set appropriate goals, and carry out action plans. They track progress toward goals in Leadership Notebooks and share these notebooks with adults in student-led conferences;</p>
<p>&#9679; Teacher planning and reflection, trusting relationships, and student-led learning combine to create environments for highly engaged learning.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110695/city-garden-tour-a-blooming-success" title="City garden tour a blooming success" style="color:black">City garden tour a blooming success</a></h1>

            <a href="https://www.mtairynews.com/news/110695/city-garden-tour-a-blooming-success" title="City garden tour a blooming success">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128601591_web1_Grow-this-1.jpg" alt="City garden tour a blooming success">
            </a>
   <p class="entry-meta">June 13, 2022</p>
   <p>There were plenty of friendly, knowledgeable folks to be found along the Mount Airy Blooms tour of gardens &mdash; but the real stars of that event were the plants. </p>
<p>Those taking in the tour Saturday were treated to a colorful and imaginative showcase of gardens at local residences &mdash; eight in all &mdash; plus a variety of informative displays by Surry County Master Gardeners at what is known as the Blue House, located downtown.</p>
<p>Visits to the different stops occurred on a self-guided basis, which produced steady traffic during the morning and afternoon hours, with a common theme evident at each location: an appreciation for greenery and beauty that highlighted the joys of gardening.</p>
<p>&ldquo;When I&rsquo;m in my garden, I&rsquo;m in a different zone,&rdquo; explained Carla Kartanson, whose home on North Main Street was one of the tour stops.</p>
<p>&ldquo;It&rsquo;s my spiritual time,&rdquo; Kartanson added, when she can escape the pressures of the outside world and achieve a sense of comfort while working with or simply enjoying the plants &mdash; one going hand in hand with a certain mental state.</p>
<p>&ldquo;I think you have to put yourself in a zone.&rdquo;</p>
<p><strong>Improvisation a key</strong></p>
<p>While inspiring others to take up the gardening hobby and make the community a greener, more attractive place, the Mount Airy Blooms tour also emphasized how one can utilize whatever space is available &mdash; regardless of light and other factors.</p>
<p>That is certainly true at Kartanson&rsquo;s home featuring a well-positioned site with southern-exposure chock full of flowering plants, including a colorful display of zinnias.</p>
<p>&ldquo;I was inspired by Herb&rsquo;s,&rdquo; she said of nearby resident Herb Mason, whose home also was part of Saturday&rsquo;s tour, with Kartanson a first-time participant in the event.</p>
<p>&ldquo;The irises were already here when I moved here,&rdquo; Kartanson said of relocating about 4.5 years ago from Texas, where she lived for a lengthy period and worked in the homebuilding field, after growing up in this area. Her flower garden also includes such varieties as Easter lilies, gerbera daisies, lantana and others.</p>
<p>But one thing Kartanson wanted visitors to take away from Saturday&rsquo;s tour was the fact that lack of sunlight needn&rsquo;t be a hindrance to plant growth. That is evident with her front yard facing the busy North Main Street, a shaded area where grass would not even grow well, she discovered upon moving here.</p>
<p>Though some homeowners purposely provide alternate landscaping just to avoid mowing their lawns, it was a necessity in Kartanson&rsquo;s case. She researched plant species that thrived under low-light conditions and the result is a well-arranged grouping of mulched beds bearing rhododendron, azaleas and similar varieties that collectively create an attractive, engaging spot.</p>
<p>Kartanson has been involved in gardening for about 40 years, since &ldquo;I first got married and started moving around and bought homes.&rdquo;</p>
<p>Before returning to her native area, Kartanson lived in Dallas, in a gated community where yards were strictly regulated &mdash; fostering what she indicated was a state of conformity and uniformity that discouraged free-form gardening.</p>
<p>She was happy to move to the home in Mount Airy where her creative energies can run free.</p>
<p><strong>Master Gardeners in force</strong></p>
<p>In addition to picking up plant tips from the various residences along the tour, participants were treated to a one-stop, virtual oasis of educational exhibits at the Blue House of the Gilmer-Smith Foundation at 615 N. Main St.</p>
<p>About five different stations were set up at tents in the back yard there by Master Gardeners, including a display of live plants native to the area and one showcasing container gardening.</p>
<p>At another location, visitors were warned about the dangers of the spotted lanternfly, an invasive species that is steadily encroaching on this region. That insect is a known pest of grapes, apples, maples, oaks and others.</p>
<p>On a less-menacing note, Tasha Greer of Lowgap, a Master Gardener for six years and also an author, displayed and answered questions about an array of edible plants she brought along, such as garlic, kale, artichokes and breadseed poppy.</p>
<p>Saturday&rsquo;s tour was presented by Mount Airy garden clubs, with Event Coordinator Anne Webb pleased with the turnout for the every-other-year attraction.</p>
<p>Proceeds from Mount Airy Blooms will benefit several appearance projects locally, including the rose garden at Joan and Howard Woltz Hospice Home and restoration of grounds at the historic Moore House.</p>
<p>Money also is targeted for the maintenance and upkeep of a mini-garden and fountain at the junction of North Main and Renfro streets and maintenance for a pollinator garden on South Main Street near the Municipal Building.</p>
<p>Another beneficiary will be exceptional children&rsquo;s classes at B.H. Tharrington Primary School, for which special programming is to be provided.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110684/two-awarded-robin-hodgin-scholarships" title="Two awarded Robin Hodgin scholarships" style="color:black">Two awarded Robin Hodgin scholarships</a></h1>

            <a href="https://www.mtairynews.com/news/110684/two-awarded-robin-hodgin-scholarships" title="Two awarded Robin Hodgin scholarships">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128598559_web1_Kylie-Bruner-382x509.jpg" alt="Two awarded Robin Hodgin scholarships">
            </a>
   <p class="entry-meta">June 12, 2022</p>
   <p>Northern Regional Hospital recently awarded the 2022 Robin Hardy Hodgin Education Scholarship to two area students pursuing a career in the healthcare field. Each will receive a $5,000 scholarship.</p>
<p>Liszbhet Hernandez, of Mount Airy, and Kylie Bruner, of Pilot Mountain, were the two scholarship recipients.</p>
<p>Liszbhet is a 2022 graduate of Surry County Early College High School and will attend UNC-Charlotte in the fall to pursue an associate&rsquo;s degree in nursing. Lizbhet&rsquo;s aspirations for healthcare began at a young age, and she has volunteered at Dunmoore Plantation Assisted Living Alzheimer&rsquo;s Care Unit and at Surry Medical Ministries.</p>
<p>&ldquo;I was overjoyed to learn I had been chosen for this award, and I am thankful and grateful,&rdquo; she said. &ldquo;This scholarship will help me with my overall cost of tuition and books. I plan to use this scholarship towards my books and with the money that is leftover, I&rsquo;ll pay off my tuition. I plan to be driven to succeed in the future and winning this scholarship will help me be one step closer to achieving my goal to become a nurse.&rdquo;</p>
<p>Kylie is a 2022 graduate of East Surry High School and plans to begin her studies to become a nurse practitioner at UNC-Chapel Hill in the fall. She is working as a certified nursing assistant in Northern Regional Hospital&rsquo;s Pre-Apprentice Program. Bruner has aspired to a career in healthcare since the age of 6, when she lost two of her grandparents to cancer.</p>
<p>&ldquo;The scholarship provided to me by the Robin Hardy Hodgin Scholarship Fund will benefit me by providing a slight relief from the added stress of paying for college. I am so thankful to become a recipient of this scholarship because I feel valued and held to a great honor being chosen by the scholarship committee. As I embark on my educational nursing journey, the Robin H. Hodgin scholarship allows me to go to college more empowered and with less worry about the cost of my education,&rdquo; she said.</p>
<p>Historically, the foundation has awarded 10 individual $1,000 scholarships, but this year, the committee chose to award two scholarships in the amount of $5,000 each to two graduates, screened and selected by a team of hospital leaders. The scholarship can be used to cover the cost of tuition, books, and supplies for selected students who enroll in accredited healthcare programs in the areas of nursing, pharmacy, or other allied-health professions. The scholarship, established in the 201-2020 school year, has already awarded $28,000 to support local graduates going into a healthcare field.</p>
<p>&ldquo;This valuable program provides a much-needed helping hand to deserving students who have chosen to pursue fulfilling careers in healthcare while honoring the distinguished and ongoing career of Robin Hodgin, one of the most gifted and committed nursing leaders we have at Northern Regional Hospital,&rdquo; said Chris A. Lumsden, president and chief executive officer of Northern Regional Hospital. &ldquo;It is one of the numerous ways Northern provides support for our local youth, and exemplifies our commitment to education.&rdquo;</p>
<p>Northern Regional Hospital established the scholarship program in October 2019, named in honor of Senior Vice President for Patient Services and Chief Nursing Officer Robin H. Hodgin. The scholarship is funded through private donations, matched dollar-for-dollar by the Northern Regional Foundation. The Hospital&rsquo;s Scholarship Committee awards one-time scholarships for up to 10 eligible students enrolled in a health science degree-granting program at an accredited college or university of their choice.</p>
<p>Scholarships are awarded to prospective students who reside in Surry County and the surrounding region and aspire to a career in nursing or allied-health professions &#8211; including respiratory therapy, physical therapy, medical imaging technology, laboratory science, pharmacy, and others.</p>
<p>&ldquo;I am honored to serve on the scholarship committee for the Robin Hardy Hodgin Education Scholarship,&rdquo; said Tina Beasley, executive assistant for Northern Regional Hospital. &ldquo;This scholarship is a testament to the talents and leadership of Northern Regional Hospital&rsquo;s top nursing executive, Robin Hodgin, who has served our hospital for more than 40 years. This scholarship program is designed to help jumpstart their careers of students pursuing a career in nursing or allied health. Recipients are chosen based on merit, academics, community involvement, and financial need. This year, both recipients ranked in the top 5 of their class and had high GPAs. Both students were involved in many extra-curricular and community activities. Each student received outstanding recommendations from their teachers and school administrators. We have no doubt that both Kylie and Lizbhet will represent Northern Regional Hospital well.&rdquo;</p>
<p>For more information about the Robin Hardy Hodgin Scholarship Fund, about Northern Regional Hospital Foundation, and to donate, visit wearenorthern.org. </p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110682/studnicki-recognized-for-volunteerism" title="Studnicki recognized for volunteerism" style="color:black">Studnicki recognized for volunteerism</a></h1>

            <a href="https://www.mtairynews.com/news/110682/studnicki-recognized-for-volunteerism" title="Studnicki recognized for volunteerism">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128598386_web1_Jeannie-no-bottle-this.jpg" alt="Studnicki recognized for volunteerism">
            </a>
   <p class="entry-meta">June 12, 2022</p>
   <p>Unlike others who serve Mount Airy in highly visible positions, city Planning Board members often labor in relative obscurity while playing important roles &mdash; but efforts were undertaken to ensure one member&rsquo;s contributions didn&rsquo;t go unnoticed.</p>
<p>Jeannie Studnicki recently was honored during a city council meeting for her volunteerism as a member of the Mount Airy Planning Board for nearly seven years &mdash; the last two as its chairman.</p>
<p>Studnicki&rsquo;s present term on that board will expire this year and she is not eligible for reappointment due to serving the maximum time allowed.</p>
<p>The planning group is an advisory board to the Mount Airy Board of Commissioners on growth-related matters such as rezoning and annexation requests.</p>
<p>It analyzes present and emerging land-development trends and activities and recommends plans, policies and ordinances designed to maximize opportunities for growth while promoting public health, safety, morals and welfare.</p>
<p>The Planning Board gets first crack at zoning and land-use issues coming before the municipality which prove controversial at times, taking preliminary action on such matters in making recommendations to the commissioners for final decisions.</p>
<p>Studnicki has a marketing background and other business expertise, which has included being responsible for spearheading extensive and sustainable growth strategies for Fortune 500 companies.</p>
<p>She grew up in Ontario, Canada, and came to New York as a student-athlete before eventually making her way to Mount Airy.</p>
<p>Studnicki has taken a special interest in historic-preservation efforts while serving with the Planning Board. That included taking a lead role in recent years to have areas of Mount Airy with architecturally valuable sites added to the National Register of Historic Places.</p>
<p>&ldquo;We have been very fortunate to have a person of your capabilities serving the city of Mount Airy,&rdquo; Mayor Ron Niland told Studnicki during a late-May council meeting when she received a certificate of appreciation for her work with the planning group.</p>
<p>&ldquo;That&rsquo;s going to be a big void to fill on that board,&rdquo; Niland added in reference to Studnicki&rsquo;s departure. &ldquo;So we want to recognize her for the invaluable contribution she has made while serving on our Planning Board.&rdquo;</p>
<p>In remarks afterward, Studnicki &mdash; who joined that group in 2015 when she was appointed to an initial three-year term as the replacement for N.A. Barnes, who rotated off &mdash; mentioned that this also has been a good experience for her.</p>
<p>&ldquo;It&rsquo;s been a special time,&rdquo; she said. &ldquo;I have learned so much.&rdquo;</p>
<p>A spirit of community was evident in her response to being honored by the city government.</p>
<p>&ldquo;I&rsquo;ve lived here for quite a while now,&rdquo; Studnicki said of Mount Airy, where she has made a contribution in other volunteer roles in addition to the planning group.</p>
<p>&ldquo;And it&rsquo;s nice to be able to contribute to its success and its growth.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110677/110677" title="" style="color:black"></a></h1>

            <a href="https://www.mtairynews.com/news/110677/110677" title="">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128595708_web1_1.-Assessment-reminder-417x509.jpg" alt="">
            </a>
   <p class="entry-meta">June 12, 2022</p>
   <p>In this day and age, most people will rarely have to use the services of their local funeral home, which is something to be grateful for. But that wasn&rsquo;t always the case, and the public&rsquo;s interaction with these businesses used to be much more prevalent &mdash; funeral homes used to also function as a basic ambulance service, and provided an early form of life insurance.</p>
<p>Before the mid 1800s, the care of the recently deceased was left up to the family. It was up to them to build coffins and sometimes even dig the graves. Times were harsh, living and working conditions were poor, which led to high mortality rates. Families preparing their deceased loved ones for burial was a common occurrence.</p>
<p>Luckily, for much of recent history, these duties can be designated to funeral homes, allowing the family to mourn without the added trauma. However, preparing for funerals has not always been the sole duty of funeral homes; they have historically fulfilled other roles in their communities.</p>
<p>Starting in the 1800s, funeral homes also fulfilled the essential service of transporting the sick and injured, much like a modern emergency medical service. Before the Surry County EMS program began in 1974, many funeral homes in Surry County had their own ambulances. Though it may seem strange to us now, it was a practical choice, as funeral directors were already on call 24/7 for funeral purposes. More importantly, hearses could be easily adapted to both function as hearses and ambulances due to their design and their size.</p>
<p>One of the first records of a hearse in Mount Airy is from 1892. Totten and Poole funeral home, which would eventually become Moody&rsquo;s funeral home, was the first to purchase a hearse for the community.</p>
<p>In 1935, Ashburn and Calloway Funeral Home, having recently moved into its remodeled building on Pine Street, replaced its old combination ambulance and funeral coach with a new Chrysler. The vehicle was picked up by co-owner JE Calloway in Ohio and driven back to Mount Airy, where it was put on display for the public to view. An advertisement for this car promoted that it was equipped with hot and cold running water, electric fans for the summer, heating for the winter, and all first aid equipment that could be needed.</p>
<p>Another local establishment, Hennis Funeral Home, located on North Main Street and opened in 1942, advertised its ambulance service in 1942 as being available day or night, and only costing $2.50 for calls within the city.</p>
<p>In 1938, Moody&rsquo;s Funeral Home purchased a new $4,000 Buick ambulance. With 140 horsepower, it was finished with a solid leather interior and was air conditioned. Moody&rsquo;s went beyond the conventional ambulance, and as of 1946, was also the Surry County and surrounding territory representative for the Air-Ambulance Service of Durham. The planes were advertised as the &ldquo;first fully organized aerial ambulance service in the US.&rdquo; The air ambulance was said to be able to transport the sick and injured to any part of the US within hours and had a nurse in attendance on all flights.</p>
<p>The community was also served by Mutual Burial Associations, an organization under which subscribers could pay a fee which would collectively go toward the funeral costs of the association&rsquo;s members. Locally, the Harrison Mutual Burial Association operated out of both Hannah Funeral Home and Moody&rsquo;s. In 1931, the association paid for at least 80 members&rsquo; funerals in 1931, each costing between $50-$100. (between $951 to almost $2,000 today). Membership for Harrison Mutual Burial Association was a 25 cent fee in 1936, up from 10 cents in 1932.</p>
<p>Moody&rsquo;s in Mount Airy&rsquo;s is the longest operating funeral home. Its origins date back to the 1870s, when Bob Totten operated a coffin and furniture business in Mount Airy. When E.A. Hannah moved to the area from Indiana, he purchased Totten&rsquo;s business, officially starting the business that would become Moody&rsquo;s in 1902.</p>
<p>Wade Moody began working at what was then called &ldquo;E.A. Hannah Harness and Coffins&rdquo; in 1915 at the age of just 19 with a salary of $25 a month. Less than a decade later, Moody would become co-owner of the business along with D.E. Nelson, before becoming sole owner in 1932. After World War II devastated an untold number of families, the home was staffed for the most part by veterans of both world wars. Wade Moody was known at the time for playing a leading role in the local posts of the American Legion and Veterans of Foreign Wars. As an article from 1948 states &ldquo;Moody&rsquo;s is not only an undertaker&rsquo;s establishment but also the center of many civic affairs and ventures.&rdquo; The business remains in the family to this day.</p>
<p><em>Katherine &ldquo;Kat&rdquo; Jackson is a staff member at the Mount Airy Museum of Regional History. Originally from Australia she now lives in King. She can be reached at the museum at 336-786-4478.</em> </p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110669/police-reports-581" title="Police reports" style="color:black">Police reports</a></h1>
   <p class="entry-meta">June 11, 2022</p>
   <p>&#8226; An Ararat woman was jailed Tuesday on charges stemming from a break-in at a local flea market last month, according to Mount Airy Police Department reports.</p>
<p>Shawn Phalen Murphy, 37, of 226 Pearman Lane, was encountered by investigating officers at the scene of the crime on May 15, a storage building at Bonnie Lou&rsquo;s Flea Market on Carter Street, where Jose Guadalupe Padron of Hemmings Street in Dobson was the victim of the breaking and entering &mdash; but fled as they approached.</p>
<p>Murphy was located by police Tuesday at a Welch Road location and arrested on warrants for charges filed the day of the incident on Carter Street, including felonious breaking and entering of a building along with three misdemeanors: resisting, delaying or obstructing a public officer; possession of a Schedule VI controlled substance (marijuana); and attempted larceny.</p>
<p>The Ararat woman also is facing unrelated charges, including four counts of failing to appear in court, issued Tuesday; a larceny charge filed by the Surry County Sheriff&rsquo;s Office on May 15; and a second-degree trespassing violation, May 12. Murphy was incarcerated under a $13,300 secured bond and is scheduled to appear in District Court on Monday.</p>
<p>&#8226; A costly piece of equipment was discovered stolen Wednesday morning from a parking lot at a construction site in the 1900 block of Caudle Drive. The Stihl Cutquik concrete saw owned by Wemco Contracting Inc. of Siloam Road, Dobson &mdash; orange in color and valued at $1,000 &mdash; was taken from a tool box.</p>
<p>&#8226; Kimberlee Monik Duncan, 41, of Pfafftown, was charged with first-degree trespassing on June 2 after allegedly refusing to leave a residence in the 500 block of Worth Street, from which she had been banned the same day in connection with a domestic investigation.</p>
<p>Duncan was released under a $1,000 unsecured bond to appear in Surry District Court on July 25.</p>
<p>&#8226; Two people were jailed on May 31 after police responded to a breaking and entering call at a residence in the 900 block of West Pine Street, where records indicated that glass windows were broken to gain entry.</p>
<p>Hannah Marie Schmidt, 28, and Timothy Travis Hicks, 45, both listed as homeless, are each charged with misdemeanor breaking and entering, with Schmidt additionally accused of possessing methamphetamine, a felony, and possession of drug paraphernalia.</p>
<p>Hicks also was found to be the subject of an outstanding arrest order for failing to appear in court which had been filed in June 2021. Both were confined in the Surry County Jail under $500 secured bonds and are to appear in District Court on July 25.</p>
<p>Christine Reece of Oak Ridge is listed as the victim of the illegal entry.</p>
<p>&#8226; A break-in was discovered on May 31 at the home of Jose Elias Rivera Reyes on Factory Street. Glass in a screen door was broken and a locked wooden door forced open in order to gain entry. Nothing was listed as stolen, but the property damage totaled $400.</p>
<p>&#8226; A case of financial card fraud was reported on May 30, which involved an apparently known individual using card information of Patty Sue Morton, a Newsome Street resident, to make an online payment without her permission.</p>
<p>The crime, for which the monetary loss was not listed, remained under investigation at last report.</p>
<p>&#8226; April Elizabeth Warren, 46, of 240 Starlite Road, No. 105, was jailed without privilege of bond on May 27, when she allegedly hit her boyfriend, Steven Erik McIntire of the same address, in the head with a lamp, fled from officers who responded to the domestic disturbance and subsequently was found with meth.</p>
<p>After allegedly running from the scene on foot and refusing to comply with police orders to stop, Warren was subdued and found with a small glass bottle containing the crystal-like substance.</p>
<p>She is charged with possession of methamphetamine, a felony; assault with a deadly weapon; resisting, delaying or obstructing a public officer; and possession of drug paraphernalia. Warren is slated for a July 11 court appearance. </p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110667/city-schools-foundation-holds-successful-dinner" title="City schools foundation holds successful dinner" style="color:black">City schools foundation holds successful dinner</a></h1>

            <a href="https://www.mtairynews.com/news/110667/city-schools-foundation-holds-successful-dinner" title="City schools foundation holds successful dinner">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128583979_web1_IMG_0206.jpg" alt="City schools foundation holds successful dinner">
            </a>
   <p class="entry-meta">June 11, 2022</p>
   <p>Mount Airy City Schools Educational Foundation recently held its first dinner aimed at raising money for &ldquo;innovative programming&rdquo; throughout the district. The night was met with celebrated success as the ballroom of Cross Creek Country Club was packed with more than 150 individuals ready to support children.</p>
<p>Superintendent Dr. Kim Morrison welcomed the group and explained how the foundation came to be and what it would support.</p>
<p>&ldquo;Our amazing Board of Education had the foresight to support an educational foundation that will ensure our innovative programs continue for generations to come. We are overwhelmed at the outpouring of support from the community to support these efforts and we are blessed to be in Mount Airy with such a great community of people who really care about the success of Mount Airy City Schools.&rdquo;</p>
<p>Deputy Superintendent Dr. Phillip Brown served as the evening&rsquo;s MC and introduced the various students who performed throughout the event.</p>
<p>The district&rsquo;s dual language immersion program, Language Leaders, was represented by kindergarteners from BH Tharrington Primary School. Students sang and danced while the salad was being served.</p>
<p>JJ Jones Intermediate School&rsquo;s Melody Makers followed with two songs and were led by Hollie Heller. During the serving of the main course, students shared their experiences in career and technical education and how the program has provided unique opportunities and connections for them.</p>
<p>Following the testimonials were individual student performances from middle school student Luca Livengood and high school student Angel Rivera accompanied by Meredith Dowdy, Mount Airy High School music teacher. During dessert, Mount Airy Middle School&rsquo;s Chorus, led by Jennifer Riska, performed three songs. Students involved in Mount Airy Middle School&rsquo;s Interact Club escorted guests to tables and selling raffle tickets for the foundation.</p>
<p>Career and Technical Education Director Olivia Sikes, Career Development Coordinator Catrina Alexander, foundation treasurer Lesa Hensley, and foundation board member Ellie Webb coordinated the event while foundation board members served as table hosts. At the close of the evening, $42,000 had been raised toward the $50,000 goal.</p>
<p>Sikes shared, &ldquo;Community involvement has always been a key factor to the success of our students. This event was yet another example of how blessed we are to serve in such a supportive community. Because of this support, students will continue to learn through innovative programming and enriched learning experiences.&rdquo;</p>
<p>The creation of this foundation provides the district with a third way that individuals can give. &ldquo;Three Ways to Give&rdquo; includes the Mount Airy Youth Foundation, alumni support through Mount Airy High School, and the Mount Airy City Schools Education Foundation. Each method of giving has a targeted purpose:</p>
<p>1. The youth foundation has been around for years and supports athletics in the district while also providing all students and staff with yearly passes to athletic events;</p>
<p>2. The alumni giving through the high school goes toward a designated project at the school. Funds from the alumni go toward a memorial being designed and built at the corner of N. South Street and Orchard Street to honor graduates who have served in the military. Once that project is complete, a new one will be presented;</p>
<p>3. The educational foundation will serve as an avenue for donors to give to the district&rsquo;s art programs, dual language immersion program, and CTE/workforce development programs.</p>
<p>&ldquo;I was thrilled with the support of the community and the willingness to get behind the foundation during its early stages,&rdquo; said Education Foundation Chair Kyle Leonard. &ldquo;I am so excited for the future and how the foundation will benefit all MACS kids towards their future. This is a special time for MACS and the future looks bright.&rdquo;</p>
<p>Anyone wishing to help the foundation reach their $50,000 goal can drop donations at the Community Central Office located at 351 Riverside Drive. Checks need to be written to the Mount Airy High School Education Foundation.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110658/blue-bear-cafe-cooks-up-success" title="Blue Bear Cafe cooks up success" style="color:black">Blue Bear Cafe cooks up success</a></h1>

            <a href="https://www.mtairynews.com/news/110658/blue-bear-cafe-cooks-up-success" title="Blue Bear Cafe cooks up success">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128596681_web1_Bear-this-1-599x509.jpg" alt="Blue Bear Cafe cooks up success">
            </a>
   <p class="entry-meta">June 11, 2022</p>
   <p>When passing by Mount Airy High School along North South Street, one notices the walls, sidewalks and signage of a typical educational institution &mdash; but probably don&rsquo;t realize that a thriving business is also within its confines.</p>
<p>During one recent morning at Blue Bear Cafe as the school year wound down, Ocean Davis, a senior, was putting the finishing touches on a fruit smoothie after earlier serving up cookies and brownies to an appreciative recipient. Chances are, another customer soon would be ordering a fresh-brewed cup of latte from the student-run operation.</p>
<p>The coffee at Blue Bear Cafe is reputed to be so tasty that teacher Ashley Pyles did not shy away from comparing what the kids prepare to that offered by a international coffeehouse chain:</p>
<p>&ldquo;They make the best coffee, hands-down, over Starbucks any day,&rdquo; Pyles said proudly.</p>
<p>Along with a variety of coffees &mdash; including frappe, latte and Americano &mdash; there are several flavors of fruit smoothies available, various sweet treats including bundt cakes, snack items, hot chocolate, cider and more.</p>
<p>The menu at Blue Bear Cafe further includes specialty drinks featuring what apparently has become a local sensation, bubble teas.</p>
<p>Yet perhaps the best product served up there is success &mdash; cooked up daily by apron-wearing student entrepreneurs who are gaining valuable business experience during the school year which can aid them in a career.</p>
<p>&ldquo;It&rsquo;s never about the coffee,&rdquo; Workforce Initiatives Coordinator Polly Long said when discussing the mission involved, or for that matter the caffeine, the stimulative ingredient of that popular beverage.</p>
<p>&ldquo;It&rsquo;s about the skills,&rdquo; added Long, a longtime school system employee who is being given much credit for making the on-campus business a reality.</p>
<p>&ldquo;A student-operated coffee shop has been a dream of Polly Long&rsquo;s for years,&rdquo; says a statement prepared in conjunction with the Blue Bear Cafe program receiving special city government recognition during a recent council meeting. That statement also references the role &ldquo;students with extraordinary talents&rdquo; have played in its success.</p>
<p>The cafe, which emerged in 2019, seeks to provide targeted youth with training in essential entry-level skills and create a pathway to employment in the service industry.</p>
<p>For example, junior Jennifer Griffin has her sights set on becoming a pastry chef.</p>
<p>Blue Bear Cafe operates through the Occupational Course of Study unit at the school and is overseen by teachers Jennifer Gentry and Ashley Pyles in addition to Long.</p>
<p>&ldquo;Jennifer is sort of our pastry chef,&rdquo; Gentry said of Griffin&rsquo;s go-to role in the operation.</p>
<p>About 10 students are enrolled in the program during a given academic year. They also take regular courses in addition to working a specified number of hours for the cafe, constituting class periods. It is open from 8 a.m. to 4 p.m. when school is in session.</p>
<p><strong>Student innovators</strong></p>
<p>Blue Bear Cafe occupies a strategic space in the high school&rsquo;s media center, which provides an inviting setting to enjoy a beverage or snack arguably rivaling that of any coffeehouse on the planet. The surroundings are pleasantly lit by large windows facing North South Street.</p>
<p>The place was arranged with the assistance of Goodwill Industries, Long said, which helped supply start-up funds to acquire new furniture and accessories.</p>
<p>It is tastefully adorned by walls painted in a soft-brown and olive-green color scheme, imprinted with phrases such as &ldquo;serving kindness one cup of the time&rdquo; and inspiring words including &ldquo;imagine,&rdquo; &ldquo;create,&rdquo; &ldquo;inspire&rdquo; and others.</p>
<p>Students respond by constantly adding new drinks and even developed a website to promote the business. A Blue Bear Cafe Facebook page is available to assist with orders.</p>
<p>The facility&rsquo;s spic-and-span kitchen is located in a side room, near a counter area where students check out library materials as part of dual, harmonious existence between the two facilities. A gift shop specializing in student-made products also is located at the cafe offering items including mugs and T-shirts and handcrafted items from local entrepreneurs.</p>
<p>Along with the culinary talents honed by the youths, other abilities are learned that they can apply to many additional career endeavors besides a coffee shop itself.</p>
<p>These include leadership, communication, organization skills and teamwork, plus the real-life functions of dealing the public in taking orders, making change from a cash register and processing credit card orders.</p>
<p>&ldquo;They&rsquo;re seeing it in real time,&rdquo; Long said of the impression left on those from the outside world who are able to witness education being applied to an actual enterprise. The students involved are a mixture of upperclassmen and lowerclassmen who ensure a seamless transition with the transfer of knowledge as they come and go.</p>
<p>&ldquo;They are basically learning how to run a business on their own,&rdquo; Pyles observed.</p>
<p>While the cafe is shut down for the summer, before resuming operations again with the start of the next school year, it has been popular among members of the public who can call in and pick up orders on the campus.</p>
<p>In other cases, large orders will even be delivered to customers.</p>
<p>&ldquo;We are in the black,&rdquo; Long said of the cost related to that service given the surge in gas prices. &ldquo;What we try to do is break even,&rdquo; with any profits going right back into the business.</p>
<p>&ldquo;We use some of that money to take them (students) on field trips,&rdquo; Gentry advised.</p>
<p>Long is hoping to expand Blue Bear Cafe to a downtown location if one can be found under the right circumstances.</p>
<p><strong>City accolades</strong></p>
<p>The smell of success from Blue Bear Cafe has emanated to City Hall a couple of miles away, as evidenced by the special recognition it received during a recent meeting of the Mount Airy Board of Commissioners.</p>
<p>Pyles attended that session along with two students, Griffin and fellow junior Shatavia Robison, who were there for a presentation on the program highlighted by the girls passing out chocolate chip cookies to those in attendance.</p>
<p>The cookies were contained in colorful packaging with labels extolling such sentiments as &ldquo;be nice&rdquo; and &ldquo;choose happiness.&rdquo;</p>
<p>&ldquo;This program is first and foremost all about our kids,&rdquo; Pyles said of the effort that &ldquo;has just blown my mind.&rdquo;</p>
<p>&ldquo;The Blue Bear Cafe is one of the bright shining lights of the Mount Airy school system,&rdquo; Commissioner Jon Cawley remarked, while thanking Polly Long for her involvement.</p>
<p>&ldquo;I know y&rsquo;all will go far in life,&rdquo; Commissioner Marie Wood told the students.</p>
<p>&ldquo;Great job, ladies,&rdquo; said the board&rsquo;s Joe Zalescik.</p>
<p>&ldquo;This is what a community like Mount Airy is and can be,&rdquo; Mayor Ron Niland said of the cafe&rsquo;s success. </p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110654/county-emergency-responders-honored" title="County emergency responders honored" style="color:black">County emergency responders honored</a></h1>

            <a href="https://www.mtairynews.com/news/110654/county-emergency-responders-honored" title="County emergency responders honored">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128595687_web1_Livesavers.jpg" alt="County emergency responders honored">
            </a>
   <p class="entry-meta">June 10, 2022</p>
   <p>If anyone were to have needed medical assistance at the county commissioners meeting Monday night, they would have found themselves in the care of some of the best emergency responders Surry County has to offer. On hand were thirteen paramedics who were being recognized by the members of the board of commissioners for saving lives and for representing the county with honor in competition.</p>
<p>Surry County Paramedics Hannah Simmons, Aaron Stolzfus, and Mark Vogler were recognized for having saved ten lives in the line of duty.</p>
<p>Similarly honored for having saved five lives were: Daniel Banks, Staphany Blizard, Colby Cooper, Tiffany Earley, Mason Gwyn, Shellie Killgo, Hunter Odum, Abby Samuels, Mason Sewell, and Kaitlin Smith.</p>
<p>Smith along with Joshua Lecrone were also recognized for their participation as members of the 2022 Surry County State Paramedic Team. In the 30th annual competition the pair were crowned 2022 Region I Champions and advanced to the finals.</p>
<p>The competition is part of the North Carolina EMS Expo, an educational conference that brings together paramedics, EMTs and county emergency services directors to sharpen their skills with presentations from faculty from across the state and the country.</p>
<p>The teams all faced the same scenario as each emerged from sequestration to respond to a mock emergency. This year&rsquo;s scenario had multiple patients at a rural farm setting &mdash; including a victim trapped in hay baler equipment, a Spanish-speaking victim experiencing chemical poisoning and an unresponsive person experiencing burn trauma.</p>
<p>Each team takes turns to assess, treat and stabilize victims in a scenario that lasts 12 minutes. They must move quickly and use their experience, education, and training to provide care to the victims. They may use first responders to assist while they render the most critical care. Teams were judged on professionalism, communication, patient rapport, conduct, attitude, appearance, and attire.</p>
<p>The competition is watched by hundreds of peers from bleachers that are set up inside the ballroom at the Joseph S. Koury Convention Center in Greensboro. It provides a training opportunity not only for the competing teams, but also for the paramedics and emergency medical technicians who closely observe each team&rsquo;s analysis and reaction to the scenario.</p>
<p>Tom Mitchell, chief of the North Carolina Office of Emergency Medical Services, announced the winners at a banquet held Tuesday evening to cheers and applause from hundreds of the winners&rsquo; peers.</p>
<p>The team from Mecklenburg County EMS won the competition defending their title from the last competition in 2019.</p>
<p>&ldquo;All of the teams in this competition are winners. They are North Carolina&rsquo;s best of the best in emergency medical response,&rdquo; said Mitchell. &ldquo;We offer our special congratulations to this year&rsquo;s winners.&rdquo;</p>
<p>The commissioners offered their thanks to the women and men who risk themselves for the people of Surry County.</p>
<p>In other county commissioners&rsquo; news from Monday:</p>
<p>&#8211; A new offer has been made on the Westfield School site. The offer was made by John and Beverly Shelton in the amount of $102,000. A recent prior offer was rescinded by the bidder shortly after it was made due to additional costs of potential remediation.</p>
<p>Commissioner Van Tucker reminded the board in the absence of County Attorney Ed Woltz that accepting the initial offer only begins a bidding process. Woltz previously told the board members that they also had the ability to walk away from any offer prior to finalizing the sale for any reason.</p>
<p>&ldquo;This bid should start a process which hopefully would land us with a little more in a final offer somewhere along the way in the open bidding process,&rdquo; Tucker said as he made a motion to accept the offer.</p>
<p>Commissioner Larry Johnson pointed out that the Sheltons live in proximity to the former Westfield school, &ldquo;I&rsquo;m pretty sure these people live across the street. I think that&rsquo;s good news too.&rdquo;</p>
<p>The offer was accepted and now a period of upset bidding will begin in which any other party may offer an increase to the initial bid.</p>
<p>&#8211; County Development Services Director Marty Needham advised the board that the planning board has given its unanimous approval to a rezoning request that will yield a new Dollar General at 120 Mount View Drive in Mount Airy. The new location is just to the North of J. J. Jones Intermediate School at the intersection of Riverside Drive and Mount View Drive.</p>
<p>The tract of 2.14 acres needs to be rezoned from Rural Agriculture to Rural Business-Conditional. Commissioner Mark Marion asked if the new store would have a similar design to newer Dollar General location in Dobson on Zephyr Road, which was confirmed. The board was told new Dollar General locations are to have a larger footprint with increased cooler space for food items needing refrigeration.</p>
<p>Property owner James Lambert told the board the store has his blessing, and the commissioners approved the rezoning request.</p>
<p>&#8211; Penny Harrison of the county&rsquo;s tax office was on hand to hold a public hearing on the renaming of private roads in the county. From the first of June 2021 through the end of May 2022 there were 13 instances of either a new private road being built, a private road name change, or corrections to private road names. As per state statute, the commissioners have to approve the naming or renaming of all roads, public or private, in the county.</p>
<p>The list of names was posted for one month with no challenges offered to the tax office, nor did any speakers rise during the meeting to speak at the hearing. Seeing no challenges, the names were approved by the board.</p>
<p>Roads impacted were: Cozy Creek Trail, Parker Hill Trail, Mountain Berry Way, Great Southern Trail, Legacy Lane, Pond Spring Trail, Willows Walk Lane, Rodriguez Lane, and Lovers Creek Trail all in Mount Airy.</p>
<p>Also on the list were Lewis Acres Lane in Pinnacle, Blue Dog Farms Lane in Dobson, David Lee Trail in Elkin, and Brudys Trail in Pilot Mountain.</p>
<p>&#8211; Dr. David Shockley of Surry Community College sent in a request to have Deidre Rogers reappointed to the Board of Trustees of the college, which was unanimously approved.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110647/arts-alive-camp-is-underway" title="Arts Alive! camp is underway" style="color:black">Arts Alive! camp is underway</a></h1>

            <a href="https://www.mtairynews.com/news/110647/arts-alive-camp-is-underway" title="Arts Alive! camp is underway">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128596731_web1_Arts-Alive-2206-0029-286x509.jpg" alt="Arts Alive! camp is underway">
            </a>
   <p class="entry-meta">June 10, 2022</p>
   <p>The 2022 Arts Alive camp kicked off the weekly summer camp series with more than 50 participants ages 3-5 years old along with middle and high school volunteers. </p>
<p>Emily and Bruce Burgess are working with arts and crafts, Shelby Coleman is hosting a drama class, and Tyler Matanick is working with music. Each class rotation emphasizes this year&rsquo;s theme &ldquo;Reach for the Stars.&rdquo; Each class is teaching and reinforcing astronomy facts but the goal of Arts Alive continues to be to have fun and engage children in the arts to build future audiences. </p>
<p>Participants are looking forward to the annual Arts Alive Parade on Thursday, June 16 at 5:15 p.m. from Truist to the Andy Griffith Playhouse. The parade is followed by a celebration at the Andy Griffith Playhouse featuring arts, crafts, food, face painting and a performance by Arts Alive participants on the Andy Griffith Playhouse stage.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110615/rockford-student-council-host-talent-show" title="Rockford student council host talent show" style="color:black">Rockford student council host talent show</a></h1>

            <a href="https://www.mtairynews.com/news/110615/rockford-student-council-host-talent-show" title="Rockford student council host talent show">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128572751_web1_Piper-Custodio-dance-382x509.jpg" alt="Rockford student council host talent show">
            </a>
   <p class="entry-meta">June 10, 2022</p>
   <p>Rockford Elementary&rsquo;s Student Council recently held a &ldquo;Rockford&rsquo;s Got Talent&rdquo; show. There were 24 performances by various students and classes.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110613/surry-community-honors-hse-ahs-graduates" title="Surry Community honors HSE, AHS graduates" style="color:black">Surry Community honors HSE, AHS graduates</a></h1>

            <a href="https://www.mtairynews.com/news/110613/surry-community-honors-hse-ahs-graduates" title="Surry Community honors HSE, AHS graduates">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128529063_web1_HES-GRAD-1.jpg" alt="Surry Community honors HSE, AHS graduates">
            </a>
   <p class="entry-meta">June 09, 2022</p>
   <p>More than 60 students earned their High School Equivalency (HSE) and Adult High School diplomas from Surry Community College during the 2021-2022 academic year.</p>
<p>Of the graduates, 22 participated in the HSE/AHS graduation held at the Surry Community College Gymnasium in Dobson.</p>
<p>Courtney Schmeltzer and Alfrida Bryant were guest speakers, and SCC President Dr. David Shockley presented graduates with their diplomas.</p>
<p>The graduation participants include Hyatt Cooke, Katie Cox, Mack Hines, Alissa Holland, Alyssia McDaniel, Vanessa Page, James Rogers, Betzabeh Vera and Jocabeth Vera of Mount Airy; Timothy Foster of Pilot Mountain; Fayth Bauguess of Elkin; Ethan Billings of Roaring River; Courtney Schmeltzer of Lawsonville; Hailyee Blanton and Alishia Smith of Boonville; Edith Navarro of Hamptonville; Jorge Benitez, Edgar Cedano, Laura Ferrera and Krystal Peterson of Yadkinville; and Alfrida Bryant of Jonesville.</p>
<p>Surry offers two assessment options for earning a High School Equivalency Diploma. Students can take either the General Educational Development Test or the High School Equivalency Test. Successful passage of either test results in an HSE Diploma issued by the North Carolina Board of Community Colleges. Surry offers free preparation classes to give students an opportunity to gain the knowledge and skills needed to successfully pass the test. Online preparation classes are also offered.</p>
<p>Surry&rsquo;s Adult High School program offers an alternative to the HSE program for adults who did not graduate from high school. Anyone lacking a few credits from high school can enroll in the online program in order to acquire a high school diploma. The Adult High School program was established by SCC with affiliation agreements from local school districts. An Adult High School diploma is awarded by the number of credits and specified courses adopted by the State Board of Education as the requirement for graduation from the public high school.</p>
<p>For more information about SCC&rsquo;s High School Equivalency programs, contact Jennifer Pardue at 336-386-3674 or Courtney Jackson at 336-386-3663.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110612/open-houses-set-at-edwards-franklin-site" title="Open houses set at Edwards-Franklin site" style="color:black">Open houses set at Edwards-Franklin site</a></h1>
   <p class="entry-meta">June 09, 2022</p>
   <p>The Surry County Historical Society this weekend is continuing its recently revived series of open house events at a local landmark.</p>
<p>Tours for the public are scheduled at the historic Edwards-Franklin House on Saturday and Sunday from 1 to 5 p.m. both days. These are free events to which everyone is invited, said Dr. Annette Ayers of the society.</p>
<p>The open house tours resumed in May after being suspended in 2020 and 2021 due to COVID-19.</p>
<p>Located at 4132 Haystack Road west of Mount Airy, the Edwards-Franklin House was constructed in 1799 and is considered the finest example of its architectural type in the Piedmont region.</p>
<p>The house was built by Gideon Edwards and later occupied by his son-in-law, Meshack Franklin, a member of Congress and brother of North Carolina Gov. Jesse Franklin, who served in the 1820s.</p>
<p>In 1972, the Edwards-Franklin House was bought by the Surry County Historical Society and restored to its former grandeur. The structure features many unique architectural components.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110609/scc-holds-graduate-career-expo" title="SCC holds graduate career expo" style="color:black">SCC holds graduate career expo</a></h1>

            <a href="https://www.mtairynews.com/news/110609/scc-holds-graduate-career-expo" title="SCC holds graduate career expo">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128542684_web1_career-expo-pic.jpg" alt="SCC holds graduate career expo">
            </a>
   <p class="entry-meta">June 09, 2022</p>
   <p>Surry Community College hosted a Graduate Career Expo recently, providing graduates with the opportunity to meet with many businesses who were recruiting employees.</p>
<p>&ldquo;We appreciate the support of our local businesses by their participation in this inaugural event,&rdquo; said Rachel L. Hiatt, SCC coordinator for Work-Based Learning and Apprenticeship Initiatives. &ldquo;The college&rsquo;s Purpose Center offered graduates help with resume preparation and interview skills during workshops in April.&rdquo;</p>
<p>Businesses in attendance were Carport Central/The Central Steel Group; Chatham Nursing and Rehab; Hugh Chatham Memorial Hospital; J&rsquo;s HVAC Unlimited LLC; Johnson Granite Inc.; Moore and Associates Engineering and Consulting; Mountain Valley Hospice; Ottenweller Company; Pike Electric; Prism Medical Products; Salem Electric Co.; Surry Communications; Wayne Farms LLC; and Weyerhaeuser; Workforce Unlimited.</p>
<p>The SCC Marketing Department took complimentary digital professional headshots of students for their social media sites during the event.</p>
<p>Any business representative wishing to partner with SCC to find employees, interns or apprentices should contact Hiatt 336-386-3291 or hiattr@surry.edu.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110605/auto-show-motorcycle-ride-highlight-a-busy-weekend" title="Auto show, motorcycle ride highlight a busy weekend" style="color:black">Auto show, motorcycle ride highlight a busy weekend</a></h1>

            <a href="https://www.mtairynews.com/news/110605/auto-show-motorcycle-ride-highlight-a-busy-weekend" title="Auto show, motorcycle ride highlight a busy weekend">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128592784_web1_FlyInShow2021.jpg" alt="Auto show, motorcycle ride highlight a busy weekend">
            </a>
   <p class="entry-meta">June 09, 2022</p>
   <p>A popular event held at the Mount Airy/Surry County Airport last fall is back by popular demand. The Second Annual Auto Show and Fly In at the Airport, presented by Speedology Solutions, LLC, will be held this Saturday from 9 a.m. to 2 p.m.</p>
<p>The event has a rain date of Saturday, June 18, just in case mother nature does not cooperate.</p>
<p>&ldquo;We&rsquo;re very excited to be partnering again with Speedology Solutions, LLC,&rdquo; Airport Manager George Crater said. &ldquo;They do a great job of coordinating, and airport staff provides the facility and handles aviation needs throughout the day.&rdquo;</p>
<p>While the car show in 2021 was a great success and food trucks fared well, the rain impacted attendance for both spectators and the planes for the fly-in aspect of the auto show. Still, more than 120 domestic, import, classic and exotic vehicles were on hand and those in attendance got to take a leisurely stroll down the tarmac looking at all sorts of cool rides.</p>
<p>A big difference from the auto show last year will be that motorcycle owners are invited to show off their steel horses. Organizers of the 2022 show are hopeful that beautiful summer-like weather will boost attendance, &ldquo;I expect it to be even better this year,&rdquo; Crater said.</p>
<p>She also noted that the event moved ahead one hour so as to get as much of the event in before the heat and humidity creep in during the afternoon.</p>
<p>The price has been reduced from the previous show, it is $20 per show car which includes the fees for all the people in that car. General admission will be $5 each for those who are not showing.</p>
<p>Knowing no such event is complete without the eats, the fly in auto show will be featuring food trucks including Cilantro &#038; Tacos and Lobster Dogs. The Dapper Bean coffee truck and Opie&rsquo;s Candy Store are also slated to be in attendance.</p>
<p>Tickets for the event can be bought at the gate or in advance by following the link on the Mount Airy/Surry County Airport&rsquo;s website: www.mascairport.com.</p>
<p>* * *</p>
<p>For those taking in the fun of the auto show and fly in, they may want to leave time in the afternoon available to take in another festival along with motorcycle ride in Mount Airy. The Mount Airy Men&rsquo;s Shelter will be hosting their Mount Airy Men&rsquo;s Shelter Summer Festival &#038; Motorcycle Ride on Saturday, at Veterans Memorial Park, from 11 a.m. to 5 p.m.</p>
<p>&ldquo;Our first annual fundraiser is to help with the expenses of getting the shelter ready to occupy. Moving some walls, adding some showers, and getting the kitchen together,&rdquo; organizer Ann Simmons said.</p>
<p>&ldquo;Along with these beautiful motorcycles on display and the scenic motorcycle ride, there will also be lots of great vendor booths and a raffle for a grill,&rdquo; she said. &ldquo;The kid&rsquo;s area will feature a sack race, twisty balloon guy, giant slide, kids&rsquo; removable tattoos, water balloon toss, obstacle course, football toss, corn hole, rock and craft painting, ice cream, shaved ice, and kids&rsquo; hot dogs.&rdquo;</p>
<p>On hand will be BBQ by Aunt Bea&rsquo;s, Mountain Top Concessions, Kona Ice of Mount Airy, Belle Full Vending, and Pickalicious. There are also going to be more than 40 vendors from local businesses on hand.</p>
<p>For the little ones there will be two bouncy castles, kids games, and activities that are free for the kids. Games operated by vendors are not, organizers want to remind.</p>
<p>The event is raising money for the new Mount Airy Men&rsquo;s Shelter which was founded in order to give the homeless men of this area a place to sleep when they are in need.</p>
<p>&ldquo;The creation of a men&rsquo;s shelter, with onsite supportive services, has the potential to significantly decrease costs to the Surry County taxpayer. Without shelter the homeless arrive at emergency rooms, urgent care centers, and local businesses,&rdquo; the group said.</p>
<p>For more information, visit: Facebook.com/Mt.AiryNCMensShelter</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110603/library-hosts-local-author-to-discuss-her-latest" title="Library hosts local author to discuss her latest" style="color:black">Library hosts local author to discuss her latest</a></h1>

            <a href="https://www.mtairynews.com/news/110603/library-hosts-local-author-to-discuss-her-latest" title="Library hosts local author to discuss her latest">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128591319_web1_MustiqueIsland_HC-scaled-339x509.jpg" alt="Library hosts local author to discuss her latest">
            </a>
   <p class="entry-meta">June 09, 2022</p>
   <p>The Mount Airy Public Library will be holding an author meet and greet with Sarah McCoy of Winston-Salem this Saturday at 2 p.m.</p>
<p>Her latest novel, &lsquo;Mustique Island&rsquo; is the seventh novel written by McCoy.</p>
<p>For this weekend&rsquo;s meet and greet event, she said all are welcome as her book was written for &ldquo;anyone with an open heart seeking to learn something new about an unknown place, a past time, and people unlike any other you&rsquo;ve ever met before. It&rsquo;s a book that welcomes all readers to its shores. It&rsquo;s time the secrets were unveiled.&rdquo;</p>
<p>McCoy paints quite a scene, &ldquo;Willy May Michael was a beauty queen in her small town of Texas as a young woman. So, she&rsquo;s only a beauty queen in once-upon-a-time memory alone. When the book opens in 1972, she is a mother of two grown daughters, divorced from her husband, shunned from British society, the captain of her own ship, and a new resident on Mustique Island. Thus, her tiara is just for show, like so many things on Mustique Island. Like so many things in all our lives.&rdquo;</p>
<p>&ldquo;She willingly joins this circle. She believes it&rsquo;s what she wants &mdash; to be part of the world&rsquo;s most exclusive upper crust,&rdquo; McCoy explained. &ldquo;Princess Margaret is a fellow resident, as is Mick Jagger, and guests included many of the world&rsquo;s most illustrious fashion designers, magazine models, actors, and even powerful gangsters. It is an island of the most elite of celebrities. To build a life in that kind of paradise sounded too good to be true, and it was.&rdquo;</p>
<p>The island of Mustique sits deep in the South of the Caribbean, around 60 miles to the North of the island of Granada. McCoy finds her own lineage in the Caribbean; although she moved often as military child, he mother&rsquo;s family still lived mostly in Puerto Rico.</p>
<p>She is happy to return to her Caribbean roots in Mustique Island. &ldquo;The novel is a family saga of a mother, her daughters, and all the ancestral roots and branches that tangle, catch, cradle, and bear us up to unimaginable heights. It&rsquo;s wild, baby.&rdquo;</p>
<p>That sounds like an open invitation for a new summer read. McCoy&rsquo;s novel has already been graced with positive reviews while finding itself Town &#038; Country&rsquo;s Best Book of May Pick, Vox Magazine Pick of May, and Deep South Magazine&lsquo;s Summer Reading List Pick among others.</p>
<p>The Booklist review says in part, &ldquo;McCoy&rsquo;s underlying tale of women-in-crisis who claw their way back to strength carries sobering messages about the importance of family loyalty and resiliency.&rdquo;</p>
<p>Family is important to McCoy, &ldquo;I was a gypsy child my whole life and am very happy to have finally put down roots in Winston-Salem. It&rsquo;s a genuinely beautiful place full of genuinely beautiful people.&rdquo;</p>
<p>She calls herself a southern lady and with roots in Kentucky as well as Puerto Rico, she is a modern Southern woman of mixed descent. She said that her mixed background did not cause her challenges, &ldquo;Not at all. In fact, it empowers me to understand that not one person on this earth is singular in his or her history.&rdquo;</p>
<p>&ldquo;We are all hybrids no matter the color of your skin, the religion you choose, the titles you are given, or the lineage from which you descend. We are one humankind. The pandemic taught us that unquestionably!&rdquo;</p>
<p>For the self-described gypsy the future holds more of the same and she has pen to paper already, &ldquo;I&rsquo;m working on my next novel. So that means more time researching, traveling to the setting, and putting the characters&rsquo; stories down on paper. More time in my writing cave. I welcome that!&rdquo;</p>
<p>For readers and aspiring authors alike, the Mount Airy Public Library invites them to attend the meet and greet Saturday at 2 p.m.</p>
<p>More information on Sarah McCoy can be found: sarahmccoy.com.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110592/golden-leaf-funds-shine-on-industrial-park" title="Golden LEAF funds shine on industrial park" style="color:black">Golden LEAF funds shine on industrial park</a></h1>

            <a href="https://www.mtairynews.com/news/110592/golden-leaf-funds-shine-on-industrial-park" title="Golden LEAF funds shine on industrial park">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128590929_web1_westwood-park.jpg" alt="Golden LEAF funds shine on industrial park">
            </a>
   <p class="entry-meta">June 09, 2022</p>
   <p>Local economic-development officials are hoping a large tract of now-wooded property at Mount Airy&rsquo;s Westwood Industrial Park can be better marketed to companies with the help of Golden LEAF funding.</p>
<p>&ldquo;It&rsquo;s going to help us get that site ready for development,&rdquo; Surry County Economic Development Partnership President Todd Tucker said Tuesday regarding $39,650 just awarded for the park located in the northwestern part of the city where some facilities now exist.</p>
<p>The Golden LEAF Board of Directors approved the funding for Surry through its SITE Program-Due Diligence component targeting such projects to stimulate job growth. The Golden LEAF Foundation was established in 1999 to administer money received by North Carolina through a master settlement with cigarette companies, aimed at strengthening economies of communities &mdash; with special emphasis on rural areas that have depended on tobacco.</p>
<p>Westwood is one of three projects in North Carolina tapped for SITE Program-Due Diligence assistance, with the others in Robeson and Martin counties. Receiving the money will allow eligible activities such as environmental assessments, archaeological analyses and mapping to be completed.</p>
<p>&ldquo;Essentially what that is, is predevelopment work for the undeveloped tract of land,&rdquo; Mount Airy Community Development Director Martin Collins explained Tuesday regarding the Westwood Park property involved.</p>
<p>&ldquo;It&rsquo;s a pretty large tract of land,&rdquo; Collins added, &ldquo;I&rsquo;m going to say the largest tract of undeveloped land the city has presently.&rdquo;</p>
<p>The predevelopment efforts will pinpoint the presence of wetlands or endangered species on the property along with geotechnic findings, according to Tucker, who wrote the grant application for Golden LEAF funding. Geotechnics is a branch of engineering dealing with characteristics of soil and its suitability for construction.</p>
<p>Industries eyeing sites for new facilities tend to be &ldquo;risk-averse,&rdquo; the county&rsquo;s chief economic-development official says, which make them avoid locations with question marks that could disrupt timetables and cause lengthy delays.</p>
<p>&ldquo;They just don&rsquo;t know what&rsquo;s there,&rdquo; Tucker said of prospects who might eyeball the available property at Westwood Industrial Park, which first came on the scene in the 1980s.</p>
<p><strong>Bridging a gap</strong></p>
<p>&ldquo;We&rsquo;ve got approximately 100 acres up there in Westwood,&rdquo; Tucker said of the space available for industrial development.</p>
<p>It is located out Boggs Drive, off Westlake Drive, to an area in the vicinity of an Andrew Pearson Design manufacturing plant adjacent to a cul-de-sac.</p>
<p>Now when business prospects visit the property, all they see is a large forest. This in itself can cause development problems even without wetland or endangered species issues emerging, Collins said of related tasks including cutting trees and removing stumps.</p>
<p>That can derail a potential project by hampering what already might be a tight time frame, the community development director mentioned.</p>
<p>Helping with such needs seems tailor-made for what Golden LEAF officials seek to accomplish, in the view of Don Flow, the chairman of the organization&rsquo;s board.</p>
<p>&ldquo;The need for industrial sites, especially in rural areas, was a gap identified in our strategic planning process,&rdquo; Flow said in a statement. &ldquo;As we have seen, ready sites are no longer a luxury but a necessity to move at the speed of business.&rdquo;</p>
<p>Flow says the latest SITE Program projects benefiting Surry and other counties will help prepare North Carolina for economic growth opportunities.</p>
<p>Tucker, the Surry Economic Development Partnership official, is hopeful about the analytical activities planned at Westwood Industrial Park and the answering of key questions about any aggravating factors present.</p>
<p>&ldquo;It&rsquo;s going to help us determine all that and get ready for future development,&rdquo; he advised.</p>
<p>&ldquo;Ultimately, it&rsquo;s going to make that site more marketable.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110591/police-reports-580" title="Police reports" style="color:black">Police reports</a></h1>
   <p class="entry-meta">June 08, 2022</p>
   <p>&#8226; The laundry of a Virginia woman was stolen Monday afternoon from a business in Mount Airy, according to city police reports.</p>
<p>The incident occurred at 651 N. South St., the address listed for the Lady Bug cleaning establishment, where miscellaneous clothing items, a youth baseball uniform and a white sheet cover &mdash; valued altogether at $400 &mdash; were taken.</p>
<p>Samantha Starr Willard of Valley End Road in Ararat is listed as the victim of the crime.</p>
<p>&#8226; Josue Munoz, 32, of 142 Fairview Club Lane, Dobson, was charged early Sunday with impaired supervision of instruction, due to his alleged overseeing of someone else&rsquo;s operation of a 2007 Hyundai Elantra while Munoz himself was legally under the influence of alcohol.</p>
<p>The charge stemmed from a motor vehicle collision, which police records indicate occurred in the vicinity of the Scenic Chevrolet-Buick-GMC dealership on Rockford Street. Munoz was released on a written promise to appear in Surry District Court on July 11.</p>
<p>&#8226; Coach&rsquo;s Bar and Grill was the scene of a larceny on June 1, when a known individual left the restaurant on North Andy Griffith Parkway without paying for food valued at $48 which was ordered for a meal, listed as burgers, a hot dog and other items including a margarita.</p>
<p>The matter was still under investigation at last report.</p>
<p>&#8226; Stefanee Nikole Davis, 22, of 292 Fisher Peak Trail, Lowgap, was charged with larceny and possession of stolen goods on the night of May 29, when she allegedly stole various beauty products and a package of tortillas at Dollar General on North Renfro Street, valued altogether at $29.</p>
<p>Davis later was located by Officer Adam Jones at the McDonald&rsquo;s fast-foot establishment nearby and admitted to stealing the merchandise, which was found in her purse during a probable-cause search, police records state.</p>
<p>It was returned to the store, from which Davis has been banned. In addition to the La Banderita tortillas, bottles of Suave Aroma shampoo and conditioner, Bior&#233; skin cleanser, a Conair comb, a Studio portable manicure kit and Fit Me powdered makeup were taken.</p>
<p>The Lowgap woman is facing a June 20 court appearance.</p>
<p>&#8226; Austin Alexander Deluca, 20, of 1215 Brooklen Ave., was served with an outstanding criminal summons for a charge of unauthorized use of a motor vehicle after he was encountered by police late on the night of May 28 at Riverside Park during a security check.</p>
<p>The charge had been filed through the Surry County Sheriff&rsquo;s Office on May 26 with Paul Swift of Maple Drive, Mount Airy, as the complainant. Deluca is scheduled to be in District Court on June 16.</p>
<p>&#8226; Olivia Easter Roberts, 44, of 248 Chatham Road, was served with an outstanding criminal summons for a school attendance law violation on May 26, when she was encountered by police during a civil disturbance at another home on Chatham Road.</p>
<p>The summons had been issued through the Surry Sheriff&rsquo;s Office on May 17, with Roberts facing a July 5 court date.</p>
<p>&#8226; Ethan Tyler Deskins, 21, of 201 Jones School Road, was served with a criminal summons for a second-degree trespassing charge on May 26 when encountered by officers investigating a suspicious person in that area and found to be the subject of the summons that had been filed on March 17 with Tammy Pell of Jones School Road as the complainant.</p>
<p>Deskins was scheduled to be in District Court Wednesday.</p>
<p>&#8226; Matthew Thomas Jarry, 22, of 1646 Joe Layne Mill Road, Elkin, was charged with hit and run on May 24, involving a 2004 Jeep Cherokee Jarry was operating which was involved in a crash.</p>
<p>Police later located him on West Elm Street, but the site of the alleged hit and run was not listed. The case is set for the June 27 session of District Court.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110589/greensboro-firm-buys-local-sign-company" title="Greensboro firm buys local sign company" style="color:black">Greensboro firm buys local sign company</a></h1>

            <a href="https://www.mtairynews.com/news/110589/greensboro-firm-buys-local-sign-company" title="Greensboro firm buys local sign company">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128592736_web1_20220428_144708.jpg" alt="Greensboro firm buys local sign company">
            </a>
   <p class="entry-meta">June 08, 2022</p>
   <p>GREENSBORO &mdash; Three-and-a-half years after Kieffer | Starlite sign company purchased Burton Signs of Mount Airy &mdash; and less than a year after announcing an expansion at the local plant &mdash; Kieffer | Starlite has opted to sell the facility as part of a company-wide, multi-month reorganization.</p>
<p>And in so doing, the former Burton Signworks company in Mount Airy has come full circle.</p>
<p>Allen Industries, a family-owned company based in Greensboro, announced on Wednesday it had acquired the Mount Airy production facility of national sign company Kieffer | Starlite earlier this spring.</p>
<p>The move brings together two firms which have, in some ways, always been connected. Wayne Burton, founder of what would eventually become Burton Signworks, started the Mount Airy business in 1983 &mdash; after learning the trade by working for Allen Industries.</p>
<p>&ldquo;Wayne Burton got his start in the sign business working for Allen Industries in the late &lsquo;60s and early &lsquo;70s before starting Burton Electric Signs Inc. in 1974,&rdquo; said Tom Allen, Allen Industries president.</p>
<p>Burton grew his sign business from a one-man, one-truck operation to a business with as many as 50-75 employees before eventually selling his sign company to a local business group in 2007, according to Allen Industries. Burton continued to work there until his retirement in 2010.</p>
<p>He ran the operation as a family-owned business, something Tom Allen said his firm does as well. His grandfather started Allen Industries in 1931 with neon signs, successfully growing into a full-service signage and architectural elements manufacturer and installation company. Now he, his brothers, and some fourth-generation family members work at the firm, which has manufacturing facilities in North Carolina, Florida, Arizona and Ohio.</p>
<p>The Mount Airy facility will be Allen Industries seventh location, allowing the signage company more capacity, equipment and expertise to design, build and maintain every type of signage and re-imaging program and fulfill even more projects across the U.S. and abroad. Allen Industries completed nearly 2,000 national and international installations last year.</p>
<p>The Mount Airy facility has already undergone some changes over the past two years. Its previous owners announced last spring it would be consolidating two area locations into one, at 699 Junction Street, and expanding its workforce and production facilities.</p>
<p>That owner, Kieffer | Starlite, has since undergone significant changes as well. In November, the firm announced it was &ldquo;right sizing&rdquo; its operations, shutting down all of its production facilities except for Mount Airy and one in Sheboygan, Wisconsin. In April, the firm announced it had been acquired by PSCO Global Group, and that acquisition included the Wisconsin plant. While the sale of the Mount Airy facility was not announced until Wednesday, that also took place in April.</p>
<p>Now, the local manufacturing operation is in the hands of the place where its founder got his start in the sign business.</p>
<p>&ldquo;Wayne Burton ran his operation with the same family-oriented atmosphere we strive for at Allen Industries,&rdquo; said Tom Allen. &ldquo;Just as we mentored him early in his career, Wayne was well known for his nurturing of young individuals starting in the signage profession and as a result, he had the loyalty and tenure of his employees. Much like Wayne&rsquo;s business, Allen Industries has many longtime employees who start here and retire with us. With the acquisition of this Mount Airy facility, the Allen-Burton legacy comes full circle and we couldn&rsquo;t be more pleased to become a part of this fantastic community.&rdquo;</p>
<p>Allen Industries plans to add employees and &ldquo;bring back the numbers and culture of the former Burton Electric Signs/Burton Signworks and welcomes all applications.&rdquo;</p>
<p>&ldquo;At Allen Industries, you&rsquo;ll find a family business and culture where our people are our most valuable asset and our team members work together to meet customer needs. With industry-leading benefits and incentives, associates are valued, encouraged to develop, and are rewarded for their performance,&rdquo; Allen said.</p>
<p>For more information the company, or potential job openings there, visit www.allenindustries.com/careers.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110586/commissioners-encouraged-not-to-be-ostriches" title="Commissioners encouraged not to be &#8216;ostriches&#8217;" style="color:black">Commissioners encouraged not to be &#8216;ostriches&#8217;</a></h1>

            <a href="https://www.mtairynews.com/news/110586/commissioners-encouraged-not-to-be-ostriches" title="Commissioners encouraged not to be &#8216;ostriches&#8217;">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128581853_web1_paper-ballot.jpg" alt="Commissioners encouraged not to be &amp;#8216;ostriches&amp;#8217;">
            </a>
   <p class="entry-meta">June 08, 2022</p>
   <p>A change in tactic was deployed Monday evening at the meeting of the board of county commissioners when another group rose during the open forum to discuss election integrity.</p>
<p>What had been a more broadly approached set of complaints against the 2020 election outcome, in particular voting machines and their security, was reduced to one point. More than a dozen speakers rose to explain their opinion that it is within the right of the county commissioners to request that the county move back to paper only ballots.</p>
<p>Keith Senter of the county Republican party again was the first speaker to rise and he reminded the commissioners that it was the anniversary of D-Day. He spoke about having courage, as those brave soldiers had, this was a recurring theme of several speakers Monday.</p>
<p>He asked the board to consider what would happen to the electronic voting machines had a catastrophic failure or a power outage occured, noting that the county would then revert to a hand count. In fact, he said the state already allows that a hand cast ballot shall be counted.</p>
<p>There are three approved voting systems in the state he advised, &ldquo;ES&#038;S, Hart InterCivic, and hand to eye ballot counting. This board may decline to accept ES&#038;S and instead choose to have hand to eye counting of the ballots.&rdquo;</p>
<p>After a vote is cast, he does not have confidence in it from there. &ldquo;After you vote, we don&rsquo;t know where the vote goes. We should. Mistrust in the voting system has to be fixed. Let&rsquo;s put the machines in the closet and have hand to eye counting because state statue 163 grants you that right.&rdquo;</p>
<p>Traci Laster offered another prayer for courage but also proclaimed that, &ldquo;For far too long we have turned a blind eye to the corruption and the perversion of our electoral process. Without a shadow of a doubt our 2020 election was rigged and stolen.&rdquo;</p>
<p>&ldquo;We the people of Surry County are rising up, standing up, speaking out, uniting, and demanding our voices to be heard.&rdquo; She referred to the book of Ephesians and noted that struggles against &ldquo;spiritual wickedness in high places&rdquo; were more pressing than those of conflict between flesh and blood, but she offered no new documentation nor evidence of her claim of a rigged election except to say, &ldquo;We have seen undeniable evidence that voting machines can be compromised.&rdquo;</p>
<p>If the commissioners wish to &ldquo;regain the trust of your constituents&rdquo; she said state statue 163-165 gives them the ability to adopt or decline any voting system. &ldquo;Although not very common, it is time to use some common sense.&rdquo; Paper ballots were used for decades without incident she reminded them. A request from the board to the county board of elections could begin the process of going back to paper ballots in Surry County in time for the general election.</p>
<p>That is where the group is now, they have requested the board of commissioners make a formal written request to return to paper ballots which they feel would be much safer. Jimmy Yokeley said that &ldquo;where there is smoke, there is most often fire,&rdquo; and many speakers pointed to the recent canvassing effort that took place in Surry County.</p>
<p>The canvassers, volunteers working with the GOP and not representatives of the local elections board, reported over a 41% rate of error in the canvasses completed, finding 170 instances out of 407 interviews in Surry County. These included voter registrations that did not match who lived at an address or the voter reported that the logbook did not match their 2020 voting method, the group&rsquo;s members claimed at this meeting and the previous one on May 16.</p>
<p>With so many errors found and with the presentation made to the board on primary eve in May on election integrity Sandra Swain said, &ldquo;You do have the authority to make a change, and after seeing the vulnerabilities in the current system, how can you not want to help ensure our elections are fair?&rdquo;</p>
<p>&ldquo;As Americans we have accepted election results in the past, but now there is too much opportunity for bad actors from who knows where to mess with the system. Make the change to paper ballots and hand counting.&rdquo;</p>
<p>&ldquo;If the Surry board of elections tries to stop the process, we the people will back you up. Instead of acting like a flock of ostriches and going along with the status quo &mdash; do something. Please stand up for fair elections.&rdquo;</p>
<p>Steve Odum told the board he had raised a challenge against two voters he claimed crossed from Ararat, Virginia., to vote in the primary. Reached by phone Wednesday, he explained that he had reported the incident in real time and swore a statement to the same. He attended a hearing the week after the primary on the matter and was informed the county had no recourse due to the ruling in August of 2018 in the U.S. District Court by Judge Loretta Biggs.</p>
<p>Her decision threw out voter ID laws on the books at that time, and her injunction still stands to this day. As interpreted by Greensboro lawyer Mark Payne for Surry County, &ldquo;In light of this order, Surry County Board of Elections is prevented from hearing this matter.&rdquo;</p>
<p>Odum asked about taking the complaint to the state board of elections as his next course of action. Given the 3-2 partisan split of the state board of elections, he has no confidence in that path of escalation.</p>
<p>&ldquo;What recourse do we have if we take it to the board or elections because your hands are tied, and they say they have no authority? It is a felony to vote like these folks did, but no one can prosecute and there are no consequences,&rdquo; he said.</p>
<p>&ldquo;You guys do have the authority to do something. If the states comes at you, if the board of elections come at you, you have thousands of people in this county who will stand behind you, I promise you that.&rdquo;</p>
<p>Not everyone was feeling as supportive of the board of commissioners with some speakers questioning their courage, motives, and conservative bona fides. Tessa Saeli who ran against Vice Chair Eddie Harris in the primary she said she was not sure why she felt called to run against someone she had previously supported.</p>
<p>&ldquo;I supported you and prayed for you because what you said on national news sources was the same thing I would have said: stand against wokeism. But now I am disappointed and now I see five cowards. Now I see why God told me to run and run hard to hold the seat you sit in, that potentially was obtained through cheating.&rdquo;</p>
<p>After the last meeting with the guest speakers on election integrity, &ldquo;Some of you were escorted out by officers of the law,&rdquo; she noted. &ldquo;Why? Because you were fearful of your friends? When you become afraid of your friends &#8211; there is evil in operation.&rdquo;</p>
<p>Jimmy Yokeley asked the board to consider what can actually be done and then file a request with the state board of elections. &ldquo;This is what we are requesting that you consider doing, and doing it as soon as possible, because if it is successful then come November, we can have great voter integrity in this county.&rdquo;</p>
<p>&ldquo;So instead of beating up what we can&rsquo;t do, why don&rsquo;t we focus on what we can do and make that written request to the North Carolina board of elections. We want to see the action and at least we deserve as citizens to see the board make that written request.&rdquo; </p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110569/new-principal-named-at-pilot-elementary" title="New principal named at Pilot elementary" style="color:black">New principal named at Pilot elementary</a></h1>

            <a href="https://www.mtairynews.com/news/110569/new-principal-named-at-pilot-elementary" title="New principal named at Pilot elementary">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128591690_web1_principal.jpg" alt="New principal named at Pilot elementary">
            </a>
   <p class="entry-meta">June 08, 2022</p>
   <p>Sandra Clement has been hired as the new principal of Pilot Mountain Elementary School, according to the Surry County Schools central office. She begins her new duties July 1.</p>
<p>Clement will be joining Surry County Schools from Patrick County Public Schools in Virginia, where she has 32 years of experience as an educator including the past 12 years as an elementary school principal. She fills the job vacated by Dana Draughn, who is retiring June 30 after a 30-year career in Surry County.</p>
<p>&ldquo;Mrs. Clement brings many strengths to the Pilot Mountain Elementary administration and the District Leadership Team,&rdquo; the school system office said in announcing her appointment. &ldquo;Her background in early literacy, exceptional children, and leadership, with a focus on educating the whole child aligns well with the strategic plan of Surry County Schools.&rdquo;</p>
<p>Over the past several years in Patrick County, Clement has served as the principal at Stuart Elementary, where she has provided support to 75 staff members while encouraging student and family engagement. Previously, she worked at Blue Ridge Elementary as a principal from 2011-2017 and as an assistant principal at Stuart Elementary from 2009-2011. Before taking on roles in administration, Clement worked as an English and history educator for all elementary grade levels. She also worked as an exceptional children&rsquo;s teacher, during which she helped implement instruction that supported each student&rsquo;s specific needs.</p>
<p>Clement earned her master of educational leadership degree from Radford University in Radford, Virginia. She also has a bachelor&rsquo;s degree in elementary education from Virginia Tech. Her certifications include Elementary Education Endorsement in K-4, Middle Education Endorsement 4-8, Administration and Supervision PreK-12, and LETRS Trainings Units 1-4.</p>
<p>&ldquo;I want to welcome Mrs. Sandra Clement to the Surry County Schools family and specifically as the next principal at Pilot Mountain Elementary School,&rdquo; said Superintendent Dr. Travis L. Reeves. &ldquo;Mrs. Clement impressed our interview committee with her knowledge of early literacy instruction and her passion for serving all students. She is a dedicated educational professional that brings a wealth of knowledge and experience to Pilot Mountain Elementary School. I know the Pilot Mountain Elementary community will embrace Mrs. Clement.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110584/board-restores-library-museum-sac-funds" title="Board restores library, museum, SAC funds" style="color:black">Board restores library, museum, SAC funds</a></h1>

            <a href="https://www.mtairynews.com/news/110584/board-restores-library-museum-sac-funds" title="Board restores library, museum, SAC funds">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128591123_web1_Potest-this-623x509.jpg" alt="Board restores library, museum, SAC funds">
            </a>
   <p class="entry-meta">June 08, 2022</p>
   <p>Citizens will say they want government to be tight with taxpayers&rsquo; money, but certain budget cuts are then met with strong resistance &mdash; which is the case with funding for three organizations in Mount Airy.</p>
<p>Annual operational support for the Surry Arts Council, Mount Airy Museum of Regional History and the public library on Rockford Street had been omitted from the city government&rsquo;s proposed budget for the 2022-23 fiscal year, which was released last month.</p>
<p>But the Mount Airy Board of Commissioners, during its latest meeting last week, voted unanimously to restore that funding, totaling $201,150. This includes $103,650 for the library, $87,500 for the arts group and $10,000 to the museum.</p>
<p>That occurred as council members faced a crowd of people who had ventured to City Hall for a public hearing on the budget scheduled during that meeting.</p>
<p>Their presence reflected a wave of opposition arising over the proposed slashing of municipal funding for the community agencies involved, which while not part of city government annually have received such support in recognition of their tourism and cultural contributions.</p>
<p>&ldquo;I think all of us received a lot of emails and answered a lot of emails,&rdquo; Commissioner Steve Yokeley said of feedback regarding the cuts as he surveyed those poised to speak on that subject.</p>
<p>Before the hearing began, Yokeley made a motion to provide the allocations for the three entities by adjusting the 2022-23 spending plan to accommodate that funding.</p>
<p>&ldquo;We&rsquo;ve had two weeks to review the budget,&rdquo; he said of the package received on May 19, with board members formulating opinions on some of its elements during that time.</p>
<p>One definite focus was the special appropriations to outside agencies, which for the present, 2021-22 fiscal year included $87,500 for the Surry Arts Council, $103,650 to the Mount Airy Public Library, $10,000 for Mount Airy Museum of Regional History, $7,500 to the Mount Airy Rescue Squad and $10,000 for Mount Airy-Surry County Airport.</p>
<p>However, for the next fiscal year that begins on July 1, only the rescue squad ($7,500) and airport ($20,000) were listed for funding in the preliminary budget prepared under the leadership of City Manager Stan Farmer, who assumed that post in January.</p>
<p>Initially within the spending plan, in lieu of a special appropriation, $206,996 was proposed for much-needed repairs to the Andy Griffith Playhouse, which houses the Surry Arts Council, and $197,322 for the library under the same scenario. Both buildings are owned by the municipality although the arts and library operations aren&rsquo;t under the city government umbrella.</p>
<p>The lack of financial support for the operational, non-building needs of the affected agencies produced a community furor.</p>
<p><strong>Hearing comments</strong></p>
<p>All that set the tone for last week&rsquo;s well-populated public hearing, for which top Surry Arts Council and museum officials Tanya Jones and Matt Edwards, respectively, were present although neither spoke.</p>
<p>Others did, yet the preemptive move by Commissioner Yokeley largely defused the pent-up dissatisfaction that might have been intense otherwise.</p>
<p>One local citizen, Calvin Vaughn, expressed concern over the notion that Mount Airy Museum of Regional History was being &ldquo;overlooked&rdquo; in the funding mix.</p>
<p>The museum is the largest-single tourism driver locally, according to Vaughn, who called it a Smithsonian-like facility with more than 25,000 artifacts telling the area&rsquo;s history from Native Americans until the present.</p>
<p>It has sustainability &ldquo;beyond the Mayberry mystique,&rdquo; the hearing speaker stated, adding that the museum generates $1.4 million for the local economy each year.</p>
<p>&ldquo;Every citizen benefits from the programs and services there,&rdquo; Vaughn said.</p>
<p>Another hearing speaker, Jennifer Johnson-Brown, social director of the RidgeCrest retirement community, also praised the facility.</p>
<p>&ldquo;The museum is the scribe of our city,&rdquo; Johnson-Brown said in her remarks to the commissioners. &ldquo;You don&rsquo;t want to be the eraser on the pencil that wipes out the history.&rdquo;</p>
<p>Nicole Harrison, a mother of two daughters, spoke in favor of the Surry Arts Council funding, while also acknowledging the commissioners&rsquo; earlier action restoring that money. &ldquo;I just want to say thank you,&rdquo; Harrison told them.</p>
<p>Khriste Petree stated that her children had benefited from both the museum and Surry Arts Council.</p>
<p><strong>Clinic move defeated</strong></p>
<p>While city leaders were in a giving mood by restoring allocations to the library, museum and arts group, this did not extend to a separate request to also provide yearly operational funding to Surry Medical Ministries. It maintains a clinic in Mount Airy which provides free medical services to people without health insurance.</p>
<p>A motion to that effect by Commissioner Jon Cawley was defeated 3-2. The board&rsquo;s Joe Zalescik sided with Cawley on the measure.</p>
<p>However, two of the three members voting against it were quick to voice support for the clinic that opened in 1993.</p>
<p>Commissioners Tom Koch and Yokeley, who were joined in their opposition by Marie Wood, said this largely involved a matter of timing.</p>
<p>Cawley sought to add Surry Medical Ministries to the list of recipients for special city appropriations at the rate of $100,000 annually.</p>
<p>Clinic officials already are seeking $200,000 in capital support from the city&rsquo;s share of American Rescue Plan Act funding for COVID relief to aid its plans for a new building to better serve patients. Cawley said the $100,000 could be used by the clinic to buy medications or meet other day-to-day needs.</p>
<p>&ldquo;I would really like to wait,&rdquo; Yokeley said of considering the annual appropriation, explaining that he believes it needs additional study, which Koch and Wood agreed with particularly in light of the clinic&rsquo;s pending American Rescue Plan Act request.</p>
<p>City Attorney Hugh Campbell also said the special appropriations involve a carefully controlled process of requirements and expectations that must be applied to Surry Medical Ministries in order for it to receive yearly funding.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110558/nadine-landry-sammy-lind-and-the-fores-to-perform-friday" title="Nadine Landry, Sammy Lind, and the Fores to perform Friday" style="color:black">Nadine Landry, Sammy Lind, and the Fores to perform Friday</a></h1>

            <a href="https://www.mtairynews.com/news/110558/nadine-landry-sammy-lind-and-the-fores-to-perform-friday" title="Nadine Landry, Sammy Lind, and the Fores to perform Friday">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128582155_web1_NadineLandry_SammyLind-511x509.jpg" alt="Nadine Landry, Sammy Lind, and the Fores to perform Friday">
            </a>
   <p class="entry-meta">June 07, 2022</p>
   <p>The Surry Arts Council will host a performance featuring Nadine Landry and Sammy Lind along with Kevin and Trish Fore at the Andy Griffith Museum Theatre, in the lower level of the Andy Griffith Museum, on Friday, June 10, at 7 p.m.</p>
<p>Nadine Landry and Stephen &ldquo;Sammy&rdquo; Lind are members of the internationally acclaimed Foghorn Stringband, out of Portland, Oregon. They play traditional fiddle music that has been passed on for hundreds of years, classics of the southwest Louisiana Cajun dance halls and songs that could have filled a 50s smoky bar jukebox.</p>
<p>Landry&rsquo;s roots lie in the rural backroads of Acadian Qu&#233;bec, and her high lonesome vocals have delighted audiences the world over. Born in Minnesota, Lind has established himself as one of the most critically acclaimed old-time fiddle players in the country. Together they play fiddle tunes, early country and Cajun songs. They play true to the roots of American music with energy and respect. They are members of the Foghorn Stringband, the Dirk Powell Band and play with Cajun extraordinaires Jesse Lege, Joel Savoy and the Cajun Country Revival.</p>
<p>Kevin and Trish Fore are steeped in the traditional music of Surry County and the surrounding area. They have learned their music directly from local tradition bearers and old home recordings; they love spending time playing for people at community events, fundraisers, fiddlers&rsquo; conventions and square dances.</p>
<p>Music featured at this concert will include Landry and Lind performing songs and tunes as a duo and will be joined by the Fores to feature many signature tunes from the Round Peak tradition such as &ldquo;Sally Ann,&rdquo; &ldquo;Lonesome Road Blues,&rdquo; and &ldquo;Breaking Up Christmas&rdquo; just to name a few.</p>
<p>Tickets are $10 and may be purchased in advance or at the door prior to the show if available.</p>
<p>For additional information or to purchase tickets, visit www.surryarts.org, call the Surry Arts Council office at 336-786-7998 or email Marianna Juliana at marianna@surryarts.org.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110554/three-summer-concerts-this-weekend" title="Three summer concerts this weekend" style="color:black">Three summer concerts this weekend</a></h1>

            <a href="https://www.mtairynews.com/news/110554/three-summer-concerts-this-weekend" title="Three summer concerts this weekend">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128582150_web1_catalinas140525105.jpg" alt="Three summer concerts this weekend">
            </a>
   <p class="entry-meta">June 07, 2022</p>
   <p>Jim Quick &#038; The Coastline will start a weekend filled with music at the Blackmon Amphitheatre on Thursday. The Catalinas will take the stage on Friday and Kids in America will play on Saturday. All three shows will begin at 7:30 p.m.</p>
<p>Pulling from the threads of soul, blues, R&#038;B, and Americana, Jim Quick and Coastline weave together their own genre of music known as Swamp Soul. Delivered with precision by frontman Jim Quick and his band, this group captures the true, honest spirit of traditions born and bred in the small southern towns of America.</p>
<p>The Catalinas always play a variety of music that suits all ages. Though known for Beach Music, regionally and nationally for the mega-hit &ldquo;Summertime&rsquo;s Callin&rsquo; Me,&rdquo; The Catalinas play all styles to a high standard of excellence.</p>
<p>Kids in America is a high-energy, power-packed, ultra-fun, six-piece band paying tribute to the totally awesome 1980s. Kids in America covers all genres from this timeless decade including new wave, pop, dance, rock, hair metal, and sing-along iconic ballads. Kids in America specializes in recreating the 80s visually and musically by delivering authentic sound with a vivid show for your favorite 80s hits.</p>
<p>Each concert will begin at 7:30 pm on Thursday, Friday and Saturday. Admission to each show is $15 or a Surry Arts Council Annual Pass. Children 12 and younger are admitted free with an adult admission or annual pass. The Dairy Center, Whit&rsquo;s Custard, and Thirsty Souls Community Brewing will be at the concerts to provide food, snacks, drinks, beer, and wine for purchase. No outside alcohol or coolers are allowed to be brought into the Amphitheatre area. Those attending are asked to bring a lounge chair or blanket to sit on.</p>
<p>Tickets are available online at www.surryarts.org, via phone at 336-786-7998, or at the Surry Arts Council office at 218 Rockford Street. For additional information, contact Marianna Juliana at 336-786-7998 or marianna@surryarts.org</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110552/local-garden-tour-scheduled-saturday" title="Local garden tour scheduled Saturday" style="color:black">Local garden tour scheduled Saturday</a></h1>

            <a href="https://www.mtairynews.com/news/110552/local-garden-tour-scheduled-saturday" title="Local garden tour scheduled Saturday">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128581455_web1_Tour-thiss.jpg" alt="Local garden tour scheduled Saturday">
            </a>
   <p class="entry-meta">June 07, 2022</p>
   <p>A chance to visit beautiful gardens &mdash; while also supporting efforts to make public spaces more attractive in that regard &mdash; will be offered to area residents Saturday.</p>
<p>The Mount Airy Blooms tour will feature 10 different stops, including gardens of eight local homes. Those sites can be visited between 10 a.m. and 4 p.m. on Saturday, with the event to be held rain or shine.</p>
<p>At one of the tour locations, the Blue House of the Gilmer-Smith Foundation at 615 N. Main St., Master Gardener demonstrations are planned and vendors also will be present there.</p>
<p>The tour is presented by Mount Airy garden clubs. It is held every other year, according to one of the organizers, Anne Webb.</p>
<p>Tickets for the tour cost $20 and can obtained at Webb Interiors on West Lebanon Street, Mount Airy Visitors Center downtown, Eventbrite.com or the various home sites involved on Saturday, including those of:</p>
<p>&#8226; Carla Kartanson at 1119 N. Main St.;</p>
<p>&#8226; Herb Mason, 1202 Crescent Drive;</p>
<p>&#8226; Bonnie and Lane Hawks, 1301 N. Main St.;</p>
<p>&#8226; Kate and Mark Appler, 216 Robin Road;</p>
<p>&#8226; Debbie and Dennis Williams, 120 Greenbriar St., No. 1;</p>
<p>&#8226; Sue and Ronnie Kirkman, 129 Ashton Court;</p>
<p>&#8226; Judy and Lee Mills, 183 Lindsay Creed Lane;</p>
<p>&#8226; Capria and Pete Smith, 676 Matthews Road, Pilot Mountain;</p>
<p>In addition to those locations and the Blue House, the comfort station on Main Street is listed as a tour site.</p>
<p>Proceeds from the Mount Airy Blooms tour will benefit several appearance projects locally, including the rose garden at Joan and Howard Woltz Hospice Home and restoration of grounds at the historic Moore House.</p>
<p>Proceeds also are targeted for the maintenance and upkeep of the mini-garden and fountain at the junction of North Main and Renfro streets and maintenance of the pollinator garden on South Main Street near the Municipal Building.</p>
<p>Another beneficiary will be exceptional children&rsquo;s classes at B.H. Tharrington Primary School, for which special programming is to be provided.</p>
<p><strong>Tour details</strong></p>
<p>With the event to be held regardless of the weather, no refunds will be given, according to guidelines issued by organizers.</p>
<p>Well-supervised children ages 6 and older are welcome on the tour, with a ticket required for each.</p>
<p>No animals will be allowed, except service dogs.</p>
<p>Strollers, cars or motorized wheels are not permitted in the gardens, which also lack handicapped access.</p>
<p>No photography or sketching will be allowed at the sites.</p>
<p>When parking at homes, tour participants are urged to be courteous and park only along paved streets.</p>
<p>Restrooms will not be accessible at homes on the tour, with public facilities available in downtown Mount Airy at the comfort station and visitors center.</p>
<p>The Mount Airy Blooms tour is supported by various businesses, individuals and organizations including the local Garden Gate, Modern Gardeners and Mountain View garden clubs.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110547/workshops-a-highlight-of-fiddlers-convention" title="Workshops a highlight of fiddlers&#8217; convention" style="color:black">Workshops a highlight of fiddlers&#8217; convention</a></h1>

            <a href="https://www.mtairynews.com/news/110547/workshops-a-highlight-of-fiddlers-convention" title="Workshops a highlight of fiddlers&#8217; convention">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128581775_web1_Fiddle-Workshops-2206-9623-565x509.jpg" alt="Workshops a highlight of fiddlers&amp;#8217; convention">
            </a>
   <p class="entry-meta">June 07, 2022</p>
   <p>As part of the 50th Anniversary of the Mount Airy Blue Grass and Old-Time Fiddlers Convention this year, Surry Arts Council held increased the number of workshops it held this year &mdash; bringing in some new sessions and courses for fans.</p>
<p>Twenty-two musicians led 39 workshops from Tuesday through Friday at Veterans Park. The heat drove the workshops from the grandstand into the VFW Building during most of the week but on Friday, overcast skies permitted some of the workshops to be held outside.</p>
<p>Traditional music enthusiasts of all ages from North Carolina and beyond attended the workshops. Some took notes, some took videos, and several hundred just watched carefully and learned new songs and new techniques. There were more young people than ever before attending the workshops ensuring that the traditions will be preserved and passed on.</p>
<p>All these extra workshops were made possible with a grant to the Surry Arts Council from the Department of Natural and Cultural Resources and Come Hear NC, and a subgrant to Veterans Park Inc from the Grassroots Program of the North Carolina Arts Council. </p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110546/police-reports-579" title="Police reports" style="color:black">Police reports</a></h1>
   <p class="entry-meta">June 06, 2022</p>
   <p>&#8226; A Cana, Virginia, woman has been victimized by three crimes in Mount Airy involving the obtaining of property by false pretense, according to city police reports. </p>
<p>It came to light Friday that an unknown party had used the stolen debit card of Tania Beketov Yopp of Wards Gap Road to buy items at the Sheetz convenience store on Rockford Street and two businesses on Carter Street, Harbor Freight Tools and Big Lots, which constitute felonies. No loss figures were listed for the incidents.</p>
<p>&#8226; Sandy Vestal Hutchens, 77, of 135 Plantation Lane, was arrested last Thursday on a charge of sexual battery which had been filed on May 3 through the Surry County Sheriff&rsquo;s Office with Austin Speer of Toast Road as the complainant and no other details listed.</p>
<p>After being served with a warrant in the case by city officers, Hutchens was released on a written promise to appear in Surry District Court on July 8.</p>
<p>&#8226; A break-in of a motor vehicle occurred on May 29 at the residence of Tammy Lynn Pell on Jones School Road, where property identified as Easy Glide 32-gauge pen needles and miscellaneous makeup items were removed from her 2005 Hyundai Elantra that was unsecured at the time.</p>
<p>The property loss totaled $30.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110542/magnet-school-grads-hailed-as-trailblazers" title="Magnet school grads hailed as trailblazers" style="color:black">Magnet school grads hailed as trailblazers</a></h1>

            <a href="https://www.mtairynews.com/news/110542/magnet-school-grads-hailed-as-trailblazers" title="Magnet school grads hailed as trailblazers">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128582370_web1_Magetize-this-1.jpg" alt="Magnet school grads hailed as trailblazers">
            </a>
   <p class="entry-meta">June 06, 2022</p>
   <p>DOBSON &mdash; They might be small in number, but graduates of Surry Online Magnet School were told that their impact has been huge.</p>
<p>&ldquo;You have trailblazed your way through education,&rdquo; Kristin Blake, the principal of the school with Trailblazers as a mascot said to members of its Class of 2022 during their commencement ceremony Friday afternoon in Dobson.</p>
<p>&ldquo;And everybody here today is proud of what you have accomplished,&rdquo; Blake added during the gathering also attended by about 90 family members and friends of the graduates.</p>
<p>The name Trailblazers not only fits Surry Online Magnet School&rsquo;s unique format compared to other institutions, allowing students the option of completing a high school education via strictly online means &mdash; stressing personalized learning through unique, flexible opportunities desired for various reasons.</p>
<p>It also applies to the fact that Friday&rsquo;s graduation program was just the second in the history of the school that is still finding its way. This year&rsquo;s class numbered 13, compared to seven in 2021.</p>
<p>The emergence of Surry Online Magnet School during the Pandemic Era was considered groundbreaking from both a state and local standpoint.</p>
<p><strong>Continue to grow, speaker urges</strong></p>
<p>It was appropriate that someone who was a key part of Surry Online Magnet School&rsquo;s development was the special commencement speaker, Dr. Terri Mosley, a Surry County Schools retiree who is a former principal of North Surry High among other roles.</p>
<p>Mosley also is an eight-year member of the Surry County Board of Education who was chairing that body when the unique campus without a campus was founded.</p>
<p>And while Mosley congratulated its latest batch of graduates for their achievement Friday, she said during her address that their education should continue long after leaving with diplomas in hand.</p>
<p>&ldquo;The real class is life,&rdquo; Mosley said while pointing out that the graduates already had shown their character through community activities and other means. &ldquo;While you were not perfect along the way, remember the job of learning is lifelong.&rdquo;</p>
<p>If the seniors remember nothing else from her remarks, Mosley said she hoped it would be her message Friday afternoon that along with continuing to focus on their ABCs they shouldn&rsquo;t forget the three Cs &mdash; change, choices and consequences.</p>
<p>In making the point about change, the speaker cited a statement from Gandhi, who said that individuals must be the change that they want to see in the world.</p>
<p>Mosley advised the Class of 2022 that the stage is now set for it &ldquo;to change the world for the better.&rdquo;</p>
<p>Regarding choices, she hopes the departing seniors will make more good ones than bad, with the consequences part of the three Cs highlighting the need to hold oneself accountable for his or her actions.</p>
<p>&ldquo;As you take your walk down Memory Lane, take time to say thanks to those who helped you throughout that process,&rdquo; Mosley concluded.</p>
<p>The seniors repeated a pledge during the program in which they vowed to view their diplomas as a sacred trust and &ldquo;strive to bring honor to myself and my school.&rdquo;</p>
<p><strong>Well on their way</strong></p>
<p>Due to the unique circumstances that characterize the lives of some Surry Online Magnet School class members, they already have gotten a taste of the adult world, said Blake, the principal.</p>
<p>This has included holding down full- or part-time jobs to support their families while also pursuing a diploma, she explained.</p>
<p>Their already hefty accomplishments will be joined by more in the future, according to Blake, who mentioned that two of the 13 graduates will be attending four-year colleges or universities, eight will take the community college route, two will be receiving vocational training and one is directly entering the workforce.</p>
<p>The fact that they have reached this point while overcoming challenges posed by COVID-19 is a special achievement in itself, the principal indicated.</p>
<p>&ldquo;As we know, these last few years have been really hard.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110512/east-surry-grads-ready-for-the-next-chapter" title="East Surry grads ready for the next chapter" style="color:black">East Surry grads ready for the next chapter</a></h1>

            <a href="https://www.mtairynews.com/news/110512/east-surry-grads-ready-for-the-next-chapter" title="East Surry grads ready for the next chapter">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128582407_web1_DSC_0495.jpg" alt="East Surry grads ready for the next chapter">
            </a>
   <p class="entry-meta">June 06, 2022</p>
   <p>PILOT MOUNTAIN &mdash; &ldquo;Pressure creates diamonds&rdquo; was a theme of East Surry&rsquo;s graduation ceremony for the Class of 2022.</p>
<p>A variety of obstacles during &ldquo;these uncertain times&rdquo; were piled on top of the usual trials of high school, testing 126 seniors in ways much different that many that came before them. The June 3 ceremony inside David H. Diamont Stadium commemorated the graduates&rsquo; resilience and brought to a close this portion of their lives.</p>
<p>&ldquo;The metamorphic change we have all undergone in the last four years has been genuinely remarkable,&rdquo; said Senior Class President Samuel Whitt. &ldquo;Shy, timid freshmen have blossomed into confident, strong seniors, ready to take on the world with fervent vigor and zeal. We have grown not only athletically, academically and artistically, but have experienced tremendous personal growth and development.&rdquo;</p>
<p>The Class of 2022 didn&rsquo;t just scrape by in what Samuel referred to as the &ldquo;masked elephant in the room.&rdquo; They thrived, and many diamonds were created thanks to the myriad of challenges the class overcame.</p>
<p>According to Principal Shannon DuPlessis, the following statistics apply to East Surry&rsquo;s Class of 2022. Of the 126 graduates:</p>
<ul>
<li>74% plan to further their education after high school</li>
<li>60% will be enrolled in a 2-year or 4-year college or university</li>
<li>9% plan to enter the workforce</li>
<li>4% plan to join one of the branches of the military</li>
<li>6% have other plans after graduation</li>
<li>24 have a weighted GPA of 4.0 or higher</li>
<li>78 will graduate with a cumulative GPA of 3.0 or higher</li>
</ul>
<p>As of Friday, East Surry&rsquo;s 2022 graduates had been awarded more than $1.5 million in scholarships and grants.</p>
<p>Following Whitt&rsquo;s speech, Cardinals Sarah Taylor, Kaitlyn Wall, Mattison Wall, Sabrina Wilmoth and Riley Yard performed &ldquo;Landslide,&rdquo; by Fleetwood Mac.</p>
<p>Then came time for the presentation of diplomas. It was at this time that East Surry also recognized two particular students for their superlative academic accomplishments.</p>
<p>Rose Jeanette &ldquo;Rosie&rdquo; Craven was honored as the Class of 2022&rsquo;s salutatorian. Craven attained the second-highest cumulative grade point average in the class: a weighted GPA of 4.65.</p>
<p>Cooper Wayne Motsinger was honored as the Class of 2022&rsquo;s valedictorian. Motsinger attained the highest cumulative grade point average in the class: a weighted GPA of 4.76.</p>
<p>Cooper returned to the stage after all diplomas had been handed out. As student body president, Motsinger was privileged to give a speech at graduation; a speech, he joked, that he tried to ignore when running for the position the previous year.</p>
<p>Glancing out at a packed Diamont Stadium, Cooper admitted he was stepping out of his comfort zone by giving the speech. However, he used it to analogize the struggles he and his classmates overcame during their time at East Surry.</p>
<p>&ldquo;Whether it be through stepping out of your comfort zone to adjust to online learning during the COVID-19 pandemic or physically stepping up to the plate to help put East Surry in a state championship game, each of you have gotten here by being uncomfortable in one way or another,&rdquo; he said. &ldquo;I&rsquo;m sure most of you have been on the receiving end of a signature Mrs. D death glare, so I know you know that feeling of being uncomfortable. In all seriousness, for that reason, being here today is an incredible achievement, and I want to congratulate you all on making it this far.&rdquo;</p>
<p>As his speech came to a close, Cooper provided encouraging words to his fellow graduates as they prepare to embark on their new journeys.</p>
<p>&ldquo;Today is a day that you probably won&rsquo;t ever forget,&rdquo; he said. &ldquo;It marks the end of a large chapter of your life, and a new one awaits you after you toss that hat. For better or worse, you won&rsquo;t ever hear that first period bell or Coach Hart yelling about some amendment from the other side of the school ever again. Our days on the field and in the student section are gone, and so are the nights trying to get an essay done before 11:59 p.m. But, the relationships and memories that we have formed here will last us a lifetime.</p>
<p>&ldquo;I cannot wait to read each of your next chapters, and I wish you the best of luck with whatever you decide to write in them.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110511/dobson-to-host-welcome-to-medicare-event" title="Dobson to host &#8216;Welcome to Medicare&#8217; event" style="color:black">Dobson to host &#8216;Welcome to Medicare&#8217; event</a></h1>
   <p class="entry-meta">June 06, 2022</p>
   <p>DOBSON &mdash; It&rsquo;s great to have Medicare available, but persons who are preparing to sign up for the government-run health insurance program &mdash; or know someone who is &mdash; might be confused about where to begin.</p>
<p>An event planned Thursday in Dobson could provide such guidance.</p>
<p>The &ldquo;Welcome to Medicare&rdquo; session to be presented by the Surry County Seniors&rsquo; Health Insurance Information Program (SHIIP) is designed to help affected members of the public navigate what organizers call the complicated &ldquo;Medicare Highway.&rdquo;</p>
<p>The program is scheduled from 1 to 2:30 p.m. at the N.C. Cooperative Extension office at 915 E. Atkins St. in Dobson.</p>
<p>Seats can be reserved at 336-401-8025.</p>
<p>Topics to be covered include Medicare basic benefits, Medicare supplemental plans, Medicare Advantage plans and prescription drug plans.</p>
<p>One needn&rsquo;t be on the road to Medicare to attend Thursday&rsquo;s session, which is open to everyone. This includes those caring for someone or with a family member on Medicare, who could benefit from the information provided by the Seniors&rsquo; Health Insurance Information Program.</p>
<p>It is part of the N.C. Department of Insurance.</p>
<p>The national Medicare program primarily provides health insurance coverage for Americans who are 65 and older, but also for some younger people with disability status.</p>
<p>It began in 1965 under the Social Security Administration and now is operated by the Centers for Medicare and Medicaid Services.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110508/she-digs-the-past" title="She digs the past" style="color:black">She digs the past</a></h1>

            <a href="https://www.mtairynews.com/news/110508/she-digs-the-past" title="She digs the past">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128574381_web1_Katelyn-Badgett-382x509.jpeg" alt="She digs the past">
            </a>
   <p class="entry-meta">June 06, 2022</p>
   <p>DOBSON &mdash; Katelyn Badgett of Mount Airy, a former Surry Community College student, is traveling the nation and unearthing its history every day.</p>
<p>Badgett graduated from Surry Central High School and then attended Surry Community College to start her college education. She was able to complete most of her general education courses at SCC before transferring to Appalachian State University.</p>
<p>&ldquo;Surry gave me what I needed before I moved on to a four-year college. Classes were cheaper, and the financial aid office was super helpful,&rdquo; she said. Badgett received a scholarship from Surry Community College that she was able to use when transferring to Appalachian State.</p>
<p>At Appalachian State, Badgett completed a Bachelor of Science in archaeology with a minor in history. While a student at ASU, she worked in an archaeology lab under Dr. Cameron Gokee as a lab technician. She received hands-on experience organizing artifacts that he brought back from his work in Senegal, Africa.</p>
<p>Badgett works as an archaeological field technician for Environmental Research Group&rsquo;s Cultural Resource Department. While the company is headquartered in Baltimore, Maryland, she spends the majority of her time traveling for work along the East Coast.</p>
<p>&ldquo;I&rsquo;ve been to some pretty interesting places. I mostly work on military bases, so I&rsquo;ve seen a lot of historic military sites and old homesteads that were there before the bases,&rdquo; says Badgett.</p>
<p>Eventually, she wants to earn a master&rsquo;s degree to open up further opportunities in her career field. &ldquo;I&rsquo;d like to either teach or work in a museum one day. I also really want to learn more about biological anthropology, because it&rsquo;s another concentration that I was interested in while attending college,&rdquo; says Badgett.</p>
<p>Badgett looks back at her time at Surry Community College fondly. &ldquo;I always recommend Surry to the younger generation. I missed the flexibility of SCC when I transferred. I had been able to work to pay for college and have Fridays off for studying and finishing homework. Also, if you&rsquo;re the type of person who wants to go into a specialized field, you can earn a degree in a short time and get your life going.&rdquo;</p>
<p>Badgett and her family have deep roots in Surry County and stay highly involved in the community. She worked at 13 Bones Restaurant in Mount Airy to pay for college and is the Color Guard instructor for North Surry High School&rsquo;s marching band. Her sister, Bailey, attended SCC for both electronic engineering technology and criminal justice. Her father, Paul, also earned a degree in criminal justice at Surry. </p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110506/wayne-farms-holds-clean-up-day" title="Wayne Farms holds clean-up day" style="color:black">Wayne Farms holds clean-up day</a></h1>

            <a href="https://www.mtairynews.com/news/110506/wayne-farms-holds-clean-up-day" title="Wayne Farms holds clean-up day">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128576503_web1_wayne-farm.jpg" alt="Wayne Farms holds clean-up day">
            </a>
   <p class="entry-meta">June 05, 2022</p>
   <p>DOBSON &#8211; The week of Earth Day saw Wayne Farms employees living up to their &ldquo;Amazing Starts With Me&rdquo; motto, holding a Dobson Complex Cleanup, then undertaking a joint effort uniting the Dobson Sustainability Team with city workers to spruce up the town and maintain common areas. </p>
<p>Wayne Farms Dobson was title sponsor for the Town of Dobson&rsquo;s annual Dobson Spring Folly, a town-square community fair held in conjunction with Earth Day and featuring local business and merchant booths, food, games and prizes for hundreds of local attendees. </p>
<p>The Wayne Farms booth showcased company sustainability initiatives and career opportunities, complete with games and prizes focused on sustainability, recycle/reuse and other eco-friendly themes. The company also recently upgraded the local plant complex to be more energy-efficient, installing new EV Car Charging Stations at the facility as part of Wayne Farms Dobson&rsquo;s ongoing effort to bolster sustainability, support community priorities. and encourage environmentally responsible corporate and individual practices at work and in everyday life. </p>
<p>&ldquo;It was great to see our people out there making things better as part of the community where we live,&rdquo; said Matthew Wooten, Wayne Farms Dobson complex manager and long-time community leader. </p>
<p>&ldquo;We&rsquo;re proud to do our part and we had a lot of fun doing it,&rdquo; said Stephanie Reynolds, one of the Wayne Farms Dobson organizers.</p>
<p>Dobson&rsquo;s approach to sustainability is part of Wayne Farms&rsquo; larger mission of sustainable operations under its &ldquo;Amazing Starts With Me&rdquo; organizational tenant. Focused on producing quality products, responsible stewardship of resources, humane treatment of animals, supporting employees and championing communities, the company said it has a long history of partnering on local causes. Community support in the form of financial aid, food products and volunteer labor is central to the company&rsquo;s operating ethos, including assistance for local social service agencies and community organizations.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110504/nester-hosiery-wins-sustainability-award" title="Nester Hosiery wins sustainability award" style="color:black">Nester Hosiery wins sustainability award</a></h1>

            <a href="https://www.mtairynews.com/news/110504/nester-hosiery-wins-sustainability-award" title="Nester Hosiery wins sustainability award">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128572544_web1_Nester-hose-thiss.jpg" alt="Nester Hosiery wins sustainability award">
            </a>
   <p class="entry-meta">June 05, 2022</p>
   <p>The need for sustainability is discussed often these days, and a Mount Airy sock manufacturer has received statewide recognition for making that happen within its operations.</p>
<p>This involved Nester Hosiery recently being presented with a 2022 Manufacturing Leadership Award for Sustainable Manufacturing by the North Carolina Manufacturing Extension Partnership.</p>
<p>The award program of that organization highlights companies for their commitment to the state&rsquo;s industrial sector, as proven by outstanding performance in the areas of manufacturing excellence, sustainable manufacturing, innovation, workforce development and economic development/developing markets.</p>
<p>Nester Hosiery is a leading U.S. producer of performance merino wool socks and the parent company of the Farm to Feet sock brand.</p>
<p>&ldquo;Sustainability is one of Nester Hosiery&rsquo;s core tenants and we continually strive to improve our processes and systems to be the best global citizen we can be,&rdquo; Anna Draughn, the company&rsquo;s director of merchandising, said in a statement.</p>
<p>For example, in 2020 Nester Hosiery used 393,229 less kilowatt-hours of energy than it did in 2019 thanks to a number of energy-reduction programs including an air leak detection initiative on which it partnered with Surry Community College.</p>
<p>By identifying and repairing air leaks throughout Nester Hosiery&rsquo;s production processes, it is estimated that the company could save 16,000 kilowatt-hours.</p>
<p>Along with reducing its plastic and cardboard usage, Nester has a strong internal recycling program and encourages employees lacking access to curbside recycling to bring recyclable materials from home.</p>
<p>In 2020, Nester Hosiery diverted 212.22 tons of those materials from the local landfill.</p>
<p>The company received formal recognition for its manufacturing excellence through such efforts at an awards ceremony in Durham in late May during an event called MFGCON.</p>
<p>It is known as North Carolina&rsquo;s premier industrial conference that features the most up-to-date and relevant topics among influential manufacturing &ldquo;thought leaders&rdquo; in the state.</p>
<p>Nester Hosiery markets itself as the designer and manufacturer of the most innovative socks in the world, a key producer in the outdoor industry operating state-of-the-art knitting, finishing and packaging equipment to make premium outdoor performance socks.</p>
<p>It does so for leading outdoor brands and retailers as well as under its own Farm to Feet brand.</p>
<p>Nester Hosiery strives to have customers value the company&rsquo;s manufacturing capabilities along with its commitment to social and environmental responsibility, while being an important employer and economic driver for this area.</p>
<p>The North Carolina Manufacturing Extension Partnership is the official representative of the MEP National Network in North Carolina.</p>
<p>That network is a unique public-private partnership that delivers comprehensive, proven solutions to U.S. manufacturers, fueling growth and advancing domestic production. </p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110495/timekeepers-of-history" title="Timekeepers of history" style="color:black">Timekeepers of history</a></h1>

            <a href="https://www.mtairynews.com/news/110495/timekeepers-of-history" title="Timekeepers of history">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128572454_web1_Army.jpg" alt="Timekeepers of history">
            </a>
   <p class="entry-meta">June 05, 2022</p>
   <p>As time pushes forward, our collective technology advances at an ever-growing speed. Each year, new phones, computers, apps, and more are released, deeming their predecessors obsolete. It is so hard to stay ahead of the technology curve that many consumers have adopted the &ldquo;if it&rsquo;s not broke don&rsquo;t change it&rdquo; rule.</p>
<p>These advancements have also discarded some technologies and training as unnecessary. Craftspeople and workers such as cobblers, seamstresses, milliners, and watchmakers/repairmen are not as common as they once were. Mount Airy has a long history of these forgotten trades and arts, especially watchmaking.</p>
<p>Watches have been dangled from and worn on our bodies for centuries. The term &ldquo;watch&rdquo; appears in a multitude of documents through the years. For example, sailors and hunting parties took turns on &ldquo;watch.&rdquo; Many cities and towns also had watchmen, whose job it was to keep time for the community. This profession helped to keep work shifts running smoothly; they served as one big community alarm clock.</p>
<p>Some sources suggest that the first portable watches appeared sometime in the 15th century. These spring-driven watches needed to be wound in order to keep time. Issues such as accuracy and longevity drove horologists, a term used to describe individuals who work on timepieces or apparatuses professionally, to continue tinkering with the technology of the mechanisms themselves.</p>
<p>The late 18th century saw new technologies invented that aided in the cutting and manufacturing of time structural pieces that make watches work. Wristwatches entered the scene early, with Queen Elizabeth the first being gifted an arm watch in 1571, however wristwatches as we know them were not that common until military men began to wear them just after the First World War. Imagine, having to pull out a pocket watch on the battlefield.</p>
<p>After this time, almost everyone would have had a timepiece, and it was no easy job keeping the mechanisms working. At one time, after WW2, Mount Airy alone had more than 21 watchmakers. One of the more famed watchmakers from Mount Airy was Foye Lester Dawson (1923-2006).</p>
<p>Dawson owned and operated his own watch shop on Virginia Street in Downtown Mount Airy. Dawson&rsquo;s Watch Repair Shop was in operation for 34 years. Inside you could see him with eyes sharp, working diligently over a timepiece illuminated by the work lamp he kept on his desk.</p>
<p>Dawson learned the horology trade through the North Carolina School of Watchmaking in Greensboro. After WW2 the U.S. Army offered training in various occupations for disabled veterans, watchmaking being one of those programs. He began his long career working in another shop for 23 years before venturing out on his own. His career in the watchmaking business lasted for 57 years. He was the longest, as well as the last, licensed watchmaker in Mount Airy.</p>
<p>While finding watchmakers on your Main Street is now uncommon, they still can be found. Several organizations still teach the art of horology, training up a generation of makers. The American Watchmakers-Clockmakers Institute is dedicated to continuing the long history of horologists in the United States. North Carolina also has two chapters of the National Association of Watch and Clock Collectors that hold meetings to keep this history alive.</p>
<p><em>Emily Morgan is the guest services manager at the Mount Airy Museum of Regional History. She and her family live in Westfield. She can be reached at eamorgan@northcarolinamuseum.org or by calling 336-786-4478, extension 229. </em></p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110485/bluegrass-convention-marks-50th-year" title="Bluegrass convention marks 50th year" style="color:black">Bluegrass convention marks 50th year</a></h1>

            <a href="https://www.mtairynews.com/news/110485/bluegrass-convention-marks-50th-year" title="Bluegrass convention marks 50th year">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128579803_web1_contestants.jpg" alt="Bluegrass convention marks 50th year">
            </a>
   <p class="entry-meta">June 05, 2022</p>
   <p>The Mount Airy Bluegrass and Old Time Fiddler&rsquo;s Convention is often described by many as a family reunion of sorts, with folks from up and down the East Coast, as well as across the nation and even a few from other lands, descending on the town during the first weekend of June.</p>
<p>Once in Mount Airy, they gather, laughing and joking, telling stories, playing in jam sessions, catching up with one another. Many consider their fiddler&rsquo;s convention buddies good friends, even though this might be the only time of year they see one another.</p>
<p>That was no different this past weekend, when the convention celebrated its 50th anniversary at Veterans Memorial Park. But there was something different this time as well &mdash; plenty of folks visiting who had never been to the event.</p>
<p>&ldquo;We used to go to Union Grove,&rdquo; said Butch Bost, who was strumming his guitar with friend Kenny Garren, who was playing a banjo. There, over the Memorial Day weekend, tens of thousands of musicians and fans would often gather, but over the years those crowds dwindled, and about a decade ago the festival closed down.</p>
<p>&ldquo;We&rsquo;ve had friends who used to go to Union Grove who come here, to Mount Airy,&rdquo; he said, adding that they had encouraged Bost and Garren to visit the Granite City.</p>
<p>&ldquo;He finally retired,&rdquo; Bost said, motioning toward his lifelong friend, Garren. So, the two, who live in Fuquay-Varina, decided to visit the Mount Airy fiddlers&rsquo; convention this year.</p>
<p>&ldquo;We&rsquo;ll be back,&rdquo; he said, adding the two had been impressed with the atmosphere and the musicians in Mount Airy.</p>
<p>&ldquo;We just saw it advertised online,&rdquo; said Tom Weierick. He and his wife, Jenn, were sitting among music fans Saturday, while their three children &mdash; Genevieve, Veronica and Juliet &mdash; took turns sitting in their laps, crawling down to play, and climbing along the bleachers.</p>
<p>The family, from Cary, drove in Friday evening to take in the concert that night and the rest of the convention on Saturday. &ldquo;We just thought we&rsquo;d drive up and see it,&rdquo; he said. &ldquo;It&rsquo;s been really great. We&rsquo;ve enjoyed it.&rdquo;</p>
<p>First-timers were not limited to fans and casual musicians &mdash; many of those taking part in the various contests had never been to Mount Airy, either.</p>
<p>&ldquo;I don&rsquo;t know,&rdquo; said Margo MacSweeny, a 12-year-old from Floyd, Virginia, who had just stepped off the stage after competing with her banjo, when discussing her reason for traveling to Mount Airy. &ldquo;Mac just asked me if I wanted to go and compete, and I figured why not?&rdquo;</p>
<p>The &ldquo;Mac&rdquo; is Mac Traynham, a music teacher who works at the Handmade Music School at the Old Country Store in Floyd.</p>
<p>&ldquo;I&rsquo;ve been teaching there for three years,&rdquo; he said, making the offer of accompanying several of his students to Mount Airy each spring. None took him up on it until this year, when Margo decided to visit the convention to play.</p>
<p>Dakota Karper, from Capon Bridge, West Virginia, was in town to compete as well, and this was her first time at the Mount Airy gathering, although in her case there was more than just playing which brought her to town.</p>
<p>&ldquo;I had this fiddle made in Kentucky,&rdquo; she said, holding a nice, new instrument she had just used on stage during the musical competition. &ldquo;I could drive all the way to Kentucky to get it, or, since he was coming to the convention, I could just meet him here and get it.&rdquo;</p>
<p>The drive was worth it, she said.</p>
<p>&ldquo;This is really a nice convention. I&rsquo;ll be back again, for sure.&rdquo;</p>
<p>Even one of the local volunteers helping staff the musician event was a first-timer.</p>
<p>&ldquo;I&rsquo;ve never done this before,&rdquo; said Wanda Crabb, who along with Bobbie Easter were selling t-shirts and other wares for the festival, serving as information guides and helping those who were in town for the event.</p>
<p>&ldquo;I have thoroughly enjoyed being here,&rdquo; she said in between laughs and jokes shared with friends and strangers alike. &ldquo;The people here, everyone I&rsquo;ve talked to, are so friendly and nice.&rdquo;</p>
<p>With all of the first-time visitors joining the regulars, convention organizer Doug Joyner said on Saturday the event had been a good one.</p>
<p>&ldquo;It&rsquo;s been great,&rdquo; he said. &ldquo;The weather&rsquo;s been good, just about perfect, we&rsquo;ve had a lot of people who come every year coming back this year.&rdquo; Last year, he explained many of them were not able to travel to Mount Airy because of COVID-related travel restrictions. The year before, of course, the event was cancelled.</p>
<p>&ldquo;They started coming in last Thursday and Friday,&rdquo; he said of the fans who came in with campers and set up for several days of living at the park. He meant the last Thursday and Friday in May &mdash; more than a week before the festival officially began. &ldquo;We&rsquo;ve had a good crowd.&rdquo;</p>
<p>The results of the convention&rsquo;s musical and dance competition were not available at press time, but will be published in an upcoming edition of The Mount Airy News. For more information on Surry Arts Council workshops held during the convention, see page B2 of today&rsquo;s paper.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/110478/police-reports-578" title="Police reports" style="color:black">Police reports</a></h1>
   <p class="entry-meta">June 04, 2022</p>
   <p>&#8226; Damage has been caused to a large downtown mural, according to Mount Airy Police Department reports.</p>
<p>It was discovered last Saturday at The Easter Brothers mural in the Jack A. Loftis Plaza rest area on North Main Street, where an unknown party climbed the wall containing it and caused paint to chip off the artwork.</p>
<p>The damage was put at $50, with the victim of the injury to real property case listed as Mayberry Trading Post, a business adjoining the plaza where the mural is located on the side of its building.</p>
<p>&#8226; Ramiro Valadez-Guzman, 45, of 958 Newsome St., was arrested Monday on a first-degree trespassing charge after police responded to a civil disturbance call at the Chili Rojo restaurant on Newsome Street.</p>
<p>He allegedly refused to leave that establishment after being banned by management personnel and was held in the Surry County Jail under a $200 secured bond. The case is set for the June 13 session of District Court.</p>
<p>&#8226; Hibbett Sports on Rockford Street was the scene of a larceny on May 23, when Nike Vapormax tennis shoes valued at $140 were stolen from the store by an unknown suspect.</p>
<p>&#8226; Ricky Mitchell Sheets, 36, listed as homeless, was jailed under a $30,000 secured bond on May 22 on felony charges including threatening an executive legal official and interfering with an electronic monitoring device, which had been filed in Wake County on May 18.</p>
<p>Sheets was located by city officers at an Arlington Heights Lane location and fled on foot after being confronted by them only to be taken into custody on Porter Street, arrest records state. That led to an additional charge of resisting, delaying or obstructing a public officer, with Sheets scheduled to be in District Court in Dobson next Tuesday.</p>
<p>&#8226; Anthony James Mangine, 56, of 1630 Mount Herman Church Road, was served on May 22 with an outstanding warrant for a felony charge stemming from his alleged assault of another man with nunchucks on May 15, which caused severe lacerations.</p>
<p>This was reported at the home of the victim, Nicholas Richard Martin of Factory Street, where Mangine hit Martin in the face and body with the martial arts striking weapon, police records state.</p>
<p>Mangine, who is accused of assault with a deadly weapon inflicting serious injury, was released on a $2,500 unsecured bond to appear in Surry District Court on June 13. An incident report filed on May 15 stated that Martin also had assaulted Mangine with a deadly weapon, but no record could be found of any charge issued against him.</p>
<p>&#8226; Joseph Tyrone Norman, 63, of 341 W. Virginia St., was charged with two counts of larceny on May 19 stemming from incidents at the Aldi supermarket on State Street, where he allegedly took five Black Angus ribeye steaks valued at $74, and Walmart, involving unspecified merchandise worth $113, with restitution owed in both cases.</p>
<p>Norman, who was taken into custody in the vicinity of the two stores on West Stewart Drive near Park Drive, was confined in the Surry County Jail under a $1,500 secured bond and slated for a June 13 appearance in District Court.</p>
</article>

</div></div></ul><div class="alm-paging">Pages: <span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583">1</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/2">2</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/3">3</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/4">4</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/5">5</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/6">6</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/7">7</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/8">8</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/9">9</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/10">10</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/11">11</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/12">12</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/13">13</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/14">14</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/15">15</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/16">16</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/17">17</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/18">18</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/19">19</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/20">20</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/21">21</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/22">22</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/23">23</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/24">24</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/25">25</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/26">26</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/27">27</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/28">28</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/29">29</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/30">30</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/31">31</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/32">32</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/33">33</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/34">34</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/35">35</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/36">36</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/37">37</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/38">38</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/39">39</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/40">40</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/41">41</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/42">42</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/43">43</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/44">44</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/45">45</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/46">46</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/47">47</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/48">48</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/49">49</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/50">50</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/51">51</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/52">52</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/53">53</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/54">54</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/55">55</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/56">56</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/57">57</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/58">58</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/59">59</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/60">60</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/61">61</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/62">62</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/63">63</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/64">64</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/65">65</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/66">66</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/67">67</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/68">68</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/69">69</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/70">70</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/71">71</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/72">72</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/73">73</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/74">74</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/75">75</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/76">76</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/77">77</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/78">78</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/79">79</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/80">80</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/81">81</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/82">82</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/83">83</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/84">84</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/85">85</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/86">86</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/87">87</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/88">88</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/89">89</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/90">90</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/91">91</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/92">92</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/93">93</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/94">94</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/95">95</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/96">96</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/97">97</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/98">98</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/99">99</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/100">100</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/101">101</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/102">102</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/103">103</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/104">104</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/105">105</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/106">106</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/107">107</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/108">108</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/109">109</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/110">110</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/111">111</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/112">112</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/113">113</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/114">114</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/115">115</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/116">116</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/117">117</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/118">118</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/119">119</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/120">120</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/121">121</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/122">122</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/123">123</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/124">124</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/125">125</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/126">126</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/127">127</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/128">128</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/129">129</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/130">130</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/131">131</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/132">132</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/133">133</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/134">134</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/135">135</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/136">136</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/137">137</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/138">138</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/139">139</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/140">140</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/141">141</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/142">142</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/143">143</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/144">144</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/145">145</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/146">146</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/147">147</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/148">148</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/149">149</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/150">150</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/151">151</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/152">152</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/153">153</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/154">154</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/155">155</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/156">156</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/157">157</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/158">158</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/159">159</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/160">160</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/161">161</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/162">162</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/163">163</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/164">164</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/165">165</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/166">166</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/167">167</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/168">168</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/169">169</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/170">170</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/171">171</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/172">172</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/173">173</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/174">174</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/175">175</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/176">176</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/177">177</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/178">178</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/179">179</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/180">180</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/181">181</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/182">182</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/183">183</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/184">184</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/185">185</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/186">186</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/187">187</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/188">188</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/189">189</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/190">190</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/191">191</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/192">192</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/193">193</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/194">194</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/195">195</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/196">196</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/197">197</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/198">198</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/199">199</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/200">200</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/201">201</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/202">202</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/203">203</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/204">204</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/205">205</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/206">206</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/207">207</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/208">208</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/209">209</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/210">210</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/211">211</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/212">212</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/213">213</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/214">214</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/215">215</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/216">216</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/217">217</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/218">218</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/219">219</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/220">220</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/221">221</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/222">222</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/223">223</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/224">224</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/225">225</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/226">226</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/227">227</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/228">228</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/229">229</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/230">230</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/231">231</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/232">232</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/233">233</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/234">234</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/235">235</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/236">236</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/237">237</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/238">238</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/239">239</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/240">240</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/241">241</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/242">242</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/243">243</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/244">244</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/245">245</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/246">246</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/247">247</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/248">248</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/249">249</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/250">250</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/251">251</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/252">252</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/253">253</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/254">254</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/255">255</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/256">256</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/257">257</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/258">258</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/259">259</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/260">260</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/261">261</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/262">262</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/263">263</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/264">264</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/265">265</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/266">266</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/267">267</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/268">268</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/269">269</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/270">270</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/271">271</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/272">272</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/273">273</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/274">274</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/275">275</a></span><span class="page"><a href="https://www.mtairynews.com/news/110793/police-reports-583/page/276">276</a></span></div></noscript><div class="alm-btn-wrap" style="visibility: hidden;"><button class="alm-load-more-btn more " rel="next" type="button">Next Article</button></div></div>	
		</div>

		 		<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-13" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Weather</span></h4><div class="textwidget custom-html-widget"><div style="width: 300px;"><iframe style="display: block;" src="https://cdnres.willyweather.com/widget/loadView.html?id=100630" width="300" height="228" frameborder="0" scrolling="no"></iframe><a style="height: 20px;position: relative;margin: -20px 0 0 0;text-indent: -9999em;display: block;z-index: 1" href="https://mtairynews.com/weather" rel="nofollow">mount airy weekly forecast</a></div>

<ins data-revive-zoneid="10" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-31" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><p>
<ins data-revive-zoneid="123" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p><p>
<ins data-revive-zoneid="124" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p><p>
<ins data-revive-zoneid="125" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p><p>
<ins data-revive-zoneid="126" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p></div></div><div id="custom_html-2" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="1" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>--->
</div></div><div id="custom_html-39" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Video</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="152" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
<script async src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script></div></div><div id="custom_html-4" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="2" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>--->
</div></div><div id="custom_html-15" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="97" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-17" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="112" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-6" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="3" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>--->
</div></div><div id="custom_html-24" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Poll</span></h4><div class="textwidget custom-html-widget"><script type="text/javascript" src="https://www.civicscience.com/widget/jspoll/?elt=130efe3f-8872-9e24-3d0a-f08413db6479&amp;tgtid=0ea95aa6-abf0-e1a4-91f4-4a6b1d2e6b5e"></script>
<div id="130efe3f-8872-9e24-3d0a-f08413db6479"></div></div></div><div id="custom_html-40" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recipe of the Day</span></h4><div class="textwidget custom-html-widget"><!-- APG TN/NC/VA; Recipe Of The Day -->

<div id="ahm-rotd" class="ahm-rotd" style="display: inline-block; vertical-align: top;max-width:365px;width: calc( 100% - 310px ); min-width: 300px;"></div><div style="display: inline-block; margin: 0 auto; width: calc(100% - 375px); min-width: 300px;"><div style="margin: 0 auto; vertical-align: top;height: 250px; width: 300px; background: #666;width: 300px; min-height: 50px;" id="_snup-rtdx-ldgr1"></div></div>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':

new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],

j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=

'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);

})(window,document,'script','dataLayer','GTM-ML7VZQM');</script>
</div></div><div id="custom_html-8" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="4" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>---></div></div>	</aside>

	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-2 mh-widget-col-2 mh-footer-2-cols  mh-footer-area mh-footer-1">
<div id="media_image-2" class="mh-footer-widget widget_media_image"><a href="https://mtairynews.com"><img width="300" height="29" src="https://s24476.pcdn.co/wp-content/uploads/2018/09/mtairynews-300x29.png" class="image wp-image-65276  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://s24476.pcdn.co/wp-content/uploads/2018/09/mtairynews-300x29.png 300w, https://s24476.pcdn.co/wp-content/uploads/2018/09/mtairynews.png 374w" sizes="(max-width: 300px) 100vw, 300px" /></a></div></div>
<div class="mh-col-1-2 mh-widget-col-2 mh-footer-2-cols  mh-footer-area mh-footer-4">
<div id="custom_html-27" class="widget_text mh-footer-widget widget_custom_html"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Contact</span></h6><div class="textwidget custom-html-widget"><b>Phone:</b><br>
336-786-4141<br>
<b>Fax:</b><br>
336-789-2816<br>
<b>Address:</b><br>
319 N. Renfro Street,<br> 
Mount Airy NC, 27030</div></div><div id="custom_html-36" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script></div></div></div>
</div>
</footer>
	<div class="mh-footer-nav-mobile"></div>
	<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-77700" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77700"><a href="https://www.mtairynews.com/terms-of-use">Terms Of Use</a></li>
<li id="menu-item-87777" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87777"><a href="https://www.mtairynews.com/cookie-policy-us">Cookie Policy (US)</a></li>
<li id="menu-item-87778" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-87778"><a href="https://www.mtairynews.com/privacy-statement-us">Privacy statement (US)</a></li>
<li id="menu-item-87779" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87779"><a href="https://www.mtairynews.com/disclaimer">Disclaimer</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			&copy; 2018 The Mount Airy News		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<!-- Google Tag Manager -->
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-WCB7NXP');</script>
	<!-- End Google Tag Manager --><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"mtairynews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"110793 https:\/\/www.mtairynews.com\/news\/110793\/police-reports-583","disqusShortname":"mtairynews","disqusTitle":"Police reports","disqusUrl":"https:\/\/www.mtairynews.com\/news\/110793\/police-reports-583","postId":"110793"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/comment-reply.min.js?ver=5.3.12'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var megamenu = {"timeout":"300","interval":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/megamenu/js/maxmegamenu.js?ver=2.9.7'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/wp-embed.min.js?ver=5.3.12'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var alm_localize = {"ajaxurl":"https:\/\/www.mtairynews.com\/wp-admin\/admin-ajax.php","alm_nonce":"f4fd92bb2c","rest_api":"https:\/\/www.mtairynews.com\/wp-json\/","rest_nonce":"63e20e63fe","pluginurl":"https:\/\/www.mtairynews.com\/wp-content\/plugins\/ajax-load-more","speed":"200","ga_debug":"false","results_text":"Viewing {post_count} of {total_posts} results.","no_results_text":"No results found.","alm_debug":"","a11y_focus":"1","site_title":"Mt. Airy News","site_tagline":"Mount Airy News, Obituaries, Classifieds, and Sports"};
var ajax_load_more_vars = {"id":"ajax-load-more"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/ajax-load-more/core/dist/js/ajax-load-more.min.js?ver=5.5.2'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/ajax-load-more-seo/js/alm-seo.min.js?ver=1.9.3'></script>
</body>
</html>